Battery drain in deep suspend (linux)

following instruction on: Framework Laptop - ArchWiki and verified by the first screenshot, it’s already in s3 deep suspend yet the battery still drained by a lot. Any suggestion?

Hibernate. You can setup suspend-then-hibernate in systemd, which is what I’ve done (if you use Gnome or KDE, they also probably have a similar setting). Within the first hour, if I open up my laptop, it resumes from deep sleep. After that, it goes into hibernation.

1 Like

I’m using btrfs and LUKS so there would some major hoops for me:

I use LUKS and LVM and I have a permanent encrypted swap partition. Here’s the output of lsblk --fs:

NAME                FSTYPE      FSVER    LABEL UUID                                   FSAVAIL FSUSE% MOUNTPOINTS
├─nvme0n1p1         vfat        FAT32          CE97-A2AC                               484.9M     0% /boot/efi
├─nvme0n1p2         ext4        1.0            29a28b41-66a3-43d5-a12e-2ce7caee35b4    210.6M    47% /boot
└─nvme0n1p3         crypto_LUKS 2              2d863699-934d-405e-8426-599194680765                  
  └─nvme0n1p3_crypt LVM2_member LVM2 001       1nibv0-bYTl-58tb-fLjx-wjDi-EqzY-hBrRZv                
    ├─Crypto-Root   ext4        1.0            89988034-bff9-4cf7-9274-3eefde2e7a37     65.8G    23% /
    ├─Crypto-Home   ext4        1.0            c8832fe8-1b53-4181-a766-4788393fc25a     85.3G    17% /home
    └─Crypto-Swap   swap        1              1f22c4d7-69fb-4f13-bf11-7db04d657baa                  [SWAP]

I don’t know if BTRFS complicates things, though.

I managed to get it working by following arch wiki (helpful as always). Essentially it’s a swapfile and the fstab simply contains:

/path/to/swapfile none swap defaults 0 0

the kernel parameter is a bit annoying, needs btrfs_map_physical for resume_offset calculation, just follow arch wiki