BIOS guide

Hey Animesh, I tried running your script and it did successfully reboot into BIOS. I afterwards tried to update again using both fwupdmgr and using the software app, and no longer get the failed to read EFI variable error, however after what seems like a successful install and reboot, my firmware version still is sitting at 03.02, so it doesn’t seem to be applying it.

Well, after using it yesterday afternoon, I closed the lid for a few hours, and now it appears to be bricked. Exact same issue as this guy posted in another thread…October 12, 2021 - YouTube

I may be using it incorrectly since I’m not confident it’s completely irreversible damage yet, but at this point I’m unable to do anything with it and temporarily it’s unusable. I can’t access bios and no keys work, it’s in a restart loop with fan coming on loud.

I get the exact same results after physically removing the NVMe drive from the laptop. Restart loops with the fan noise loud.

update: I’ve been opening and closing the laptop for a few minutes with some pressure and it now booted back up normal!!! Now that I’m in, I want to securely update bios. Any other things to check

3 posts were split to a new topic: Battery degradation

Any insight into CPU Flex Override setting?

I’ve got no real clue what the valid range is, nor specifically any idea what will increase battery savings.

Grateful for any insight; best I can tell is it should be between 35 and 48?

3.5 Ghz standard, 4.8Ghz max turbo?

Is that correct?

Mine is currently set to 30, and it still turbos to the same upper threshold.

I would like to make the processor run as low as the minimum speed for as long as possible before clocking up. Can this setting do that?

Windows 10 maximum battery mode does not do enough about keeping the CPU running slow on my batch 5.

@Ben_R Your best bet is to give ThrottleStop a shot. I used it when I forgot my power adapter and was working at our out-of-state office with only a 30w charger. It helped me get through the day. You can get it here. I have honestly no idea how to use it, but this link should help. I just ham handly messed with it to result in it helping the CPU from going nuts. Good luck and enjoy the EXTRA HOURS!

1 Like

The release notes for 3.03 include the Known Issue “System cannot recognize Thunderbolt 3 devices after resuming from S4.”

Is this still a known outstanding BIOS problem? I’m seeing this problem on the current 3.07 BIOS. Whenever I wake my Framework from S4 I need to unplug and replug my TB3 dock.

True enough. I know it’s still a problem, but I’m wondering if Framework knows it is still a problem (and if they are working on fixing it).

Is there a reason the BIOS Password is restricted to 10 characters?

10 byte seems a rather arbitrary value. Perhaps so because it can (the number of characters you typed) fit on the window that pops up to prompt you.
Perhaps a bit like this
enter password: [*********_]
Wow. this look oldschool. I like it.


Is there a way to determine the BIOS version (like 3.07) within the BIOS?

1 Like

You’ll find it on the front page.

I stole this screenshot from @jeshikat’s first post:


If you strip off the GFW30 part, you’ll get the version number Framework uses.


I could also check the BIOS version on a terminal on my Fedora 35 with dmidecode.

$ sudo dnf install dmidecode
$ sudo dmidecode -s bios-version

Just to add another answer in this series, you can find the version in windows by getting the “run” dialog with windows + R, then type in “msinfo32” and hit enter. This will bring up system information, which has BIOS version a little ways down. (see attached screenshot)

(edit: forgot to paste said screenshot, oops)


Thank you very much for the 3 version! :slight_smile:


To add a fourth (and redundant) solution, you can run sudo cpu-x -N and look at the Motherboard tab :slight_smile:


I have two M2 SSD drives that I use with my Framework laptop, one with Manjaro and one with Windows. My Framework laptop is currently on BIOS 3.02 is it safe to upgrade the BIOS from within the Windows install and then plug my Manjaro SSD back in and boot as normal?

i’ve even done it from the efi partition of my (only) linux ssd. you’ll be fine.

1 Like