BIOS guide

@Patrick_Corey I didn’t get an email for some reason, at least not one that I noticed. I bought my laptop a while ago and have been signed up for email alerts and newsletters since August. Not sure if I missed it or something bugged out. If there are meant to be email alerts, I will keep my eye out next time.

I’m in batch 2,and did not receive an email about the new bios either. They seemed to have sent it out only to later batches shipped with 3.06.

Everyone should be included in bios updates info.

Do we have an “always on USB charging” or similar thing? Or are USB ports always “always on”?

Another batch 2 baby here. I didn’t receive an email either, fwiw.

I too have never gotten an email about Bios upgrades. I am a batch 2 DIY customer. I have 3.07 because I browse this forum. I do think all customers should be getting bios update notices by default.

1 Like

@ImaxinarDM @CraigO @David_Mischel You can see BIOS 3.07 + Windows 10 and (11 Alpha) driver bundle - #91 by Duane_Johnson .

1 Like

Oh yea, understood @junaruga. And thanks. I was piping up in case the company was gauging whether there was a problem in email comm.


sorry if I’ve missed this information somewhere else, but has anyone from FW commented on adding memory XMP support so we can use some tighter latency memory?

It is not forthcoming, it is an Intel restriction with Framework unable to support it


is there another post with some more details about the specifics of this? is it a restriction in this model of CPU specifically? or does supporting it require some compromises in some way that FW isn’t willing to do? other laptops certainly have this ability so it can’t be intel across the board or impossible.

Text is for filler, please reference the above quote

thanks for the link. i’ll continue discussion there.

1 Like

Does anybody else receive this error?

“failed to read EFI variable: Error opening file /sys/firmware/efi/efivars/OsIndications-8be4df61-93ca-11d2-aa0d-00e098032b8c: No such file or directory”

If you’re using base distributions, chances are they do not automatically mount the efivars.

Try running this

mount -t efivarfs efivarfs /sys/firmware/efi/efivars

and then running whatever you want to do with the efivars.

If the mount works and you want to make the mount permanant (auto-mount at every boot) add this to the /etc/fstab:

efivarfs /sys/firmware/efi/efivars efivarfs defaults,nosuid,nodev,noexec 0 0

If mount didn’t happened with former command probably the system is booted in MBR/Legacy mode, (create backup first and) try formatting the SSD to GPT/UEFI and install OS again. UEFI is pretty much standard now a days, most probably you might just not have efivars mounted.

Hi Animesh,

Thank you for the reply! It appears that it is already mounted. When I run the mount command…

mount: /sys/firmware/efi/efivars: efivarfs already mounted on /sys/firmware/efi/efivars

Any other suggestions?

Thanks again,


I’m not so sure then, but if kernel and bios are at latest, all the supported efivars should be right there.

Where else would you suggest I go to troubleshoot? I figured this thread would be the best place.

My exact error “failed to read EFI variable: Error opening file /sys/firmware/efi/efivars/OsIndications-8be4df61-93ca-11d2-aa0d-00e098032b8c: No such file or directory”

@warehows123 hey, I just got my framework yesterday, and I see the OsIndications file is not present in the efivars, but if I write to it creating a new one, the changes are actually reflected. That is, if i run, it does reboot into BIOS.

Hey Animesh, I tried running your script and it did successfully reboot into BIOS. I afterwards tried to update again using both fwupdmgr and using the software app, and no longer get the failed to read EFI variable error, however after what seems like a successful install and reboot, my firmware version still is sitting at 03.02, so it doesn’t seem to be applying it.

Well, after using it yesterday afternoon, I closed the lid for a few hours, and now it appears to be bricked. Exact same issue as this guy posted in another thread…October 12, 2021 - YouTube