Blender 3.0.0 viewport flickering

Hi, i installed the Blender 3D Software and when using it, the 3D viewport is flickering. according to some forums this is because of the graphic driver … they suggest to either downgrade or upgrade.

does any one have an idea on how to configure Blender for the framework or how to up or downgrade the graphic driver?


Are you on Linux or Windows? If on Windows look at the latest Beta BIOS post. It has updated drivers for Windows 10 that specifically update the graphics driver. Make sure to upgrade the BIOS as well. it has a number of nice new features.

Hi, thanks for the answer and sorry i was not specific enough, i run on Linux Fedora35 (one of the recommended distro) and i did the BIOS firmware upgrade you mentioned

Is there a way to finetune the graphic driver on FEDORA35 to try various configuration to better tune the system for blender in order to e.v. avoid the flickering?

The Framework laptop is using “ Iris Xe Graphics”.
Here is the graphics detail via the bash command lshw

description: VGA compatible controller
product: TigerLake-LP GT2 [Iris Xe Graphics]
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0he
version: 01
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list fb
configuration: depth=32 driver=i915 latency=0 mode=2256x1504 visual=truecolor xres=2256 yres=1504
resources: iomemory:600-5ff iomemory:400-3ff irq:190 memory:605c000000-605cffffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

It appears Intel shows how to enable the graphics in Ubuntu 20.04.1 as the default kernel is not enabled by default.
The default kernel provided in Ubuntu 20.04.1 does not provide a kernel driver for the Intel Iris Xe graphics adapter. To enable that graphics adapter, you need to configure the system to use the linux-oem-20.04 kernel.

You can follow the steps provided in this web article:

I checked my own desktop install (Ubuntu 21.10) has the following kernel packages installed:
The following additional packages will be installed:

linux-firmware/impish-updates,impish-updates,now 1.201.3 all [installed,automatic]
linux-generic-hwe-20.04/impish-updates,impish-security,now amd64 [installed]
linux-headers-5.13.0-19-generic/impish,now 5.13.0-19.19 amd64 [installed,automatic]
linux-headers-5.13.0-19/impish,impish,now 5.13.0-19.19 all [installed,automatic]
linux-headers-5.13.0-22-generic/impish-updates,impish-security,now 5.13.0-22.22 amd64 [installed,automatic]
linux-headers-5.13.0-22/impish-updates,impish-updates,impish-security,impish-security,now 5.13.0-22.22 all [installed,automatic]
linux-headers-generic-hwe-20.04/impish-updates,impish-security,now amd64 [installed,automatic]
linux-image-5.13.0-19-generic/impish,now 5.13.0-19.19 amd64 [installed,automatic]
linux-image-5.13.0-22-generic/impish-updates,impish-security,now 5.13.0-22.22 amd64 [installed,automatic]
linux-image-generic-hwe-20.04/impish-updates,impish-security,now amd64 [installed,automatic]
linux-modules-5.13.0-19-generic/impish,now 5.13.0-19.19 amd64 [installed,automatic]
linux-modules-5.13.0-22-generic/impish-updates,impish-security,now 5.13.0-22.22 amd64 [installed,automatic]
linux-modules-extra-5.13.0-19-generic/impish,now 5.13.0-19.19 amd64 [installed,automatic]
linux-modules-extra-5.13.0-22-generic/impish-updates,impish-security,now 5.13.0-22.22 amd64 [installed,automatic]

I have not download the application, but I will try later in the week.

Any tip for FEDORA35? the output from the lshw command … i hope there is a trick :slight_smile:

description: VGA compatible controller
product: TigerLake-LP GT2 [Iris Xe Graphics]
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list
configuration: driver=i915 latency=0
resources: iomemory:600-5ff iomemory:400-3ff irq:145 memory:605c000000-605cffffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

and some more fun facts from the command:
sudo apt install mesa-utils
glxinfo -B

name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: Intel (0x8086)
Device: Mesa Intel(R) Xe Graphics (TGL GT2) (0x9a49)
Version: 21.3.3
Accelerated: yes
Video memory: 3072MB
Unified memory: yes
Preferred profile: core (0x1)
Max core profile version: 4.6
Max compat profile version: 4.6
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Xe Graphics (TGL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.3.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.3.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.3.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

i also tried glxgears and when resizing the window it flickers as well … see the output below
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
304 frames in 5.0 seconds = 60.620 FPS
299 frames in 5.0 seconds = 59.796 FPS
292 frames in 5.0 seconds = 58.224 FPS

what i did so far:

created a startup shell script ( with the content below to set mesa einvironment variables. the flickering is gone but the rendering is fairly slow. i more or less choose intuitively the environment variables that might have effect on flickering. since i do not exactly know which variable is having what effect i just tried and there is still some trying to do this is where i got the variables from:

[Environment Variables — The Mesa 3D Graphics Library latest documentation]

my current startup script (, make sure you give it the right permissions (sudo chmod u+x


export LIBGL_DRI2_DISABLE='false'
export LIBGL_DRI3_DISABLE='false'
export MESA_NO_3DNOW='false'
export MESA_NO_SSE='false'

exec /usr/bin/blender "$@"

may be someone has some input on how to get the mesa variables properly
meanwhile i will try a few permutations …

the variable LIBGL_ALWAYS_INDIRECT set to true will output the following error, that one makes it clear that blender requires a specific version of OpenGL …

Error! Unsupported graphics card or driver.
A graphics card and driver with support for OpenGL 3.3 or higher is required.
The program will now close.

other from that FEDORA35 on Framework works well, this is why i choose to change the variables only for Blender

looking forward to any input and support

what i did so far:

playing with the mesa environment variables resulted in a slow blender not flickering
i started to install various version, only one is not flickering

not flickering: (fairly old version)


at this point it is fair to say that blender is far ahead of the mesa dirver’s capabilty.
the hardware Iris Xe Graphics works well with most 3d software, the full framework laptop is definitely capable to handle blender.

looking forward to new input and suggestion

1 Like

today is a great day for Framework, FEDORA35 and Blender 3.0.0
After software update The Viewport Flickering Disapeared!

now my Framework is perfect!
thanks to who ever fixed this

1 Like

from what i can tell, yes

can confirm. Fcking wonderful.

1 Like