Broken CMOS clip

I was trying to remove my CMOS battery and broke the plastic clips holding it in. Is there any fix for this besides replacing the whole motherboard?

1 Like

Why were you trying to remove the cmos?

I’ve been having issues with my computer randomly shutting down and giving me this error

I’ve tried a clean install of Windows 10 and Windows 11 and both still gave me this error until I turned off secure boot. I then tried to clean install Windows 11 and reset the motherboard by unplugging the battery and removing the CMOS battery, but broke the CMOS connector in the process.

1 Like

A boot device issue is rarely related to the CMOS battery, if it ain’t broke don’t fix it. Contact support.

1 Like

I’d talk to support, but honestly looks like something a bit of glue or tape could handle. (For the clip, not gluing the battery in!)


The plastic is probably glass filled nylon and you can’t glue that, and glue wouldn’t be strong enough anyway as the cross section of material is way too small.

However, for someone who can solder, the battery holder is easy to replace with a new on. The part is easy to find on DigiKey or similar, inexpensive (the $5 shipping will be far more than the part), and the soldering job is simple, assuming someon slightly more artful at it than the typical guy hacking on drones on youtube.

Warranty is well and truly out the door at that point, but it might be anyway from breaking the battery holder. Framework could pretty legitimately say the unit wasn’t shipped broken or defective. Which is understandably frustrating if the unit was in fact shipped defective in some other way which was causing your original problems.

If you happened to live near me I’d offer to do it just to see it done because I know how silly it would be to kill an entire motherboard with all the exotic crazy stuff that goes into a motherboard, just because of something crude and simple like a battery clip or a connector. It’s like having to throw away a Tesla because one of the a/c vent grills broke.


For anyone still viewing this in the future, carefully applied gorilla glue can work if only one arm of the clip is broken. This of course is at best a superficial solution and assumes that you don’t plan on removing the cmos again, because, as @Brian_White has said, the cross-section is too small for glue to be effective.

I had the same issue trying to replace a ML 1220 that just wouldn’t hold a charge. The plastic clips came right off when I tried to extract the battery.

I found a battery holder on DigiKey, soldered it in, and replaced the ML 1220. So far, works great.

Here’s the DigiKey part number: 36-1072CT-ND


@Michael_Meehan How do you do that can you send me an link with instructions?

I just broke mine cus the laptop didn’t start with the old one.

I haven’t seen any instructions for replacing the RTC cradle. When I broke it, I was attempting to perform the mainboard reset located here:

I broke the RTC cradle during step 5. To repair it, I soldered in a new cradle between steps 6 and 7, and then completed the remainder of the steps. The cradle has two solder points at the top and bottom, and two small plastic pins on the left and right side that help hold it in the correct orientation. Fortunately, the battery polarity is printed on the board.

The ML 1220 was definitely the problem in my case, since it never exceeded 1.7v even after charging for days. So far, the new one is working just fine.

1 Like