Can’t install anything

After some minimal distro hopping I settled on Popos. Recently I had some issues with my laptop going to sleep, so I decided to wipe the drive clean and start again. Then the debugging began. For days I tried every single distro, even Windows, 3 different USB flash drive, also a SD card. All of them failed one way or another. Some installers will simply boot into a blank screen, Federo installs but won’t boot. Popos fails on both available versions when extracting squashfs. Windows 10 installer fails with 0x8007025D while installing (it worked once on the first time but won’t boot and every time after just never completes the installation). I have tried every expansion card I have, USB C USB A Micro SD. The Type C slots recessed without a card are also all tested.

1 Like

You might want to reach out to support. Are there any LED blink codes?

I should do that huh, for the blink codes. postal code 3, 4, 6, 7 returns green instead of blue, so i guess thats not normal?

FWIW I installed Pop!_OS 21.04 without any problem (aside from realizing I needed to turn off secure boot in the bios) and subsequently upgraded to the latest 21.10 beta. I suspect a hardware-related issue in your case, unfortunately.

I feel like that’s definitely yet, I have installed Pop OS multiple times successfully on this machine along with EndeavorOS, the sudden failure suggests a hardware failure pretty strongly.

I ran memtest and a bunch of errors appeared for one of the memory modules. So for now I am going to stick with just one before I have time to start the RMA process

@Runkai_Zhang I had the same problem, did you do an RMA for the memory or for the framework laptop?

Because when I removed the 2nd stick that I had purchased recently, I was able to install Windows again and not get the 0x8007025D error. I’m just confused if this is a memory module issue or a framework laptop issue?

That was my intention, but Crucial’s website and customer support were a big pain for me and I sort of just put it off and you just reminded me I should do that.

Edit: to answer your question, yes it is for me, I ran memtest86 and oh so many errors with one of the sticks

Thanks for the quick reply!
I’ll run the memtest to ensure it was really my RAM, but given that I’m now typing this comment on my framework without that extra memory module inside it, I highly suspect that I had the same issue as you

If you can, run memtest over 10 passes. I had memory modules (not for this particular Framework purchase) that didn’t fail until the 7th pass. It was because internal temperature was taking awhile to reach thermal equilibrium with its environment…then the modules took a bit longer to fail.

That is, when you’re testing the memory, you’re not really just testing the memory for errors. You’re testing the memory as part of an integrated system in its operating environment.