Computer boots directly into bios

Hello everyone I have the Framework with the i7 1165G7. I was running Endeavor OS and I updated and rebooted, and when I rebooted, it immediately shuts off, then starts up directly into BIOS every time. I can’t seem to get it to stop doing that. I am running BIOS v3.07 right now.

1 Like

Are you able to boot into Endeavour from the boot menu in the bios or does it not let you?

1 Like

No, it won’t even get past the logo before shutting back off and then rebooting into the bios exclusively.

EDIT: by logo, I mean boot past the Framework bios logo

Perhaps it’s this:


  • check if secureboot has problems
  • check if grub needs to be reinstalled
  • check if boot options in BIOS are appropriate
  • check if startup with “F3”, which now allows manual selection of an EFI works (with the above GRUB problem, booting the grub efi probably fails)

@Nils I can’t even access any F keys when it first starts up. It simply just shows the Framework bios logo, shuts off, then reboots directly into the bios. I tried using a bootable USB and it still does the same.

Oh that sucks! It might actually be grub being totally borked. Maybe try removing the SSD and booting into the bios with no storage apparatus installed.

@Cheese I removed the ssd and that fixed it. Thank goodness because I didn’t want to have to fiddle with sending in the motherboard. You are a life-saver!


Mine is doing this right now. You removed the SSD and then reattached it?. I’m not sure what effect that would have.

Edit: I’m on Arch and realise I updated and then shut down the last time I used the laptop. This is probably not a coincidence.

Edit 2: I think we both hit this issue: Full transparency on the Grub issue (UPDATE 29-08-22) – EndeavourOS

1 Like

@Rob_Fisher yes, I removed the ssd and it booted up to the no bootable devices screen rather than the bios boot loop I was experiencing. Then I powered it back off, plugged in the ssd again and booted into a bootable usb and just installed Artix since i wasn’t really digging Endeavor anyhow, but yeah, that’s how I fixed it. I am sure there is a more clean way to fix it.

1 Like

It seems to have been an actual issue with arch and not just the FW laptop! :blush: