CPU Performance Governor

One thing I have noticed: in my install of Arch, the default CPU governor is power-save, which in my opinion is crazy aggressive. It caps core usages to half of the logical cores, and only allows turbo boosting in exceedingly short bursts, making things like multitasking effectively impossible (It’s so bad that even mouse movements are super choppy). Changing the governor to performance fixed the issue, but I thought I’d post about it in case others have issues too.


that’s really odd. what desktop environment are you using?

i leave my governor on powersave like 98% of the time i use my framework and i don’t notice any slowdowns at all. to the contrary, everything is quite smooth, even if i’m compiling code in the background.


GNOME 40. Maybe it’s something else weird with my config?

If you haven’t disabled PSR yet, definitely do that:


Just did. I’ll see if the setting it back to powersave works better this time.

I’m finding strange results in cpupower as well. It says that my frequency range is 400mhz-400mhz despite the governor I select and whenever I check frequency under load it maxes at 1.5ghz. Experiencing somewhat slower performance than I would expect but no UI stutters after PSR fix.

1 Like

That’s definitely strange. Just to confirm for folks at 400MHz, do Ubuntu 21.04 and Fedora 34 respins show normal performance? Is the issue specific to Arch?

1 Like

I’ll whip up a live usb after work and test it out, considering I haven’t seen any complaints on the other thread I’ll assume it is not a problem.

I may try and dig up a CPU benchmark and run it on ubuntu vs arch and see what’s up. Might also be good to test out the latest kernel and make sure that’s not the issue.


Did some more investigation under arch.

sudo pacman -S s-tui; s-tui

displays a super nice monitor of core usage and temps if you scroll down with the arrow keys. I was stuck at 1.2ghz on all cores for sure, twitch was lagging on one display pretty badly and vscode was very slow to do any operations.

I installed https://github.com/erpalma/throttled which describes a throttling issue affecting many modern intel bearing laptops under linux getting prematurely throttled.

According to the logs from journalctl -u lenovo_fix.service the service fails to start but another look at s-tui after reboot shows clocks all the way up to 4.0ghz on cores and settling in the 2-3.5ghz range under load.

Everything definitely feels way snappier. @nrp perhaps the issues described https://www.reddit.com/r/thinkpad/comments/870u0a/t480s_linux_throttling_bug/ and in the link above is something to be investigated by the team?


On Linux Mint xfce 20.2, kernel 5.11, with default settings haven’t had any stuttering issues, but happy to run diagnostics/benchmarks and report if it can help isolate the issue

I have experience with throttled using my current Thinkpad X1C6 (until my new Framework arrives). It made a significant difference in performance and stopped premature throttling on the laptop’s i7-8550u. I needed this for eGPU passthrough for VFIO.

According to the Arch wiki for the X1C6 Lenovo ThinkPad X1 Carbon (Gen 6) - ArchWiki, a fix has been implemented in thermald as well, but I can’t report as to that as I’ve not tried it.

1 Like

Has anyone tried this to see if it possibly would fix this issue?

I am seeing throttling to 200 MHz across all cores.

Both powertop and /proc/cpuinfo are showing 200MHz.

I have been able to get better performance a few times, but now seem to be stuck. Even boot takes almost a minute to get to the drive unlock.

This is on Ubuntu 21.04 with everything up to date.

Could you check if removing all Expansion Cards changes this behavior?

I booted with no expansion cards and it booted in seconds. Haven’t had any problems since with the cards inserted, so I am not sure which one it was. Will need to test further to verify.

1 Like

If you narrow it down to a card in a specific bay, could you try this: An Expansion Card bay on my laptop does not function correctly

Following up on this, moving the RF sticker seems to have fixed the issue for me.

In my case, it looks like the edge of the sticker was right against the legs of the IC and causing problems. The other side of the sticker had detached and was floating. I adjusted them and made sure they were stuck and haven’t had any issues since.


Can anyone else confirm this?

1 Like

After moving the sticker, I had no issues until today.

On a cold boot, it took minutes to start up and checking powertop showed everything stuck at 200MHz. Strangely not the same as the 400MHz I saw before.

Removing the micro-sd reader in the previously problematic slot immediately brought everything back to full speed.

Looking inside, the sticker did not appear to be shorting anything any longer, so I removed the sticker entirely for that slot. So far everything appears to be working well.

Here is what the sticker looked like while causing a problem.

1 Like

Very interesting. By any chance what kernel are you using I’m currently on I believe 5.1.4 and don’t have the issue. Although I only got this yesterday haha.