Debian 11 on the Framework Laptop

Would ventoy work for your case? If it does, it’ll save you a lot of hassle creating the USB over and over. You just have to copy over the new iso. I believe that I first heard about it on this forum. and I’d like to thank whoever noted it here, because it has worked very well for me.


In an effort to fix my vainfo, I installed intel-media-va-driver (21.1.1+dfsg1-1), both the regular and intel-media-va-driver-non-free. Now I get:

libva info: VA-API version 1.14.0
libva error: vaGetDriverNameByIndex() failed with invalid VADisplay, driver_name = (null)
vaInitialize failed with error code 3 (invalid VADisplay),exit

Does anyone get a different output when running vainfo? Is there a different driver/s I ought to install instead or in addition to that? Thank you in advance.

ETA: link, text, vainfo update.

I spent more than I would have liked trying to install Debian 11, including some attempts inspired from this thread and from Debian 11, Gen12th : Wifi working? - #9 by disposedtrolley … then luckily I found out that was apparently updated since @John_Grow posted it (?).

Following instructions there now works like a charm. In particular, you need a recent kernel and manual download of missing i915 firmware.


Thanks for sharing your experiences. For most people, we recommend Ubuntu 22.04 or Fedora 37 as the official recommendations.

1 Like

@Pietro_Battiston how’s the system so far? I’m running Fedora 37 but I’ve had some annoying lockups lately, thinking about giving Debian a try.

After a week or so of normal use (with kernel 6.0.0-6, from backports), the system seems to work just great. Very responsive, I noticed no crashes or lockups whatsoever.

My only concern currently is that in suspend mode the laptop discharges much faster than I would have expected based on my former laptops. But I have yet to do a serious comparison with what other people posted ( e.g. Suspend on linux drains a lot of battery compared to other laptop - #26 by Matt_Hartley , Test results for standby battery use of Expansion Cards ) in order to find out if the OS is somehow to blame (or maybe the expansion cards). I will maybe do a test of Ubuntu 22.04 to see if it fares better.

By the way, the only other very minor annoyance I had was the somehow distracting automatic brightness regulation, but it can be easily disabled: "auto-brightness" aka ambient light sensor in Linux? Details? - #5 by devnull

1 Like

Also make sure you have the latest beta BIOS.

1 Like

Well, except that I hadn’t noticed hardware video acceleration is off (which does not visibly affect playback smoothness, but it does imply more heat and battery use). I experimented a bit with installing proprietary drivers (package intel-media-va-driver-non-free ) but no change: vainfo returns “vaInitialize failed with error code 3” (the error code was 5, I think, before I upgraded some packages to bullseye-backports).

No idea if this has to do with me using wayland rather than X11 (which is mentioned in the Debian page about this laptop). Or maybe with me using a later kernel than that described?

Thanks, I had missed this. Not sure when I will be brave enough to try, as it seems to be an irreversible experiment at the moment.

1 Like

It’s what we recommend. Due to resources and time, we’re focused on Ubuntu and Fedora. And despite shared bits, Debian and Ubuntu differ on a number of areas.

@Matt_Hartley I think the threads on the forum are a type of Q&A or a type of specific topic-related discussion such as Debian 11. The “Something on the Framework Laptop” threads can be spaces where diverse people who have different preferences can stay in this community. For the thread with the type of specific topic discussion, it’s weird to see “[Answered]” prefix on the title. What do you think?

Edited x2: simplifying the sentences, and correcting English grammar.

Agreed for threads of this nature. Threads marked Solved are per request higher up the chain so we can see things are indeed being, resolved.

But yes, Answered can be removed from those threads. :slight_smile:

1 Like

Sure, I understand. I feel expert and risk lover enough to at least try, my aim in this thread is definitely not to complain or discredit Framework because the Debian experience is still not smooth enough :+1: By the way, Debian names itself “The Universal Operating System”, so its aim is to support even hardware that does not support Debian :wink:

1 Like

I can understand the benefit of adding the prefix “[ANSWERED]” or “[SOLVED]” to the Q&A-type threads. I agree with the way. And thank you for removing the “[Answered]” from this specific topic-related thread.

I appreciate people staying and working to develop and maintain the Debian packages in the Debian community, and also their contributions to the upstream open source projects. Without people working for the greater good in Debian, and without a thriving Debian eco-system, Debian’s downstream Linux distros such as Ubuntu, Pop OS, and Mint cannot thrive.


Hardware acceleration worked (glxgears full screen) with X11, but it was buggy. I needed a compositor to have things look moderately right, and even then it was unreliable. I switched to Wayland (sway). I believe this is a(nother?) bug in the intel driver (and there are still some, even in Wayland). I would be surprised if this would be a kernel regression, but everything is possible!

That said, ake sure you have the latest linux-firmware package, missing that might be why you don’t have hardware acceleration. See my section on firmware blobs.

Wow, great review, thanks, I had missed it. This said, I do have the last version of firmware-linux (20221214-3), as well as firmware-linux-nonfree (20221214-3), plus the missing blobs I manually downloaded as recommended in the “DebianOn” guide (and indeed, I don’t see firmware errors in dmesg).

It might be worth mentioning that I do not have the last version of intel-media-driver, as the version from unstable or even bullseye-backports (either of the free or non-free driver) wants me to upgrade stuff like libc6, something I currently would like to avoid. So I have 21.1.1+dfsg1-1 . What version do you have?

I have not tried running Debian stable on the Framework. I would advise against it: many things are missing, and you’re going to be playing that annoying whack-a-mole game a lot.

I don’t have intel-media-driver at all, what I do have is intel-media-va-driver at version 22.6.4+dfsg1-1:

anarcat@angela:~$ dpkg -l '*intel*'
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                           Version                  Architecture Description
ii  intel-gpu-tools                1.26+git20220524-1.1     amd64        tools for debugging the Intel graphics driver
ii  intel-media-va-driver:amd64    22.6.4+dfsg1-1           amd64        VAAPI driver for the Intel GEN8+ Graphics family
un  intel-media-va-driver-non-free <none>                   <none>       (no description available)
ii  intel-microcode                3.20221108.1             amd64        Processor microcode firmware for Intel CPUs
un  inteltool                      <none>                   <none>       (no description available)
ii  libdrm-intel1:amd64            2.4.114-1                amd64        Userspace interface to intel-specific kernel DRM services -- runtime
ii  xserver-xorg-video-intel       2:2.99.917+git20210115-1 amd64        X.Org X server -- Intel i8xx, i9xx display driver
1 Like

Sorry, I mistyped. It’s intel-media-va-driver indeed, and I guess you’re right: insisting with stable is probably a lost cause.

I assumed it would be fine because Ubuntu 22.04 is several month older than Debian 11.6, but I see the guide suggests 22.04.01 (which is “only” 4 months older, from Aug 2022).

Still, I wonder what Ubuntu uses - it doesn’t even have this package in 22.04 (it does in 22.10).

Just upgraded to testing and hardware acceleration immediately worked!


see? testing is your friend. and if you wait a few months now, you’ll be running stable in no time. :wink: just make sure you use the code name (bookworm) instead of the symbolic suite name (testing)…