Debian 11 on the Framework Laptop

I got my DIY Framework recently, just wanted to open a new topic to share tips and information about its setup.

I ordered without WiFi, hard disk and memory.

I bought the following after and it all worked out of the box :

  • Crucial 32 GB memory stick (DDR4 3200) - CT32G4SFD832A
  • WD Black SN850 NVMe (1 TB) - WDS100T1X0E
  • Intel Dual Band Wireless-AC 31683rd Gen 802.11ac, Dual Band, 1x1 Wi-Fi + Bluetooth 4.2 (used) - 3168NGW

I didn’t chose the wifi card and will probably upgrade at some other time but it’s what was available at my local computer shop which carries a bunch of old used stuff.

I used scaling at .75 for fonts in Tweaks > Fonts > Scaling factor and made sure Area was ticked under Tweaks > Keyboard and Mouse > Area for the right button to work as I expected.

I am using full disk encryption and other than boot time being significantly longer than other slower systems or Ubuntu on the same system, I am satisfied with the performance.


Do you know why the boot speed is slow?

1 Like

No idea, I only ever reboot so it’s not a deal breaker for me while I test the environment during the next few days.

Good idea for a thread!

I’m also running Debian 11 on my Framework. Here were the steps I required for installation:

Install Debian

The Intel AX210 wireless card requires non-free firmware and a newer (backported)
kernel. Debian can be installed using an ethernet adapter with the netinstall image, or
alternatively use the full DVD image and manually load the required firmware after
installation using another USB drive.

Modify /etc/apt/sources.list to include non-free and backports

The Framework laptop requires non-free firmware for the AX210 wireless card to
function properly, as well as a backported kernel.


deb bullseye main contrib non-free
deb-src bullseye main contrib non-free

deb bullseye-security main contrib non-free
deb-src bullseye-security main contrib non-free

deb bullseye-updates main contrib non-free
deb-src bullseye-updates main contrib non-free

deb bullseye-backports main contrib non-free
deb-src bullseye-backports main contrib non-free

Install required firmware and backported kernel:

apt update && apt install firmware-iwlwifi firmware-misc-nonfree
apt -t bullseye-backports install linux-image-amd64

Reboot the system!

Hopefully that is helpful to someone! Debian seems to work really well on this machine.


Do you have a Wi-Fi 6 router? If yes - does everything work well for you?

1 Like

I only have a Wi-Fi 5 router.

1 Like

Let me know if you upgrade and test :slight_smile:
On my tests, the Wifi with 5.14 worked OK but sleep was broken, and in 5.12 sleep works OK but Wifi 6 disconnects every few minutes. Wifi 5 works fine though.

Mine is also slower than expected. I initially only had 32GB of memory and later upgraded to 64GB. Boot time got slower - I can only imagine it’s doing some form of memory space enumeration before starting up.

Can I ask why you chose to go with the unsigned kernel rather than the signed kernel?

Which card ? The whole point of the DIY edition is you choose your hardware. I didn’t order my wifi card from Framework so my card is a bit older and fully supported.

I have seen similar comments about both 5.12 and 5.14 kernels. My plan after reading a bunch of posts here and on reddit, was to try 5.13. I’d like to run debian 11, if I can get everything to work nicely, but plan to try various distros for fun if nothing else. My device is scheduled to arrive in 2 days, so I can try this soon myself.

So my question is, has anyone here tried debian with 5.13? If so, are either of the sleep/Wifi issues an issue?

At the time I installed it seemed to be the only option to get the 5.14 kernel but I see that is not the case, thanks for the heads up! I just installed the signed kernel.


The AX210 card that Framework offers.

If anybody is having difficulty with getting Bluetooth to work, this comment on another thread worked for me. Unfortunately, it looks like a soft reboot borks bluetooth until you power the FW off all the way and turn it back on. Not the worst tradeoff, but something to be aware of.

I’m also using the backported kernel (at time of writing, 5.14.9-2) and all the non-free firmware packages.

1 Like

You can get sound working on the Framework with Debian 11 with

apt install firmware-sof-signed

For fingerprint reader, follow the instructions in the Ubuntu thread. However, it also requires support from the desktop environment for login/unlock. Gnome supports it, but KDE doesn’t yet.

1 Like

Hi All.

Just joined the Framework/Debian 11 group yesterday. XFCE if anyone cares.

I found this thread because the wifi card was crashing my whole usb system after 20 minutes or so of uptime. Just upgraded to 5.14 and at least Im stable now. At home, I run wired through a usb 3.1 hub. I think Ill pick up a AC card soon and downgrade back to the LTS kernel. I dont think Ill run into a AX hotspot for quite awhile.

I dont care about the fingerprint reader.

I havent been able to get any external monitors working yet. I have 2 different usb c to hdmi dongles and neither work. I think Im going to have to bite the bullet and move up to a displayport or usb c monitor(s).
Any ideas on that?


Hello. Framework has the hdmi add-on card you could use, instead of using a separate dongle. As for the wifi, the one I’m using is the QCNFA222, which is supported in Debian via atheros 9k driver. So far it’s been working well, but I haven’t been able to get bluetooth working.

1 Like

Is the expansion card known to work with linux?
Im in a little over my head on this one. My desktop ran debian for years with dual monitors, but that was through the graphics card that had dual out.

My research has lead me to believe that usb c to hdmi involves a converter chip in the dongle that requires a driver. Theres a company that sells dongles called displaylink that has linux drivers available, but I dont have that brand. I dont know. Im guessing a little. My dongles both work on my android tablet, which would suggest a driver exists somehwere. Displayport seems to be a much more native usb c spec. Its probably time to upgrade.

I tried the HDMI expansion card when I got it and it works just fine (Debian sid). Since HDMI is a standard, all of the conversions should be happening in the expansion card itself (and I don’t think there need to be any special drivers?). When I plugged in a monitor (a TV in my case, since that functions as a spare monitor to test this sort of stuff), everything ‘just worked’ (including HDMI audio routing).

According to this post:

The guy who wrote some kernel module code to get it to work, says some dongles just dont work. Ive tried all the stuff he mentions in that thread.

Ive actually got 3 dongles. Ones built into my hub. I really want dual 1080p monitors when Im home, so I have a dual hmdi out dongle. I dont to tie up 2 ports with single use cards. Finding that one unicorn dual hdmi dongle that works seems like too much of a scavenger hunt to me.

If I cant have dual monitors, Id rather upgrade from 1080p and just get a new setup that has something more modern that hdmi. I was just hoping a $20 dongle would work.