Debian 11 on the Framework Laptop

Also, don’t let it discharge completely, it won’t turn on again unless you follow a bunch of steps (15m minimum). See:

1 Like

I’d like to get Debian setup on my Framework DIY. Just thought I’d summarize what I think would be needed, maybe it would help others. Does below sound right?

  1. Install using either a usb flash drive w/full Debian install image written to it OR use a usb flash drive with netinst written AND a usb ethernet adapter.

  2. For fingerprint reader, if wish to use graphical interface, use Gnome. Looks like libfprint must be 1.92.0 or greater. Correct me if I’m wrong, looks like we’d have to install that from source. See the link at the end.

  3. For Intel AX210, follow instructions for neurology_equator posted.

Blog post for getting Debian running on Framwork, the fingerprint reader part seems to be of interest.

I did have a question as to which kernel might be the better choice, reads like there might be issues with 5.12 as well as 5.14 there seem to have been reported issues with both. But it looks like anything below 5.14 is end of life.

Also concerning secureboot, looks like since Debian 10, secureboot’s worked out of the box. Looks like we wouldn’t have to mess with that option in BIOS, should just work.

Before you do anything, install Windows 10 on it and make sure you upgrade its BIOS and hard disk firmware.

That’s a good point, I had already installed the drive into a Windows machine and updated the firmware. I figured I’d go through with the bios using the EFI shell process.

What version of libinput are you running?

This is very generic - what 5.14 specifically?

This is the one that solves all my problems: 5.14.21-051421-generic (WiFi 6, fingerprint reader, sleep…).

@Carlos_Fernandez_San Did you have to compile that version? I’m not finding it in any of the Debian repositories.

5.14.0-0.bpo.2-amd64 is the highest available on the backports repository at the moment.

Make sure you have the backports repository enabled and search for linux-image and the options will show up.

Ive been exclusively on debain as my desktop for maybe 5 years…Im familiar with all this stuff on paper, but I dont usually go fiddleing unless I have to. I’d like to get back on a LTS suported kernel asap so I dont have to think about it anymore…

@Carlos_Fernandez_San t I’m searching all the packages on and not seeing anything newer than the the 5.14.0-0.bpo.2-amd64 that Ryan Horst mentioned, which looks like 5.14.9

That one doesn’t work well. For me Wi-Fi worked, but sleep/wake up didn’t.

Try this one:

Ubuntu being based on debian - with a bit of luck it will just work for you.

Im hesitant to try that. Im reading up on either making the jump to bookworm (testing) or using apt pinning to upgrade just the kernel which is up to 5.15…which is were I think I would rather be…Sleep is buggy for me, Id like to fix that, but its not a deal breaker. I think I could really care less about the fingerprint reader. If it could enter my disk encryption password, Id be into it, but 90% of the time my laptop lid is closed and Im on a dock…so I would rather type a password than open up the lid to read my fingerprint…

Why? It either works or it doesn’t. It takes a few minutes to try, and grub lets you choose between installed kernels so it’s not like if it doesn’t work it takes a lot of effort to just remove it.

I’d agree. I can’t say I particularly like the idea of installing a kernel compiled by another distro. When does it stop being Debian and become Ubuntu? Who knows what options they’ve enabled. I’d most likely either grab the source for 5.14.21, pull the config from my current Debian kernel and compile it myself, or go with pinning and install the kernel from testing.

I’ve gone to Ubuntu (21.10) as Debian 11 (still) required a lot of tweaking for HiDPI support and with external monitors I couldn’t find an acceptable configuration. This needs constant tweaking for each new app and breaks with upgrades (custom .desktop files, gconf fiddling etc.).
Blurry apps (including Firefox, Thunderbird, Signal, Telegram which I use the most), long boot time (often required because of the battery issues-still doesn’t last >1d on suspend) were all dealbreakers for me. Having heavily outdated browser and email applications also means keeping those installed manually - not practical anymore for me on this system as a daily driver.

@Darrel_Hunt I suppose you do have the backports repository enabled in Debian ? Otherwise you won’t be able to install any “bpo” packages.

See Instructions

You can trivially find out all the patches and compilation options they used.

Anyway I pointed out to what works perfectly, if you prefer to compile your own version, or wait for Debian to make a new official backport, or just suffer the old one, fine by me…

I have identified, that image: works great! :wink: just so you know, pals. :wink:

By the way, setup says, that it cannot install kernel, just skip it on base install step and proceed. When setup wants to reboot after software and grub install, select ‘go back’ and select ‘exec shell’ from main menu, and when you are in a shell:

chroot /traget ; apt install linux-image-amd64 -y ; exit ; exit and now select reboot/finish installation…


Just for your information, here are the threads to Debian unstable (sid) and testing branches

To understand Debian’s 3 kind of branches: unstable (sid), testing and stable branches, you can see the following documents.


Does anybody else has problem playing netflix on either chromium or firefox running a backported debian 11?

1 Like

Works fine for me in Firefox, but I always install the main Firefox binaries directly from Mozilla:

The Debian Chromium doesn’t have the necessary DRM decryption code for netflix, I haven’t looked into it any more as I daily-drive Firefox anyway.

1 Like

Ah, cheers. Stupid me forgot to check DRM settings. Apparently they were off by default.

On another note: Does anybody have difficulties with the function keys? (I am using KDE Plasma) and sometime the use of the function keys with “Fn” continues even after I let go of the keys themselves. E.g. it just decreases volume indefinitely until I hit ESC or any other key.

1 Like