Device Incompatibility: Kingston DataTraveler DUO

I just bought a new Kingston DataTraveler DUO for use with the Framework, specifically because it has both Type A and Type C jacks.

[  +0.033118] usb 2-3: New USB device found, idVendor=0951, idProduct=173c, bcdDevice= 0.01
[  +0.000005] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  +0.000002] usb 2-3: Product: DataTraveler Duo
[  +0.000001] usb 2-3: Manufacturer: Kingston

On my Ubuntu 21.10 system, the device disconnects/reconnects every couple seconds regardless of which port I use. I tried USB-A, USB-C on both left and right side of the machine.

dmesg shows:

[  +0.000135] xhci_hcd 0000:00:0d.0: WARN Set TR Deq Ptr cmd failed due to incorrect slot or ep state.

This same drive works in my desktop just fine, so I also tried formatting it on the desktop to see if that would make a difference. It did not.

Based on some other reports I found, I also try intel_iommu=off but to no avail.

It does work however if I instead plug it into the lapdesk hub. It only fails when it is plugged directly into the framework modules.

Other USB drives seem to work just fine (in the USB-A, I don’t have other USB-C sticks).

What kernel are you running?

I am using the 5.13.0-21-generic kernel.

You probably need to post more logs

Sure. Any particular logs you are looking for?

Looks like this is the same issue reported here and here.

I have not been able to repro with any other usb thumb drives so far.

1 Like