Dock Compatibility (AMD) - USB-C / Thunderbolt

The patch has made it into 6.8.11, which will become available to Fedora users in the coming days. I have just tried that kernel from the testing repo and can confirm that the freeze is no longer reproducible. There is still a short 7 second hang sometimes until the gpu driver logs a timeout, but other than that the permanent hang is resolved.

Matt, I feel this is kinda a bad answer. The point of most people wanting to use a dock is to avoid having to plug in more than one cable. If they just want to push USB and Ethernet there are way cheaper options, but someone that needs to plug in and unplug constantly wants a dock to unplug one cable when needed and then when back at the desk plug that one cable back in and be good.

I have a Kingston TB4 that works flawlessly with my work laptop running Manjaro and has been for well over a year. I plug in the dock to the fw16 and it no longer works. This leads me to believe that there is an overall issue with the fw16 and others are seeing it as well and the best answer we seem to get is just don’t push video through the dock. Kinda frustrating TBH.

3 Likes

I’ve had issues with a FW13 AMD and (the same?) Kensington TB4 dock. I’ve found a (fairly brittle but functional) workaround, see here upthread. Even with a pair of Apple TB4 cables involved it still breaks, so cable dependent which smells strongly of race condition to my software-biased nose.

Tracked upstream as AMDGPU driver issue here.

The kworker issue mentioned on the first link may be specific to FW13, either way workaround was found here although several of us myself included are still awaiting the root cause fix for that.

I’ll look at the kworker issue, I’ve changed the cable a couple times. For me it works if I only have one monitor, when I have two monitors I get the no EDID errors.

Hello @Matt_Hartley on my side my USB-C dock works only if I first plug :

  • Lenovo Thinkpad Laptop
  • Then plug any laptops, screen output has signal

If I reboot the USB-C dock, then the signal output vanishes for the Framework Laptop or any other (Dell Latpop or HP Laptop same issue too)

I’m suspecting the USB-C dock is sending an authentication challenge to the Embedded Controller, but I have yet to order the USB-C packet sniffer in order to confirm this hypothesis.

I see no issue with using the Thinkpad USB-C gen 2 dock other than the one I mentioned, if you have any more information to share on why it would be bad, please feel free to let us know.

This was not my experience on my side with the 13th FW AMD but my USB-C dock has an authentication challenge for HDMI/DP output it seems and can only work if I plug the proper brand of laptop (Lenovo Thinkpad).

Since this was “fixed” I’ve booted my system like 20 - 30 times, with the issue reoccurring on 3 occasions at bolt.service. Now it is much harder to reproduce and I don’t know what the issue is now.

Other rare and unreproducible issues I sometimes have with my CalDigit TS 4:

  • Everything connects fine, Fedora 40 switches to the external monitor. But it does not charge until I unplug and reconnect to the dock
  • Everything connects, charges and peripherals work fine but the external monitor is not recognized at all. In this case I need a full reboot

I have a FW13 7840U on order. I’m keen to move away from my StayGo USB-C dock (as it already crumbles under USB+Display+Ethernet).

I’m keen to upgrade to multi-monitor (high refresh rate) setup with multi-gig ethernet.

The new generation of TB4 docks seem kick-ass on paper with multi-display and 2.5G ethernet. Although they don’t clarify if they are high refresh rates

Many of them claim backwards compatibility with TB3/USB-C.

Does anyone have any experience of these:

  1. Sonnet Echo 20 Thunderbolt 4 SuperDock
  2. Plugable USB4 Dual HDMI Docking Station (UD-4VPD)
  3. Satechi Thunderbolt 4 Multimedia Pro Dock
  4. Plugable Thunderbolt 4 & USB4 Quad Display Docking Station
  5. Anker 568 USB-C Docking Station

I’m using the FW13 7640U with Ubuntu and the Caldigit ts3 plus is the best dock I’ve used so far. Haven’t had any issues so far. I got it on eBay for about $100.

I’ve tried the Anker 555 8 in 1 dock and Dell D6000 docks and they both had a lot of issues with needing to be unplugged and replugged to get both the single display and mouse + keyboard working.

I’m also making sure I’m using a good Cable Matters usb 4 cable with the Caldigit dock, since I know a lot of cables look like they’ll do 10gbps but actually only have the pins for 5gbps.

I’m using an old Dell TB16 dock, with my FW13 laptop. Running Debian.

After much trial-and-error, it’s reliably working now, but the dock needs to be connected to the laptop first, then powered on (so I take the power out every time I disconnect the laptop).

What’s more strange is that while the full displayport port does not work, my two monitors work fine if I have one linked to the mini-displayport port, and the other to the HDMI port. I’ve got the displaylink drivers installed, fwiw.

When connecting my old lenovo laptop to the dock, the full-size displayport port is working fine.

This has been working reliably for at least a week.