eGPU Not Being Detected on AMD Framework

Hey guys, not the most experienced here so looking for any ideas. I have an Aorus Gaming Box with a 2070. I have an AMD framework 7840U.

When I plug it in the thunderbolt cable, I get power, but that’s it. It does not detect the eGPU or the monitors attached to it. Typically I get a Thunderbolt popup asking what I want to do, but nothing with the Framework. I’ve tried installing Thunderbolt drivers, which gets me the control center, but nothing is detected. I’ve double checked with two other laptops that both detect it and fire up. I can’t get any of the Nvidia drivers to install because the graphics card is not detected. Any ideas on what to do next to troubleshoot?

Which of the Framework’s USB-C ports did you plug it into?

I’ve tried both of the back two (closest to the monitor hinge). As I understand it those are the 2 that support usb4.

Can you check if anything appears in device manager?

1 Like

So, I’ve gotten it part way working.

The Graphics card and USB hub are showing up as unrecognized. I can trouble shoot the problem, restart, and it detects them, then install the driver. However, if I unplug the device, I have to go through this whole process again, including reinstalling the GPU drivers.

Any ideas how to get it to recognize the device and the drivers each time I plug it in?

Looks like there’s errors, from the icons. Does it give an error code or other information in the properties?

It does not, but works semi consistently after a restart.

Not sure if this will help, but my restart solution stopped working.

After a couple more hours of troubleshooting, I was able to get it connected again by uninstalling thunderbolt drivers, reinstalling them and restarting.

It looks like some other AMD boards have had issues with Thunderbolt docks - anyone have solutions there?

Is there a way I can avoid the restart to have it detected?

(Another note is that power is always delivered, but if I plug in when the laptop is on, which I have to do as a restart works but powering on from off will not detect the eGPU, the GPU fan does not spin and I have to unpower and repower the GPU itself. It’s like the laptop is specifically telling the GPU to not run as an EGPU)

Okay, not sure anyone can really help here, but I’ll keep shouting into the void a bit longer.

I’ve played around a lot more, and I got it consistently semi-working for now.

In order to get it to work, I need to:

1.Plug in the Aorus eEGPU while the computer is on
2. Restart the computer

Once the eGPU is connected, I can use the NVIDIA system tray icon to disconnect and reconnect the eGPU, but if it is unplugged it will not work, I can only connect and disconnect it from the NVIDIA. While I’d really like to be able to disconnect/reconnect on the fly, I at least have a workflow to get it working.

However, now the USB ports on the eGPU are not working. Swapping back and forth between an Intel Laptop with Thunderbolt, there is no issue there, so I know that the ports are still technically working. Just not sending any information back to the Framework. I see the USB-C Dongle and the USB Root Hub (USB 3.0) in the detected devices, but for whatever reason they are no longer working. These ports were working previously, so if anyone has any tips on what could be done to troubleshoot this it would be appreciated!

Okay - one more update; I believe hot swap is working now!

I went and downloaded the drivers directly from AMD for the 7840u:

I had run these before, however, I did a reinstall of Windows and reinstalled the framework drivers, so maybe some order of operations piece that I unfortunately can’t document well because I’ve been trying so many things.

Now I can unplug the eGPU and replug it without restarting! Which is great.

However, still no luck on getting the USB Ports on the back of the eGPU working. It looks like they are providing power, but no connectivity. The hub still seems to be connected in device manager, but no data is actually getting through. (I’ve tried with mice, keyboards, and thumb drives. I’ve tried uninstalling the drivers, but windows won’t let me (even on administrator account) so if anyone has any ideas of how I might get this working please let me know!

Hey all, not sure if this is super helpful as I tried a bunch of things, but it’s working most of the time now. I believe the big step forward was installing the amd whql-amd-software-adrenalin-edition-23.12.1-win10-win11-dec5-rdna after installing the GeForce drives from Asus.

I still have no connectivity on the USB ports on the back, which is a bummer, as they are working fine on the windows machines that I have.