Expansion card usb A do not fit well


Recently i bough a 13 framework Labtop with one expansion card usbA. When i plugged usb key or another device my connector fit perfectly in this connector.

But today i see this isn’t the case, see photo. I can’t fit it at max deep in usbA slot and the connector on my other usb cable moves and is not stable once inserted in it.

What i did ? Idk maybe broke it ? or is it normal and i didn’t noticed it before.

Thanks for help !

Hi and welcome.

I’ll check my USB A
DONE: Yes a) it doesn’t fit that well. Like yours there’s some 3.5 mm of metal showing and the device, a cable in this case, wobbles from side to side and up and down.

I hardly ever use it. Just tried with two USB A devices
One with metal It’s is bad the cable whilst the other, a microSD to USB A plastic adapter, is a little better.

Still over two years so too late for me to complain officially.

I have the same on my USB C cards in that the plugs to not seat very far.

1 Like

Thanks for your answer. it’s seem normal but my ledger usb A cable connector do not fit well and there is some mecanics instability when plugged in. So BAD.

Otherwise this labtop is really good.

1 Like

Yes I can see it’s not the depth so much as the tolerance top bottom and sides that mean it a very poor fit.

1 Like

interesting. i didn’t notice with the usb sticks which is all i have used that port for so far.

but yeah on reading the post tried a few cables and see the same as shown above. my expansion card is part of my recently arrived fw16 so thinking a recent manufacturing

1 Like

Have noticed this on my USB-C and USB-A ports as well, perhaps it was done for maximum compatability with connectors?

1 Like

Or maybe our devices connector have an old design ?