Extremely slow startup, loss of Bluetooth, external storage not recognized

Hi everyone, I noticed that my Framework 13 running Fedora 39 is suddenly extremely slow to start. I thought perhaps it was because I had let it run out of power then it sat idle for 2 weeks while I was traveling, but I’m not sure. What is the best way to go about troubleshooting in such a case?

System info:
Fedora 39 (Workstation Edition)
13th Gen Intel Core i5-1340P x 16
Firmware Version 03.04
Windowing System: Wayland
Kernel Version: Linux 6.8.7-200.fc39.x86_64

Here is a video in case it’s helpful. You can see that it takes 15 seconds after I press the power button for an expansion card light to start flashing white, then green, then red, and stops at 0:29. The Framework logo appears at 1:28, and I’m able to enter my password for the hard drive at 1:38. I had a stopwatch running, and it took an additional 2 min 45 sec for me to reach the login screen.

The only other issue I’ve been having was that the keyboard would fail entirely from time to time, but then I’d pop out all the expansion cards, pop them all back in, and it’d be back to normal. (This temp fix was mentioned here. Not ideal, of course, but the issue is not reliably reproducible so I’m at a loss here as well.)

What other information is helpful to provide? Should I try to do a clean install of Fedora 40? Give up on Fedora entirely? (I’m flexible, as long as it’s not Windows.) Thank you so much!

EDIT (4/29): New video link. Updated title with additional issue descriptions.

Something similar to this was happening to me over the past 2 years (but I had other issues with the USB ports). I use FreeBSD primarily but I tested some stuff on Linux and on Windows as well. Recently I replaced my Intel Core i7-1165G7 CPU @ 2.80GHz (11th generation) mainboard with a new Intel Core i7-1185G7 @ 3.00GHz (11th generation) from the Framework Marketplace, and after installing it all of my USB ports worked again, all of my expansion bay cards worked, and also the system feels snappier as well (startup, bios, and general use). So I would say your mainboard may be failing or has some sort of defect similar to me. There was also a few times (I wasn’t able to reproduce it) but I did see slow start up, and then the system kinda just got stuck at boot up (black screen) but I did see those rainbow colors on the side led lights, green, red, etc.

Thank you for sharing! I’m not yet hardcore enough for FreeBSD, but since my last post, I discovered that neither my external SSD nor my USB-C flash drive are being recognized at all (via Files, lsblk, and lsusb). I bought my Framework 13 in mid-October 2023 and the keyboard failure first occurred in mid-November, so perhaps it is a hardware issue after all :cry:

Hi, I have a similar problem, but I’ve never had any problems with the keyboard.

Fedora 39 (Workstation Edition)
13th Gen Intel Core i5-1340P
Firmware Version 03.04
Windowing System: Wayland
Kernel Version: kernel-6.8.6-200.fc39.x86_64

Today I tried to turn on the laptop, but it turned out that the battery was discharged to 0% (I thought it was fully charged).
After connecting to the charger, the laptop took a long time to boot, exactly as above. After starting, the system did not detect the fingerprint reader.

I tried to turn it on after removing all expansion cards and the charger (it doesn’t matter whether it is plugged in via the expansion card or directly) - then the system starts normally (the fingerprint reader works).

However, there remains a problem when turning off the laptop - the screen goes off, but the fan works, and the keyboard and power LED are on - only holding the power button turns it off. When trying to restart from the boot menu (ctrl+alt+del), the same problem occurs.
I tried to perform Fully Resetting the Mainboard State - Framework Guides (I noticed that I have no RTC battery. Is this normal?), but it did not help.
I also moved the RAM from slot 0 to 1, then vice versa, removed the SSD drive and restarted the BIOS to factory settings, but this also did not help.

I updated to fedora 40, and now the following logs appear during startup:
DPC: RP PIO log size 0 is invalid
usb usb3-port9: unable to enumerate USB device
usb usb3-porti0: unable to enumerate USB device

I tested ports, when laptop is on(started without extension cards), and any of port don’t work with UsbA extension with pendrive. I also try connect my phone with usb cable(with and without extension) and only reaction was that phone starts charging, but with the lower left port there was no reaction.
I can charge laptop with any of ports.

1 Like

I’m curious if you maybe did a bios update? Did you have your laptop out of power for a long time? Any thing that could have caused bios settings to return to defaults?

In the bios setting there is a startup power profile option. Turbo performance is a setting that I can get sub 8 second cold boots in windows 11 with.

If I change this to something more power conservative that number changes and goes into the 40 and 50 seconds range.

Adding a few troubleshooting finds!

1. The “extremely slow startup” issue resolves itself if I power it on while it’s unplugged. Comparison videos (now collected into an album here):

  • Here is the original video, which was taken while plugged in via an expansion card (on the other side, which is not visible).
  • Here is a video of it being powered on while unplugged, with all the expansion cards taken out.
  • Here is a video of it being powered on while plugged in directly, with all the expansion cards taken out. You can see the same white/green/red light flashing pattern as in the original video.

2. The “extremely slow startup” issue (= powering it on while it’s plugged in) kills Bluetooth. If I power it on while it’s unplugged, Bluetooth works as expected. This is what it looks like:

3. My external SSD/USB-C flash drive are not recognized, regardless of how I power it on (with and without it being plugged in). However, I can charge using all 4 slots, both with and without expansion cards.

Last but not least, to answer your question @2disbetter, I don’t know how to do a BIOS update so I doubt I’ve done it. Given the differences in behavior above, would you still suspect that the BIOS is the culprit?

It is less likely for sure, but I am curious about what that setting is set to currently?

The video definitely looks it is stuck in or before post for a while so it would pretty much have to be bios or ec

Does it do the thing with a different power supply?

Can you try disabling standalone detection in the bios?

Just a few random guesses here:

  1. Please send the error code (the full sequence of the blinking LED including how often each color blinks and in which order) to support. They should have a table with the meanings of these codes, so they might be able to tell you what is going on.

  2. Guessing from the fact that it gets stuck whenever anything is plugged into the USB-C ports, including a charging cable itself, I would assume something is broken with the communication with the ports. Perhaps BIOS is trying to figure out if it can boot from one of the ports and check whether a storage medium is plugged in, which takes a long time until it fails.
    Could you go to BIOS settings and try to completely disable anything USB related, including booting from USB? It should be called “USB Boot” or something like that. Disable all that and try to boot again without any expansion cards, but with a charger plugged in.
    (also what Adrian says above, you can try to disable the detection as well)

Hi everyone, thank you so much for your expert insights! I sent this thread to Framework Support and they kindly got back to me, so I’m posting our exchange so far below (plus addressing a few points from above) for anyone else who might find it helpful:

1. When did the issue start to occur?
I first noticed the “extremely slow startup” part of the issue on April 23, 2024. I had left the laptop unplugged while I was away for a week or so, and it had died. I plugged it back in, powered it on, and noticed the issue. The “entire keyboard failing” issue started on the week of November 13, 2023. I didn’t submit a support request for this because there was a temporary fix and the issue was intermittent.

2. Were there any changes you’ve made prior to this issue?
No, not that I’m aware of. I upgraded to Fedora 39 on December 1, 2023 and did not upgrade to Fedora 40.

3. What is the current BIOS version of your laptop? You can find your current BIOS version on the first screen of your BIOS menu next to “InsydeH2O Version”, in System Information in Windows next to “BIOS Version/Date”, or on Linux by running “sudo dmidecode -s bios-version”.
I ran the command and it told me “03.04”.

@2disbetter The “Boot performance mode” was/is “Turbo performance”.
@Adrian_Joachim Unfortunately I don’t have another power supply, but I’ll try to ask around! Currently, “Standalone detection” is disabled, and “Standalone operation” is enabled.
@TomsonTom I’ve set “USB boot” to disabled.

Given all of the above settings, I’m sorry to say that the “extremely slow startup (while power is plugged in)” issue is still occurring, both with the power plugged in directly/via expansion card.

Also, a few more notes:

  • I forgot to mention that I’ve also been experiencing the “laptop won’t turn off/restart without me long pressing the power button” issue described by @Bartosz earlier. This is regardless of whether the laptop is connected to power.
  • If I power up while plugged in, pressing F12 (the Framework logo key) immediately doesn’t take me to the boot menu, so I assume this indicates that the process is getting stuck at the very beginning, before it can recognize that I want to get to the boot menu.
  • I’ve counted the lights and this is the sequence/frequency: White x1, Green x12, Red x1, Green x8

4. What is the make and model of the charger you are using on your laptop?
I’m using the leftover charger from my MacBook Pro (this is the one that perished and was replaced with my Framework 13). The block says 61W USB-C.

Can you try disabling that then?

Done, though to no avail :melting_face: However, I’ve sent the above info along to Framework Support, so I’m hoping they can decode the light sequence and provide next steps. Thank you!

1 Like

If you haven’t already tried it, I would reset the bios to the defaults, and if that doesn’t help, do a mainboard reset. Curious to hear what Support has to say.

I’ve been experiencing the same issue described by Bartosz also starting around April 25th.

Kubuntu 23.10
13th Gen Intel Core i5-1340P
Firmware Version 03.03
Windowing System: X11/Wayland(happens on both)
Kernel Version: kernel-6.0.5-generic

A few notes from my troubleshooting:

-Disabling external IO ports in BIOS seems to “solve” the issue

-the problem persists regardless of what if any drive is installed in the internal nvme slot

-plugging any usb device into the expansion bay port whether it’s an expansion card, charger, or usb drive creates the same behavior

-bootable USB drives plugged in directly or with an expansion card don’t show up in BIOS

-The speed of both POST and boot cycles are greatly reduced when something is plugged in

I’ll update as I continue to try new combinations of bios settings and usb devices

Hi @Nicholas_Shepard, it may be better if you create your own thread, then link to Bartosz’s/my posts from there in order to keep the troubleshooting separate and organized.

Hi everyone, sharing another update. Below are the instructions from Framework Support:

  1. Could we try to reset the BIOS to optimal defaults and check if this can make improvements?
  • Access the BIOS by pressing F2 during the bootup
  • Once on the BIOS page Press F9 to load the defaults
  • Press F10 to save and exit
  1. Try to see if using a live USB of Fedora or Ubuntu distros could help us isolate the issue. You can follow our guides via this link​. Please note that we won’t have to install the Linux distro, instead, we would have to run it off of the USB Drive, for us to do this, you’ll have to select “Try Linux” instead of installing it. Use the live USB distro for a certain amount of time and monitor if the issue persists.

  2. To isolate the issue with the expansion cards, please remove all expansion cards, and if you need to charge your laptop, please connect the charger directly to the laptop ports and observe within the day if the issue persists. If the laptop is stable without the expansion cards connected, please connect it one at a time to find out which expansion card is the culprit.

My answers:

  1. I was able to successfully reset the BIOS settings. I turned the laptop off, then on (attached to power source, directly plugged in without expansion cards), and the issue persisted for all 4 ports. To confirm, the issue doesn’t occur if the laptop is disconnected from power source at startup.

  2. I attempted to use a live USB, but as I mentioned previously, it is not being recognized, and I was therefore unable to complete this step. I used the expansion cards because the shape of my USB prevents it from being plugged in directly. In the “Boot Option Menu”, the only “EFI Boot Devices” I see is my internal drive (“Fedora (224546806942-WD_BLACK SN700 500GB”) which is listed twice for some reason.

I have been talking to support for the last few days.
I will finally receive a new mainboard.

1 Like

I had the same issue (from a month ago), eventually contacted support, and after many troubleshooting steps they decided to replace the mainboard (hasn’t arrived yet).

I have a Framework 13, Intel® Core™ i5-1340P, Windows and have the same slow startup + USB not working (even in BIOS) + No Bluetooth. However unlike @Agnes, my issue happens even on battery, and has fixed/broken itself twice.

@Nicholas_Shepard I tried disabling IO ports in bios, and the system now boots normally and bluetooth appears in device manager, however (as previously) it is unable to shut itself down. This option is under Security → I/O Interface (scroll all the way down) → External I/O Ports. Naturally this doesn’t fix the problem, but at least we know it’s related to the I/O Ports (support never told me to try doing this).

I think we should all post in this same thread to share information with each other, since we have similar symptoms.

Hi everyone, just me again with another update.

  1. Support asked me to test with another charger, which of course was a challenge because I don’t have multiple orphaned chargers lying around. But I manged to borrow a Dell 130W USB-C charger, and gave it a go. Issue persisted.

  2. Support asked me to do a RAM shuffle (instructions below), which I did. Issue persisted. At this point, I suggested that perhaps I also required a mainboard replacement.

Remove your sticks of RAM and then just taking one of them and installing it into Slot 0. Then, try the same with the other stick of RAM? What I mean by this is you only place one stick into Channel 0, and then try to boot, then remove that stick and move it to Channel 1, and then try to boot, then remove that stick and then try the other stick in Channel 0, etc. Finally, perform the shuffle, placing both sticks in and try to boot.

  1. Support replied and asked me to do a mainboard reset (instructions below) and send videos of the results, which I did. Issue persisted. (They also asked me to remove the two black protective sticky covers on the components and send photos of the stuff underneath.)

Mainboard reset instructions

  1. Turn off the laptop and unplug the charger.
  2. Remove the input cover and plug in the charger.
  3. Press the chassis open switch/case switch 10 times. You must press it slowly, so press for 2 seconds, release, wait for the red blink on the mainboard LED, and repeat.
  4. Press the power button to boot the system.
  5. BIOS settings will be reset to defaults.

Now I’m waiting for them to get back to me, and I hope it’ll only take a few more back-and-forths! :crossed_fingers:

@drojf I’m glad they replaced your mainboard! I hope that fixes your issues permanently. To me, it was useful that you kept all of your records in your thread (especially since you’re on Windows and I’m not), but then again, I suppose if anyone else wants actual support (as in, from the Framework team) they won’t post in the Framework Laptop 13 category and post in the Community Support category instead :sweat_smile: