F.W 16 batch 18 motherboard not starting

Running windows 10 pro./ 16 inch No track pad, keyboard, or num Pad. No lights. Nothing. I moved all modular parts to my (batch 4) everything worked. I thought it was a driver issue. I cloned the computer of the first one to batch 18 computer. Still nothing. I believe i got a bad motherboard on arrival. Nothing works in bios either. Only external devices work.

Ok, so a few things potentially at play:

  • Did you follow the Mainboard replacement guide completely?
  • Have you tried booting it with no SSD installed?
  • Have you tried booting it with only one DIMM installed (ideally, try each RAM stick in each slot)
  • How long did you let it sit before determining that it was not turning on?
  • Have you tried booting it with no RAM installed? That way, you can see if it gets to the POST code for no RAM or if it errors out before that.

If you can’t even get to BIOS, it’s not likely to be a driver or Windows issue. That said, Windows 10 is not supported on Framework Laptop 16. Windows 11 is the only supported version. Ensure you follow Framework’s install guide, as it differs slightly from normal installation.

1 Like

Im sorry if I wasn’t clear. MY ONLY GOAL is to get the keyboard, num pad and track pad working. I have tried what you suggested however the keyboard, num pad, and track pad still do not work. I can get to Bios only with external devices. Everything works except keyboard, num pad and track pad. The only reason I mentioned the Bios is that at the very least the keyboard should work in Bios. This does not happen.
Im not really sure if I need to remove the motherboard as I have an exact labtop to test everthing and doesn’t have any issues. I do need a new Motherboard sent out though so I can get back up and running. I have waited a long time to get this second one but all I can do at the moment is look at it.