F16 does not wake from sleep

I recently got my AMD Framework 16 laptop (Batch 18!) a week ago, and most (9/10) times it goes to sleep it does not wake up. The only workaround is to hold the power button untile hte laptop restarts.

I am running Fedora 40, and I believe I have everything up to date. But let me know what commands to run in my terminal to show whatever debugging information folks need.

Running amd_s2idle.py

Debugging script for s2idle on AMD systems
💻 Framework Laptop 16 (AMD Ryzen 7040 Series) (16in Laptop) running BIOS 3.3 (03.03) released 03/27/2024 and EC unknown
🐧 Fedora Linux 40 (Workstation Edition)
🐧 Kernel 6.8.11-300.fc40.x86_64
🔋 Battery BAT1 (NVT FRANDBA) is operating at 104.06% of design
Checking prerequisites for s2idle
✅ Logs are provided via systemd
✅ AMD Ryzen 9 7940HS w/ Radeon 780M Graphics (family 19 model 74)
✅ LPS0 _DSM enabled
✅ ACPI FADT supports Low-power S0 idle
✅ HSMP driver `amd_hsmp` not detected (blocked: False)
✅ PMC driver `amd_pmc` loaded (Program 0 Firmware 76.82.0)
✅ USB4 driver `thunderbolt` bound to 0000:c6:00.5
✅ USB4 driver `thunderbolt` bound to 0000:c6:00.6
❌ GPU driver `amdgpu` not loaded
✅ System is configured for s2idle
✅ NVME Sandisk Corp WD Black SN850X NVMe SSD is configured for s2idle in BIOS
✅ GPIO driver `pinctrl_amd` available
Your system does not meet s2idle prerequisites!
Explanations for your system
🚦 AMDGPU driver is missing
	The amdgpu driver is used for hardware acceleration as well
	as coordination of the power states for certain IP blocks on the SOC.
	Be sure that you have enabled CONFIG_AMDGPU in your kernel.

Can you upload the report it saved to a gist or pastebin?

You probably have nomodeset on your kernel command line. If not; then check your kernel log for why amdgpu isn’t loading.

Yes I do see nomodeset

Get rid of it. You also don’t need the sg_display parameter with newer BIOS.

1 Like

Understood. This is my /etc/default/grub

kylepdm@devtop:~/Downloads$ cat /etc/default/grub
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"

I still have the same issue related to amdgpu not being loaded. I ran the script again: gist:06596e50189090c160a13294b24c6006 · GitHub

It doesn’t look like it’s been made effective. In the script you can see it still.

Any advice or suggestions? Should I re-install Fedora (maybe 39 instead of 40?). Or is it likely some kind of hardware issue?

There is some grubby argument that rebuilds the config file in the efi system partition. You shouldn’t need to reinstall.

Hmm I think the issue embarrassingly enough was that I had an older kernel installed and removing it fixed it. I think the implication was that I was booting up with that older kernel ??

Im not sure but seems good now. gist:341f5140a111e1d37b1147330b7cd7d0 · GitHub

Removing the old kernel would have run “update-grub” that would have removed the “nomodeset”.
So I think the removing of “nomodeset”, was the actual fix, you just found a different way to apply it.
The kernel version mentioned in the logs was the same before and after.

1 Like

Thanks for the correction! Hopefully if anyone is facing a similar issue now they will know all they had to do was

  1. Upgrade the Kernel
  2. Run update-grub

This laptop is running noticeably smoother, and all my issues around not waking from sleep have been resolved.