Fedora 34 on the Framework Laptop

@Alan_Ning Thank you, I just installed and restarted and I hope it will change something.
Do you know if this issue also caused a bunch of v-sync errors when updating the display?

@Jerry. That, I don’t know. This is day 2, and I am still testing the laptop. I wonder if we should all pool in our experience in a wiki page or something (like the arch wiki, but for Fedora).

1 Like

I think for the greater good of the laptop and the future fedora users, it would be a great idea. Maybe we can even resolve issues or get some we have known out there that aren’t just happening to framework users. It’s only day 2 for me as well.

UPDATE: After installing grub-customizer and inserting the “i915.enable_psr=0” into the general settings and rebooting, my vertical sync issue (which was apparent all throughout the screen whenever my display updated) as well as my computer freezing has hence ceased.

Just a note that the first post on this thread is actually a wiki post, so you can add updated fixes there.


@Michael_Lingelbach Thanks for the great review. Seeing your comment Community reviews - #9 by Michael_Lingelbach , didn’t the libfprint-1.90.7-3.fc34 work on normal Fedora 34 on your Framework Laptop?

Here is the related Bugzilla ticket: 1985720 – f34: libfprint to upgrade to 1.92.0 or newer . It says the current Fedora 34 latest libfprint RPM libfprint-1.90.7-3.fc34 works on Framework Laptop.

The fingerprint reader worked when using libfprintd (I was able to enroll and verify), I’m not sure what was backported to 1.90.x, but I was providing instructions for installing 1.9.2 based off npr’s comment about idle power draw (I had noticed the fingerprint reader getting hot on 1.90.7). Still troubleshooting SDDM login, but that’s not a framework or driver issue :slight_smile:

Okay. I assume you tested it with libfprint-1.90.7-3.fc34, not with libfprint-1.90.7-2.fc34. I updated this thread’s first comment having wiki feature, by adding your instructions link for installing libfprint 1.92.

I’m having trouble updating the original post, I assume due to some issues with the discourse instance. I’ll try to update later, but this worked for “fixing” the input freezing (thanks Alan), no idea if this will impact battery life as PSR is supposedly an efficiency thing.

  • Input lag/freezing under wayland
    There is an issue with Intel’s panel self refresh that causes input lag/freezing under Wayland. If you experience this, you can disable PSR in the kernel by modifying the GRUB entry as follows:
    sudo grubby --update-kernel=ALL --args="i915.enable_psr=0" 
    Ensure you reboot your system afterwards.

Has anyone tried the microphone? My mic is only picking up internal noise (it’s on, I checked) and is not usable for voice. I’m assuming a pipewire issue.

@Michael_Lingelbach I’ve used my microphone for a couple of days and it’s been perfectly fine for me out of the box installation of fedora 34, sounds just like what you would expect. Although if I am to play a video during a call or a song, it is audible through the microphone as well as my voice, which is expected with any device

Perhaps it’s a hardware issue, given it works on your system. I’m not sure the best way to debug this, I already tried reverting to pulse audio, downgrading to the 5.11 and 5.12 kernels (from 5.13), and the microphone “works” but is incredibly faint (I have to tap the case directly above it to hear anything), even when I boost the volume to max (tested via arecord/play and zoom). I tried changing the input sample rate on pipewire (I think it defaults to 48 KHz anyways).

@Michael_Lingelbach could you try out one of the Fedora respins or Ubuntu 21.04 on a live USB drive to see if the behavior is the same?

I updated this thread’s wiki, adding a touchpad issue on normal Fedora 34 with libinput RPM by this conversation.

1 Like

@jches I see the Wifi works on your environment on kernel 5.13 on Fedora 34, right?

But I see Wifi and Bluetooth don’t work on by an Intel AX210 adapter’s bug on kernel 5.13 on the threads: [SOLVED] Using the AX210 with Linux on the Framework Laptop, Arch Linux on the Framework Laptop 13 and Linux users: Use kernel >=5.13.10 to avoid WFi/BT issues.

So, the Wifi and Bluetooth issue does not happen on Fedora 34?

The Fedora 34 latest kernel version is kernel-5.13.6-200.fc34.

Fwiw, WiFi works fine for me in 5.13 for me (on Arch, not Fedora). Bluetooth doesn’t.

I am on Fedora 34 with kernel 5.13.4; wifi and bluetooth both work for me.

$ uname -r

$ lshw -C net
WARNING: you should run this program as super-user.
       description: Wireless interface
       product: Wi-Fi 6 AX210/AX211/AX411 160MH
1 Like

@nrp Same behavior on ubuntu 21.04 (I’m currently using the KDE respin for Fedora 34), I can follow-up on the support email I sent with the images of the microphone/bezel that were requested. Sorry all for the unrelated noise on the thread!

1 Like

I’m not brave enough to try running 5.13 but from what I’ve read on some of the links discussing the regression, wifi does work on 5.13, and bluetooth reports that the modules are loaded on 5.13 but no hardware actually exists when you try to connect devices.

1 Like

It sounds like bluetooth support might have regressed between 5.13.4 and 5.13.6? I am able to add/remove/use a bluetooth mouse without any problems. I might have to try the .6 release later and see what happens…