Fedora 34 on the Framework Laptop

I’m having trouble updating the original post, I assume due to some issues with the discourse instance. I’ll try to update later, but this worked for “fixing” the input freezing (thanks Alan), no idea if this will impact battery life as PSR is supposedly an efficiency thing.

  • Input lag/freezing under wayland
    There is an issue with Intel’s panel self refresh that causes input lag/freezing under Wayland. If you experience this, you can disable PSR in the kernel by modifying the GRUB entry as follows:
    sudo grubby --update-kernel=ALL --args="i915.enable_psr=0" 
    Ensure you reboot your system afterwards.

Has anyone tried the microphone? My mic is only picking up internal noise (it’s on, I checked) and is not usable for voice. I’m assuming a pipewire issue.

@Michael_Lingelbach I’ve used my microphone for a couple of days and it’s been perfectly fine for me out of the box installation of fedora 34, sounds just like what you would expect. Although if I am to play a video during a call or a song, it is audible through the microphone as well as my voice, which is expected with any device

Perhaps it’s a hardware issue, given it works on your system. I’m not sure the best way to debug this, I already tried reverting to pulse audio, downgrading to the 5.11 and 5.12 kernels (from 5.13), and the microphone “works” but is incredibly faint (I have to tap the case directly above it to hear anything), even when I boost the volume to max (tested via arecord/play and zoom). I tried changing the input sample rate on pipewire (I think it defaults to 48 KHz anyways).

@Michael_Lingelbach could you try out one of the Fedora respins or Ubuntu 21.04 on a live USB drive to see if the behavior is the same?

I updated this thread’s wiki, adding a touchpad issue on normal Fedora 34 with libinput RPM by this conversation.

1 Like

@jches I see the Wifi works on your environment on kernel 5.13 on Fedora 34, right?

But I see Wifi and Bluetooth don’t work on by an Intel AX210 adapter’s bug on kernel 5.13 on the threads: Using the AX210 with Linux on the Framework Laptop, Arch Linux on the Framework Laptop and Linux users: Use kernel >=5.13.10 to avoid WFi/BT issues.

So, the Wifi and Bluetooth issue does not happen on Fedora 34?

The Fedora 34 latest kernel version is kernel-5.13.6-200.fc34.

Fwiw, WiFi works fine for me in 5.13 for me (on Arch, not Fedora). Bluetooth doesn’t.

I am on Fedora 34 with kernel 5.13.4; wifi and bluetooth both work for me.

$ uname -r

$ lshw -C net
WARNING: you should run this program as super-user.
       description: Wireless interface
       product: Wi-Fi 6 AX210/AX211/AX411 160MH
1 Like

@nrp Same behavior on ubuntu 21.04 (I’m currently using the KDE respin for Fedora 34), I can follow-up on the support email I sent with the images of the microphone/bezel that were requested. Sorry all for the unrelated noise on the thread!

1 Like

I’m not brave enough to try running 5.13 but from what I’ve read on some of the links discussing the regression, wifi does work on 5.13, and bluetooth reports that the modules are loaded on 5.13 but no hardware actually exists when you try to connect devices.

1 Like

It sounds like bluetooth support might have regressed between 5.13.4 and 5.13.6? I am able to add/remove/use a bluetooth mouse without any problems. I might have to try the .6 release later and see what happens…


Okay, here’s where I found it: @mbernhard posted a link in Linux users: Use kernel >=5.13.10 to avoid WFi/BT issues - #3 by mbernhard to Bluetooth via AX210 fails with Linux 5.13.4-1, but works with 5.12.19-1 - Support - Manjaro Linux Forum where the OP there posts that bluetooth didn’t work using Manjaro Linux Pahvo 21.1.0 (stable) but didn’t mention what kernel version this uses (beyond 5.13).

For the touchpad libinput bug, I just filed the following issue ticket on Fedora Bugzilla to ask to apply a patch of the upstream commit to the Fedora 34 libinput RPM. I updated this thread’s wiki too.

Framework laptop: touchpad right-click doesn’t work

1 Like

Hey guys, do any of you guys have any idea about what to do when updating fedora? Currently on 5.13.5 and I tried updating to 5.13.6 from gnome software as well as from my terminal just for both to give me a boot error of “systelctl status initrd-switch-root.service” ( initrd-switch-root.service failing). I look up the issue online but there are different options to try and the two that I tried didnt work. Do you guys have any idea? It seems people have this issue with Fedora when updating. Currently, I’m back on my 5.13.5 install but my grub still has the two installs that don’t work.

I’m also having moments where I’ll restart my computer and use it for a while and then everything gets really slow, and when I’ll suspend my computer my closing the lid and then reopening it causing everything to be slow and it’ll say my CPU usage is high. Any ideas about that?

EDIT: Like right now after just browsing the internet, listening to Spotify, and in a call on discord, my OS just decides to slow down and all everything gets super slow. I’m not even doing anything super intensive, and I can’t even see what is using all of my CPU or whats causing me to throttle. I just restarted and after a couple of minutes of a slow install (which normally doesn’t happen) it went somewhat back to normal. A couple of animations are still slow and all.

Why don’t you use Ask Fedora? I think you can find more people to answer for your question there.

Hi folks, I’m struggling to get the fingerprint reader working on Fedora 34. I got all hardware working 100% on Ubuntu 21.04 yesterday, but decided to switch to Fedora 34 due to the much better trackpad gesture support (3-finger desktop switching was a must for me!).

As recommended, I installed from the latest respin of Fedora 34. I’ve got libfprint-1.90.7-3.fc34.x86_64 installed, but every time I try to enroll a fingerprint, I immediately get an error and it gives up. Some reading on fprintd suggests this is usually a driver error. Here’s what the error looks like:

[sawaba@fedora ~]$ fprintd-enroll 
Using device /net/reactivated/Fprint/Device/0
Enrolling right-index-finger finger.
Enroll result: enroll-unknown-error

Is that the right device?

I can’t find anything in /var/log that gives any more details and all my Googling hasn’t revealed anything useful. I also tried pulling from the Fedora 35 repo, but it just gives me the same version of libfprint that seems to be working for everyone else…

1 Like

There is Ubuntu thread, and others, suggesting that libfprint must be version 1.92 1 for the fingerprint sensor to work.
I haven’t managed to get a successful compile yet, always some package not found.

@Edward_Gray you shouldn’t need to compile, you can just install from rawhide: Community reviews - #9 by Michael_Lingelbach

1 Like