Fedora 36 on the Framework Laptop

Fedora 36 is locked in for a May 10th release, but the current Release Candidate 5 (which will become the final release) is available now.

Installation Guide: Fedora 36 Installation on the Framework Laptop - Framework Guides

See also


s2idle still appears to be broken. I used the command from the F35 thread to change my sleep mode to deep.

This was tracked down a little further and a workaround was found that should make s2idle work no worse than it did before:

1 Like

Good to know. I’ll try that out. Thanks!
EDIT: Seems to have done the trick

Fedora 36 is available on the official website.

Here is the summary.

1 Like

I just tried to request the backport of the patch to make microphone work without configuration on Fedora 36 by Fedora Bugzilla with component: kernel. However I gave it up for now because I needed to show the reproducing steps on F36 and rawhide. See the description template on the component: kernel. I am not sure if people in Fedora kernel is positive for this kind of backporting, as I saw this comment. However I think it’s still worth to request the backporting.

1 Like

What is the current state of suspend and hibernate on F36? If I add the “mem_sleep_default=deep” kernel parameter then they keyboard and mouse are unusable upon wake. What does “nvme.noacpi=1” do?


I followed a guide to conditionally swap between disk and zram on sleep/suspend but didn’t get suspend + hibernate working yet but general battery drain is terrible. A fully charged laptop will be dead within 24h even if untouched within that period.

Basically this: https://gist.github.com/eloylp/b0d64d3c947dbfb23d13864e0c051c67?permalink_comment_id=3936683#gistcomment-3936683 - maybe with some other tweaks, can’t remember, tried a few things.

I love Fedora and Framework (especially together) but the battery situation is such a bummer. Looking into more options for battery tuning today …

I have a Dell XPS 13" runing ubuntu 22.04 and I tweaked the swap settings on it and the battery life is the polar opposite. Lasts forever while the lid is closed. It HAS to be possible.

For what it’s worth, battery life while using it seems great!

Thanks for sharing the GIST document about the hibernation. I would recommend checking the Fedora 35 main thread written on the 1st comment, and try the sleep: deep for now.

Have you tried this in the guide above on the 1st comment?

There is also one optional workaround needed to get the best suspend battery life, which is setting “nvme.noacpi=1” in your kernel parameters. In Fedora, you can do this by running the following command: sudo grubby --update-kernel=ALL --args=“nvme.noacpi=1”


Thanks for testing the kernel option!

1 Like

I’m not sure if this is a Framework thing or a Fedora 36 / Gnome 42 thing, but I normally see a UI indicator when adjusting the keyboard backlight brightness. This works for most of the Fn keys like display brightness, but not when pressing Fn + Space for keyboard backlight brightness. Is there a way to get this to register in Gnome on Fedora 36 with the Framework?


Does anyone have the Wi-Fi 6E intel AX210 “seeing” 6 GHz channels (In Europe/NL)?

My (11th Gen) Framework laptop with i5 running Windows 10, Windows 11 with Intel driver version.
2.4 GHz and 5 GHz channels are seen. But 6 GHz is not.

Fedora 36 “live” version running from USB or hardware install, not seeing the 6 GHz Wi-Fi network/ESSID.

(I have an Alienware 15R3 with AX210 that is working with 6 GHz. (It is seeing the 6 GHz radio/ESSID of my Wi-Fi 6E access point. But only on Windows 11. Someone “fixed” this remotely for me. But I was not told yet what they did. It was not working before it was fixed either.)

It might have something to do with regulatory domain. However the chart at Countries Enabling Wi-Fi 6E | Wi-Fi Alliance already shows adopted for most of Europe. I know that it passed all regulatory hurdles (for the low part of the 6 GHz band). And link shows it should be adopted into law in the individual EU countries by last December.

But if it needs to be forced, how? Anyone knows? (Or for any Linux distribution and/or Windows 10/11 on the Frameworks laptop? )

There is little to find about it working on 6 GHz specifically. However not many people have access to Wi-Fi6E equipment yet.

Best regards,

1 Like

Just in case, I wrote steps to run the sudo grubby --update-kernel=ALL --args="nvme.noacpi=1" here on my wiki, Battery Life: Improve suspend battery life with nvme.noacpi=1 · junaruga/framework-laptop-config Wiki · GitHub

1 Like

This problem is new to Fedora 36. Everything described here worked fine in Fedora 35.

I have a Framework laptop attached via USBC to a dock that hosts my monitor via HDMI, keyboard, trackpad, and 2.4GHz mouse dongle (all via USB A).

Everything works when the dock is plugged in.

When the system goes to sleep, either because it was left idle or by shortcut keys, the dock essentially disappears from the system.

In Fedora 35, moving the mouse, clicking the trackpad, or touching a keyboard key would wake the system and everything returned to working order.

In Fedora 36, none of those behaviors wake the system. I have to physically open the laptop to wake the system, but that does not wake the USBC dock. I have to physically disconnect the dock from the USBC port and reattach it. This wakes the keyboard, mouse, trackpad, and monitor.

My laptop is docked 98% of the time, so this has made using Fedora 36 EXTREMELY frustrating.

My system was upgraded from F35, so I had already done some of the previously recommended fixes for Framework/Fedora interop.

The system sleep mode is set to deep sleep.

Anyone else having similar problems or does anyone else know of a dock that maybe just works better?

I’m having similar issues with every dock I’ve tried. A bit odd. Hopefully this all gets fixed soon.

My laptop is docked over 96% of the time. I’ve run both Fedora 35 and 36 and never had the problem you described. I keep my mouse adapter directly into the computer, not on the hub.

Dock is an Aukey 6-in-one adapter.

@James_Kaufman thanks for the info. Maybe I’ll just try buying a new dock.

I’m running the latest Framework BIOS, so I don’t think it’s got anything to do with that. But that said, the Framework BIOS is pretty limited on power management settings.

I’m giving the laptop a pass, mainly because all of this worked fine in F35, so I’m fairly certain the issue is with F36 or the combination of F36 and my dock

UPDATE: I ended up finding this dock online for about $28 (shipped). I’ll update this thread with my results. Hopefully the new dock just works better.

UPDATED UPDATE: The new dock arrived and the results are different, but still not 100%. The mouse and keyboard attached to the dock still do not wake the dock from sleep … I still have to open the laptop to wake it up. BUT I no longer have to unplug the dock from my laptop to wake the monitor. Still experimenting…

FINAL UPDATE: While the new dock didn’t solve all of my problems, I believe it helped (I no longer had to physically disconnect the dock to get things working). That said, my final solution involved creating a set of udev rules that gave my keyboard, trackpad, and mouse “permission” to wake my laptop from sleep. Below is a copy of my script which I stored in /etc/udev/rules.d/10-wakeup.rules

My vendor IDs are 05ac (for Apple) and 046d (Logitech). You will need to change the vendor ID and product ID values for your own devices. Research the “lsusb” command to learn how to acquire vendor and device IDs for your products.

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="05ac", ATTRS{idProduct}=="026c" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/power/wakeup'"
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="05ac", ATTRS{idProduct}=="0265" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/power/wakeup'"
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c52b" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/power/wakeup'"

Adding the above script now allows my laptop to be woken up by moving the mouse, touching a key, or fiddling with the trackpad.

1 Like

Just did some updates. Anybody’s function keys (specifically F7-F10) not working anymore? (fn lock is not on)

1 Like