Fedora 40 on the Framework Laptop 13

Fedora Workstation 40 is released! You can download Fedora Workstation 39 here .

Official Fedora 40 release announcement can be found here .

Installation Guide: Fedora 40 Installation on the Framework Laptop 13 - Framework Guides

VAAPI profiles: If you want VAAPI profiles exposed then you need to enable rpmfusion and run the steps listed here:


To expose the various capabilities via vaapi for encode/decode - fedora strips patent encumbered bits from mesa by default. IME people forget to run the dnf swap bits after adding rpmfusion .

You can check what is exposed by installing libva-utils and running vainfo.

The xz vulnerability was fixed a while ago. BUT… There are some zero-day security vulnerabilities on other packages. It happens! They are already fixed in our package repos, but the fixes are not on the install images. Make sure to promptly upgrade after a fresh F40 install.


Opened back up now that it’s released.

Just upgraded from Fedora 39 to Fedora 40. All good so far :crossed_fingers:.

I don’t seem to be able to update the GRUB bootloader though:

% sudo mount | grep '/boot'
/dev/nvme0n1p2 on /boot type ext4 (rw,relatime,seclabel)
/dev/nvme0n1p1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=winnt,errors=remount-ro)

% sudo grub2-install /dev/nvme0n1 
grub2-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.

None of the /dev/nvme0 and /dev/nvme0n1p2 variants are working either. How do I adjust the command to fix this?

Update: Nevermind. My system is UEFI, not BIOS so I don’t think I need to update the bootloader.

% [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

Have you seen the laptop they used to promote Fedora Workstation?

Looks oddly familiar :wink:


Anybody seeing the fingerprint reader stop working after update? My machine seems otherwise fine, and the fingerprint reader worked fine under Fedora 39. But now, no dice. I also tried deleting my saved fingerprints and re-registering them, but it doesn’t even detect my finger now.

Note: fwupdmgr sees my finger print reader, and its version is the correct one:

Framework Laptop 13 (AMD Ryzen 7040Series)
└─Fingerprint Sensor:
      Device ID:          23ec719b6aabc2d2dac5176c232f0da7a21881b0
      Summary:            Match-On-Chip fingerprint sensor
      Current version:    01000330
      Vendor:             Goodix (USB:0x27C6)
      Install Duration:   10 seconds
      Serial Number:      UIDDD748D1F_XXXX_MOC_B0
      GUID:               1e8c8470-a49c-571a-82fd-19c9fa32b8c3 ← USB\VID_27C6&PID_609C
      Device Flags:       • Updatable
                          • Device stages updates
                          • Device can recover flash failures
                          • Signed Payload

I’ve tried the usual rebooting, as well as full power off and restart. Gnome fingerprint enrollment shows the enrollment UI, but when it asks me to touch the sensor, it doesn’t detect my fingerprint, it just waits.

Hi, I updated my Framework 13 Intel 12Gen from Fedora 39 to 40 (Gnome) a few minutes back and I noticed, that I can`t play sound anymore. When I use the speaker keys (F1 to F3), it shows that hdmi/display port is the output.
Firefox crashes constantly and I can’t play music or videos o_O

Does anyone have similar problems?

1 Like

Upgraded my 11th Gen i5 to Fedora 40 (Cinnamon Spin) and everything’s working amazingly well.

I briefly had some issues with sound when I booted into F40 for the first time, but that seemed to be more of an issue with the default audio output being changed. I changed that back in the settings panel and audio started working normally again. I’m running F40 now on a custom desktop (amd cpu + gpu) as well as my Framework 13 AMD laptop. There may be some hints to the problem in your journalctl.

Sounds like you’ll have to reset your fingerprint scanner.
The symptoms sound identical to the Windows-Linux dual boot issue. Instructions can be found in that thread!

After the update to Fedora 40 all sound devices didn’t work anymore for my Framework. It turns out, that the format of the wireplumber-config-file has changed (I didn’t run rpmconf after the update :man_facepalming:).

I deleted the wireplumber.conf, selected the audio device in the Gnome settings and everything works and sounds fine :slight_smile: :
sudo rm /etc/wireplumber/wireplumber.conf

Perhaps this might help you?


Hm, well I don’t have any audio settings and I don`t find a wireplumber.conf o_O
I gues, I have to reinstall my fedora system…

Is this helpful?


I searched and found some threads on this issue, and in the end, while none of the python scripts to reset my fingerprint storage worked (nor did the app-image) I think that running fprintd-delete $USER (which I think achieved nothing, as the command line output said there were no enrolled prints) and then manually re-enrolling on the command line seems to have worked.

Shrug? Well, all’s well that ends well.

It seems mostly good on my end except I lost brightness keys…

Using evtest command line tool, they don’t report anything when FN is pressed in combination with brightness up/down


If upgrading from Fedora 39, we recommend backing up your home directory and doing a clean installation.

I wonder why this recommendation to do clean install exists here. Fedora is known for quite reliable update between major releases. Are there any particular risks/known issues on FW HW ? On all of my PCs and laptops upgrades were smooth almost ~100% so far.

Artūras B.

I’m also experiencing this. Pressing the brightness keys, or Fn + brightness keys, or the brightness keys on my Apple Magic Keyboard 2 always triggers the corresponding function key.

Otherwise, the upgrade has been fairly smooth on my 12th gen Intel Framework 13.

Before the upgrade, in the Software app in the box that said “Fedora Linux 40 available”, when I clicked “Restart & upgrade”, I got a warning dialog saying that blender was incompatible. When I clicked the “remove” button in the dialog, Software showed a toast saying “There was a problem” and then when the system restarted, the update didn’t begin.

I had to manually uninstall blender from Software and then press “Restart & upgrade” again for the update to start.

From official Fedora docs on upgrading:

Back up your data before performing a system-wide upgrade as every system upgrade is potentially risky. As a precaution, download the Fedora Workstation Live image in the event something goes wrong.

A system-wide upgrade is fundamentally a risky proposition compared to a clean install.

If it helps, I upgraded from 39 to 40 by following the official upgrade guide. I didn’t run into any issues. However, with the optional post-upgrade steps, the process is quiet a bit of work (and I got confused on the BIOS update step). A clean install could be easier for many users in comparison.

I personally always upgrade, but I also always have my data backed up in case something goes wrong. Irrespective of whether you choose a clean install or an upgrade, please be sure to have a backup before you begin (in case something goes wrong).

I hope that helps.

Thanks for insights.

I have my systemd-homed managed home dir on 1TB Framework’s module. I also have a user on internal disk for admin purposes. Before upgrading I’ll remove external 1TB module and I’ll run update with that another admin user. This should be safe enough as I haven’t customized my install, just added proper SELinux for homed. This should survive the upgrade. If the upgrade is successful, I’ll plug 1TB module back to my laptop and should be able to log in to my homed managed user normally.

As I couldn’t hear any specific upgrade issues or conditions to avoid, I’ll proceed with upgrading it and not doing clean install.

1 Like

Hey, yessss, thank you :slight_smile:
I used this:

rm -Rf ~/'.local/state/wireplumber'
sudo reboot now

and I can play audio again and the buttons work.