Fedora Silverblue - equivalent to Fedora 35?

Hi folks, I know that Framework recommends Fedora 35 as the Linux distribution with the best hardware support. In the official guide for the DIY Edition, they call Fedora 35 “Essentially fully functional out of the box.”

Is this also true of Fedora Silverblue 35? Are they functionally the same in terms of hardware support? Or does the “immutable” stuff interfere somehow with hardware support?

I’m not sure how I feel about containers, but the idea of an “immutable” Linux distro that I can’t easily screw up has its appeal.

They’re the same in hardware support. Custom drivers like the nvidia ones are slightly harder to install on Silverblue (or at least different) but that doesn’t matter here, as Fedora works out-of-the-box.


From what I understand the only difference between Regular Fedora and SilverBlue is that SilverBlue is immutable and all your apps are containerized. Hardware support is still the same as @Jonathan_Haas mentioned.

SilverBlue does only come with Gnome/Wayland and I’m unsure if you can change that. Regular Fedora 35 comes with more Desktop Environments. I use KDE/Plasma.

Kinoite is the KDE/Plasma equivalent of Silverblue. However it’s even newer and more experimental than Silverblue.

I currently am installing Silverblue on my Framework.

I just noticed this line in the Fedora instructions:

The only hardware that doesn’t work out of the box is the microphone input on the 3.5mm jack. It’s an easy workaround though. Create a file called “/etc/modprobe.d/alsa-base.conf”, add “options snd-hda-intel model=dell-headset-multi” to it, and then reboot.

Is this doable on Silverblue? Or am I out of luck when it comes to microphone input?

/etc is still writeable, you should be fine!


The good news: hardware support for Silverblue appears to be flawless. I even tested the microphone input and it seemed to work (so no need to mess with /etc).

Bad news: While this may be a fine distro if you don’t develop software, I found it unusable the moment I dropped to the command line.

First, they recommend installing+using Toolbox, a containerized environment where you can install packages as normal with low risk of borking your system. I thought, fine, I’ll install this and do software dev in a container. Adds an extra step when opening my terminal, but I could just add toolbox enter to the bash scripts that run when I launch my shell.

Sadly, when I created a toolbox and entered it, I found I couldn’t even change my default shell. chsh doesn’t exist, but I found lchsh does exist and claims to work. When I installed fish shell and tried to change my default shell to fish, it reported success. When I look in /etc/passwd in the container, it shows /usr/bin/fish is my shell. But logging in and out of the container has no effect, my shell is still bash. Restarting my computer causes /usr/bin/fish to disappear from my /etc/passwd entry, even though fish is still installed and still appears in /etc/shells.

I decided that this was a bad sign, that if I can’t do something as simple as change my default shell, development work in toolbox is not going to go well. I’m going to reinstall with normal Fedora I think.