Fingerprint reader (fprintd) 'just working' for Ubuntu 21.10

So, got most everything working a while back, decided I’d circle around on fprintd because at the time it looked like it was going to be twitchy.

Decided to ‘just try it’ this morning, for giggles, and it enrolled three fingers, no problem, and worked right off the bat.

I’m always suspicious when things ‘just work’. Am I missing a problem here?

matt@Cogsworth:/var/log$ hostnamectl
Static hostname: Cogsworth
Icon name: computer-laptop
Chassis: laptop
Machine ID: xxxxxx
Boot ID: xxxxxx
Operating System: Ubuntu 21.10
Kernel: Linux 5.13.0-39-generic
Architecture: x86-64
Hardware Vendor: Framework
Hardware Model: Laptop
matt@Cogsworth:/var/log$ apt show fprintd
Package: fprintd
Version: 1.90.9-1build1
Priority: extra
Section: misc
Origin: Ubuntu
Maintainer: Ubuntu Developers
Original-Maintainer: FingerForce Team
Bugs: OpenID transaction in progress
Installed-Size: 647 kB
Depends: dbus, policykit-1, libc6 (>= 2.34), libfprint-2-2 (>= 1:1.90.1), libglib2.0-0 (>= 2.56), libpolkit-gobject-1-0 (>= 0.99)
Homepage: fprintd
Task: ubuntu-desktop-minimal, ubuntu-desktop
Download-Size: 89.3 kB
APT-Manual-Installed: no
APT-Sources: Index of /ubuntu impish/main amd64 Packages
Description: D-Bus daemon for fingerprint reader access
fprintd is a D-Bus daemon that offers libfprint functionality over the
D-Bus interprocess communication bus. By adding this daemon layer above
libfprint, various problems related to multiple applications simultaneously
competing for fingerprint readers get solved.

1 Like

Yes the problem is that you’re just used to using “microsoft friendly” hardware that you always have to look for workarounds for it to work with Linux. Maybe this is the change all the linux people have been waiting for


Yeah! Ubuntu shipped an updated version of libfprint which supports the reader in the Framework laptop. It works out of box on Ubuntu 21.10 (though it didn’t when 21.10 was released)