Fingerprint scanner stopped letting me add fingerprints and won't work at all now

Just got my new 12th-gen Framework a few weeks ago and installed Debian testing on it. One of the first things I did was enroll my fingerprint. To, start, I just added my index finger, and it worked fine. A couple weeks later I decided I’d add more fingers on my right hand, and that’s when the trouble started. I filed an issue with the libfprint folks, but to summarize:

I tried adding right-thumb, but after a bunch of enroll-stage-passed messages, it ends with enroll-disconnected. After some fiddling, I ended up using fprintd-delete to delete all prints, but now any finger I’ve tried to previously enroll fails in that way. Trying to enroll a brand-new finger that I’ve never tried to enroll before succeeds, but then when I try to use it (either to unlock from the screen locker, or testing using fprintd-verify), it fails to recognize the finger… and then, inexplicably, the scanner forgets that finger even exists; fprintd-list shows that nothing is enrolled!

I tried running the storage cleanup script posted on another topic, but that oddly gives me “Device doesn’t support clearing storage.” This is the new 12th-gen mainboard, so maybe it has a different fingerprint sensor (27c6:609c) that libfprintd doesn’t know how to clear?

At any rate, I’m at a loss for how to proceed. I’ve never installed a different OS, let alone used the fingerprint scanner from another OS, so it’s not the whole different-OS-storage-conflict issue. It sorta seems like the scanner is actually remembering prior fingers that I’ve enrolled, even though libfprint doesn’t think there’s anything enrolled. And regardless, it’s weird that enrolling a new finger succeeds, but then fails to actually work, and then libfprint (and possibly the hardware?) completely forgets about it. Any ideas?

1 Like

Of course, after I post this, I decide to clone libfprint master and try running the storage-cleaning script off of that, and the storage cleaner works. Then I’m able to re-enroll my right index finger successfully, and it seems to work. Then I’m able to enroll my right thumb again, but… it’s unable to verify using the thumb, and when it fails, it “forgets” that the thumb is even enrolled anymore. At least my right index finger is still working. So I’m somewhat unstuck (one finger is better than none), but there still seems to be an issue here.