First Repair - Broken expansion card release button

Hi everyone,
So I ran into my first issue with my Framework laptop. The release button on one side was very tactile, but the other one was loose. I attempted to pry off the button plate and glue it back in, but this didn’t help. Does anyone know how I should go about fixing this?


20211019_010652
Even after gluing it, the button was still not quite right, so I took it off again, and it broke off one of the plastic pegs.
20211019_011253

Update - I was able to get down to the culprit. I wish I would have tried this solution first.


I’m not sure if this part will be salvageable, and I don’t see it available on the marketplace.

I’ll see what I can hack up with what I have left, but I would really appreciate these release buttons being available on the marketplace, as I could see them going bad after multiple presses or by yanking out an expansion card too hard. That being said, I understand that the team has a lot on their hands, and I would be more than okay with waiting on this. Just wanted to document my first repair attempt should anyone face anything similar! I love this modular design :smiley:

3 Likes

I found the problem. The non-tactile release button had a chip in the plastic latch closest to the edge of the laptop.
20211019_014250(1)
Here is what the plastic latch looked like on the good button.


and here they are side-by-side.

Additionally, flipping them over reveals that they are numbered, which gives me hope that replacements will be made available.

For now, one side of my laptop will simply remain button-less. I hope this information is able to help anyone who may come along a similar issue.

2 Likes

So it is like the release button on Nintendo Switch Joy-Con? You can 3d print replacement parts for those and if you have access to a 3d printer then I imagine that you could probably make a replacement part.

I know what you’re talking about, and this one is a little different. The ones on the Switch are just pieces of plastic, and while what is broken here is a piece of plastic, it is an entire button assembly consisting of a spring and hinge mechanism, as seen in this photo.


Were I to take this apart, I’m not sure that the structural integrity of either the spring or hinges would stay intact.

2 Likes

I certainly hope so as well, and I have heard of several folks having difficulties ejecting expansion cards which makes me wonder if this will become a more common issue as time goes on. However, I do wonder why these are numbered. Are they not identical?

As far as I could see, yes. The 1 fit into the 2 slot and screwed in properly, and vice versa. If we could get an official answer for why they are numbered, that would be cool.

3 Likes

Reviving a very old topic here—my 12th-gen Framework just arrived today, and it, too, has a damaged card release button. It seems like my example might be a little more extreme than this one, as the button was completely detached and fell to the ground as soon as the laptop was removed from its sleeve. No word from support yet, though I did open a ticket. OP, were you able to get the affected part(s) or the bottom chassis replaced? Has anyone else seen a similar issue with their machine? It’s been a long wait from my day-one preorder to receiving a damaged machine, so I’m pretty bummed :frowning:

Edit: Got a reply from support an hour or two after posting this thread–all taken care of now :blush: Hopefully no one else encounters this issue with their Framework (it seems like it’s pretty rare), but don’t hesitate to reach out to support if you should notice any issues with your expansion card buttons! Thanks so much for the speedy resolution :heart:

2 Likes

Awesome to hear you got it fixed! What solution did they offer you?

I was offered to purchase a new bottom cover kit for $100, and I declined since that seemed excessive for a single button, so to this day I have a broken button :(. I really hope they make the buttons available on the marketplace one day.