First setup, black screen still after 1+ hour

Firstly, I have contacted support but I’m assuming I won’t get a response for a while and I’d love to get this laptop up and running as soon as I can!

The TL;DR is that after installing all the parts on my DIY edition 16, plugging in power, and turning it on, the screen remains blank seemingly no matter how long I wait.

Chosen specs just in case its relevant:

  • 64GB RAM (bought from framework)
  • 2 SSDs installed (bought from framework)
  • Graphics Module

Things I have tried whilst troubleshooting:

  • Let the computer do its thing for over an hour
    • The fans spin up, computer gets hot, but nothing on the display
  • Re-seating the RAM
  • Every combination of SLOT + RAM
  • Attempt at resetting BIOS (I think) by pressing sw3 10 times, though its hard to know if it actually did anything
  • Swap out graphics module for blank one
  • Plugged in external display, no output to it either

I’ve noticed occasionally during my attempts the LEDs will flash a sequence of colours, though it happens so fast and randomly that I’ve yet to note what the sequence is down, not that I can see any official guide as to what they would mean anyway.

Also one time some sort of corrupted looking vertical bars flashed on the screen near the centre bottom for a split second. Its probably worth noting the display backlight does appear to come on.

Any other suggestions? or even just better guidance on what I should expect to see happening, how long should I wait between testing RAM combinations (apart from the first attempt where I left it for over an hour, i’ve been doing 3 minutes.

Should I try with the second SSD removed?
Should I take the display off and reseat the EDP connection?
Should an external display show anything (assuming its getting past RAM checks/training)?
Is testing without reinstalling the mid plate okay like one comment I read suggests it is?

Check the display cable connection both to the motherboard and the display itself. Sometimes it is a bit loose. (It’s on the upper left of the board)

If that doesn’t work, it’s probably a screen problem in which case you can just have them send you another screen for free

Thanks, just tried reseating both sides of the display cable, no luck

Have you tried plugging in a bootable USB with Windows or Linux on it and restarting the machine? Or are you sure it’s a display problem? If you’re 100% sure it’s a display problem, I would definitely contact framework support directly as soon as possible. Also, did it ever work or did it just come like this? If it never worked before, then it is probably a hardware problem.

I have no idea if its a display problem, I’m leaning on it not being due to all the things I’ve tried (I did try with a bootable usb to see if anything came up on the internal or an external display with no success).

It has been like this since it arrived (this morning!)

I agree that it does seem like a hardware issue at this point unfortunately

In an external screen (connected correctly) doesn’t turn on either, it’s probably not a screen issue.

It might not be the most helpful advice, but you could try to record the flashing lights on a smart phone if you have one and post to support, or perhaps here if anyone fancies trying to slow it down and see what the colours are.

Managed to get it on video and slow it down, pattern is:

B = blue
G = green
R = red

The blink codes are explained here:

I think you might be missing some white and orange blinks in that colour pattern.

That’s the Framework 13.

I got it to boot… for a bit

Found a guide for ‘resetting the state’ on the 13 mainboard (Fully Resetting the Mainboard State - Framework Guides), essentially just remove the battery and wait a few minutes. So gave it a try with one stick of ram in slot 1. Got something on the screen for the first time, managed to get into the bios.

I then turned it off and put the second ram stick into slot 0, and it stopped working again. I then removed it, still not working. Re-did the battery thing and it started working again (with the 1 stick of ram in slot 1). Put it all back together and confirmed I could still get to the bios, put in my bootable USB, it booted to the framework logo a few times, seemed maybe to be in a boot loop so I turned it off, took out the USB and now its not booting at all again! :sweat_smile:

1 Like

OK, I’ve never seen that happen before. My best guess would be an issue with the ram or the motherboard but honestly, I have no clue because this is the first time I’ve encountered this kind of issue that you just described . I would try taking out that faulty stick of ram and see if you can get it to boot and install windows with the one working stick of RAM. And either way contact Support and tell them what you’ve tried and they should be able to walk you through fixing it or send you a replacement.

Took it all apart again to disconnect the battery and get it booting again, out of curiosity I tried it with both sticks installed and it is booting with both installed. We’ll see how long it stays working without needing to pull the battery again…


Okay yeah this thing just really won’t start from anything but a fully cold boot

I guess you’ve emailed support already.
Aside from working with just one RAM stick for a while, assuming one of them might be causing problems, I don’t think there is much else you can try.

I just got my laptop today and I also have not had a single sign of life yet

interesting update, seems like it is either the SSD, or the SSD slot causing the problem!

With the main SSD (long one) removed, it boots every time, and I have finally managed to boot into a bootable USB!

The problem SSD does seem to get quite warm to the touch just sat in the bios, and (the thing that clued me in to removing it) it didn’t show up as a listed device in the bios whereas as the second smaller one did.

Using a cheap thermal camera it shows the connector getting notably hot after just a few seconds after boot.


Did it come with RAM and SSD or have you fitted your own?
Have you connected the power cable to one of the rear two ports on the left or right sides?

Bought the DIY edition, SSD: 2TB Samung EVO, RAM: Crucial 2x DDR5-5600 16GB.
I tried every charhing port with and without battery, no LED’s or anything. I also tried every RAM configuration and with/without SSD.

Oh I can’t believe I didn’t think of this! The SSD has a thermal pad with blue plastic film that needs to be removed before use.