Framework 13 Windows 11 "Framework Laptop EFI USB Device Boot failed"

I have a Framework 13 with an AMD chipset and Linux installed.

Now I would like to do a fresh install of Windows 11. The EFI USB was created following the instructions here.
I do see the EFI USB when booting in the BIOS boot menu. However, when selecting the USB I get the following message: “Framework Laptop EFI USB Device Boot failed”

I have tried this with two different USB flashdrives but no luck. Could not locate any obvious problems in the BIOS set-up either. Any idea what could be wrong?

No useful ideas on what the problem might be, but you should be able to narrow it down. As I see it, there are only a few general places that this could be going wrong:

  • Something could be wrong with the installation image on the flash drive. To confirm it, you can try booting a different EFI-capable machine from the flash drive, to make sure that the image works there. No need to go through with the install on that machine, of course. :slight_smile: If it boots on the other machine, then the image is good.
  • Something could be wrong with your Framework machine. To test that, you can try booting from a completely different USB image, such as the Ubuntu installer image. If that works, then your Framework system isn’t the issue.
  • Something could be physically wrong with the flash drive you’re using. You’ve already tried using a different flash drive, which should rule that out, but if the above tests don’t turn up the issue, you might try a completely different flash drive (maybe from a different manufacturer, for instance).

One of those should show where the problem is coming from, and maybe suggest a solution.


I tried the Ubuntu installer image as well - no luck.
Could the problem be related with security settings in BIOS - did not find an obvious culprit, however.
I suppose the security settings of the Linux-OS on the laptop right now won’t matter that early in the boot-process, correct?


1 Like

Yes, it could be a security setting in the BIOS. You may need to turn off “Secure Boot,” for instance – I don’t know that that will cause problems for Ubuntu, but it does for a lot of other Linux distributions.

Yes, the security settings within Linux shouldn’t matter that early in the boot process, particularly the ones on an installation copy. Since you have two different operating systems that won’t boot from a flash drive, then the problem is specific to either your machine or the flash drive you’re using, not to any settings of the OS.