Framework Laptop 16 Ryzen 7040 BIOS 3.03 Release and Driver Bundle

Day after this released Pop!_OS sent me a notification that a firmware update was available. Sure enough it was this BIOS update and in addition a firmware update for the fingerprint sensor. Change log was even provided. Clicked install, entered root password, laptop rebooted BIOS installed. No issues.


I just upgraded and had hard freezes after the upgrade (couldn’t even switch to other terminals with Ctrl+Alt+F3). After quite some debugging it only happens on my current install of Manjaro KDE /w wayland, but not with X11 and not on Fedora /w wayland (both 39 and 40, upgraded during testing). I’ve booted into btrfs system snapshots from days ago with various prior kernel versions and am still seeing the freeze so I am pretty sure the BIOS upgrade is at fault since that is the only thing I couldn’t roll back.

Can you provide me with the 3.02 BIOS so I can roll back for testing?

And if I can’t find another fix, I’d probably stay on 3.02 for a bit longer as well. Need wayland for the much better multi-monitor fractional scaling support, and although I have Fedora installed, I don’t feel like switching to it (nor Ubuntu for that matter) - don’t have the time for a switch rn even if I wanted to

Thank you!

EDIT: Some more context
The freezes would happen pretty soon after logging in, usually when opening a window or shortly thereafter. But running an all-core stress test on a separate terminal had no effect, survived just as long on the desktop. Usually opening the terminal after waiting a bit was fine (at least for a while), but opening the system monitor or browser, it would crash basically immediately.
I’ve also noticed it would be stuttering for the first couple seconds after login, which wasn’t the case before - e.g. hovering over taskbar icons had 500ms-1000ms delay.

I’d love to be able to revert back to the old BIOS and just maybe I failed to isolate another variable and it’s not a BIOS issue at all, but something that just happened to start at the same time. Because it’d be very odd if wayland + new bios combination would cause that. But X11 on the same system has been stable during work for hours now, so idk.

What SSD’s are you using?

WD Black SN850X (2TB)
Why? Think it’s related?

I am struggling with this. I am wanting to do an EFI shell update:
I format the USB drive, and extracted the contents on to the USB drive.
Secure boot disabled and use F12 to I boot from the thumb drive. Good so far.
I get to a grub boot menu and do not know what to do.
The instructions say to let startup.nsh to run but the zip contents have a file called update.nsh. I tried help on the grub menu but nothing stands out. Help. Thank you!

I have the WD_BLACK SN770M 2TB ( 2230 ) and WD_BLACK SN850X 2TB ( 2280 ) using BTRFS filesystem.

Since I upgraded to BIOS 3.03 my SN770M kept cutting off ( I never found the trigger ) which was not happening in BIOS 3.02. I later found there’s a firmware update for the SN770M and SN850X.

I’ve only updated my SN770M so far and since then ( 3 days passed and still assessing ), I’ve had no cut off’s.

by “cut off” I mean that the nvme controller would go down but would not come back and later disable the SSD. The errors I was seeing was

Apr 08 19:07:47 user kernel: nvme nvme0: controller is down; will reset: CSTS=0xffffffff, PCI_STATUS=0x10
Apr 08 19:07:47 user kernel: nvme nvme0: Does your device have a faulty power saving mode enabled?
Apr 08 19:07:47 user kernel: nvme nvme0: Try “nvme_core.default_ps_max_latency_us=0 pcie_aspm=off” and report a bug
Apr 08 19:07:47 user kernel: nvme 0000:01:00.0: enabling device (0000 → 0002)
Apr 08 19:07:47 user kernel: nvme nvme0: Disabling device after reset failure: -19

and then a bunch of repeated errors from BTRFS which were basically saying it couldn’t find the device

Using this source and this source ( I recommend this one as it’s better explained ) is how I updated the SN770M firmware.

The firmware version for my SN770M was 731100WD and upgraded it to 731120WD
The firmware version for my SN850X is 620331WD and newer version is 620361WD

I’ve not updated my SN850X yet as I’ve had zero issues with that.

I use BTRFS with RAID1 on both my SN850X and SN770M. Situations like this is why I refuse to buy laptops/desktops with less than two storage slots, it’s why I didn’t buy the Framework 13. I’ve been using BTRFS since 2015, not lost any data yet…

1 Like

I must admit, I didn’t think this would do it, but it totally worked
Followed the arch instructions so I updated with nvme-cli, logged out and back into wayland, and without even a reboot it works again! No crashes so far.
If I do happen to encounter the freezes again, I’ll be sure to edit this.

Really no idea why this unholy combination of new BIOS, wayland (specifically kwin), and older drive firmware caused this. This must be the weirdest incompability I’ve encountered so far. But the same install with X11 and Fedora with flutter have both been unconditionally stable… so odd

1 Like

For reference I was on 620331WD before I upgraded to 620361WD. Model “WD_BLACK SN850X 2000GB”. So if you have that, I’d upgrade anyway even if your current setup doesn’t cause any problems.

Maybe I’ll do a RAID1 setup in the future, but I’m happy with my setup as is already. Ofc I can recover all data losses due to my own error with a btrfs snapshot, and all linux installs are equally also covered by snapshots of their own. Should the drive fail, or the laptop go missing, I manually btrfs mirror all data to a hard drive every once in a while, and the current working data is simply backed up with a private cloud in case the main drive itself fails.
Hoping to replace that soon with my own off-site VPS to back up all data, not just the most important.

I’ve only started using BTRFS since I bought the SSD for use in the FW16, and I love BTRFS so far. Can be a bit confusing to get into, especially how some distros have their installer setup the subvolumes and the tools (e.g. timeshift I believe) just expect that exact subvolume hierarchy and if you set it up differently, you have to fix it afterwards. Or how you have to dig into the command line to recover full folders from a past snapshot because tools like Btrfs Assistant still can only recover single files through their GUI - stuff like that.
But it is quite nice to be able to revert anything back, had multiple data loss aversions already (or at least time savings). Even stupid stuff like games with weird auto-saving behaviour and points of no return, never again - you can just take an earlier point of their saves:)
I’ve also been saved multiple times by being able to just boot into an earlier system snapshot with grub if something broke in an update, and not having to worry about my data (since that is on a separate btrfs system) and just being able to continue working. Allows you to be on rolling release systems without fear even when using it for work/production.

1 Like

There were numerous issues with BIOS 3.02 which later were fixed. With 3.03 there are other issues and I’m trying to narrow down the triggers before I report them so they’re easier to trace.

I didn’t update the SN850X yet because with BIOS 3.02 I didn’t have the “2230 and 2280 not found on boot or resume” issue that was fixed in BIOS 3.03 but then I did with the SN770M on BIOS 3.03 before the SSD firmware update.

I found it puzzling that it would be the BIOS although still possible and find it wasteful getting rid of a problem your not entirely sure on where the trigger is before possibly bringing in another

This is one of the things I love about BTRFS, I don’t need to do a manual once a week backup when it’s in RAID1 mode ( although I do just incase ).

For every write you do, It copies the data, applies data integrity and upon read if the block is missing, corrupt or out of sync ( this is what happen with SN770M ), it recovers this all on the fly while your using it.

You can use the command

sudo btrfs scrub start -Bd /path/to/btrfs/mount/point

to scan over your entire filesystem and if it detect any issues, it tries to fix them

When I first setup BTRFS back in 2015, I had two setup together in RAID1 mode and one of my SSD’s was faulty ( OCZ brand ) and I wasn’t aware ( this was for about a year ) and BTRFS kept recovering the data while I was using it.

1 Like

I figured it out. I tried several USB thumb drives. The one that worked was a brand new Sandisk USB 3.2 Gen 1. It is not that the other ones were that old however (usb 3.0). I’m all up to date now.

Hi y’all. Does this BIOS update contain patches for LogoFAIL?

After installing the new bios update and drivers update notices that my numpad backlight pulses on and off.I can turn it off but when I turn it back on it continues to pulse. Anyone else experiencing this and does anyone have a fix?

Hi Vic,
The pulse is regulated with the Plus-Key (Numpad), for brightness use the Enter-Key (Numpad). Num-Lock must be off.


and this is what I love about Framework

I believe it should

So via fwupd, updating to 3.03 was simple and easy. Run it, reboot, UEFI triggers the install, reboot and good to go.

Do we think there’s a chance of S3 sleep getting added so I can stop wearing my SSD with hibernate? (S0 sleep is terrible.)


The Framework 16 implements S2idle, which is more efficient than S3idle and provides better wakeup times.

1 Like

If it works, great, but my FW16 with W11 always restarts after going to sleep. I hope it gets fixed in the future. Currently I use hibernate.

1 Like

For Windows, the only sleep appears to be the kind of sleep where it continues to guzzle battery and stay hot even when supposedly asleep. Whatever the numbers, “Windows Modern Standby” is not any more efficient than what was available prior.

(And this is after disabling the Windows wake-up timers it does.)