Western Digital Drive Update Guide Without Windows/WD Dashboard

If you want update the firmware on your SSD while avoiding Windows or the Western Digital Dashboard application, this is the guide for you. For those with the SN750 from Framework, no updates are available at this time.

Before we begin, you will need two pieces of information about your drive:

  1. The model number
  2. The firmware version

Click your operating system below for instructions.

Linux

First, open a terminal.

  1. To get the model number, type cat /sys/class/nvme/nvme0/model
  2. To get the firmware version, type cat /sys/class/nvme/nvme0/firmware_rev
Windows

First, run PowerShell as an administrator.

  1. To get the model number, type Get-PhysicalDsik
  2. To get the firmware version, type Get-PhysicalDisk | Get-StorageFirmwareInformation

When checking the firmware version, make sure you use the version in the active slot.

With those pieces of information in hand, consult the table below for the appropriate firmware file to download. Make sure both the model number and the firmware version match. If the firmware version you obtained in step 2 is instead listed in the “Download Link (Latest Version)” column, your drive is already up to date. If you don’t see your drive listed, or if you are curious about how I got these links, click on “Unlisted Drive” below for details.

Model Number
(Step 1)
Firmware Version
(Step 2)
Download Link
(Latest Version)
WDS500G1X0E-00AFY0 613000WD
611110WD
611100WD
613200WD.fluf
WDS500G1X0E-00AFY0 614600WD
614300WD
614900WD.fluf
WDS100T1X0E-00AFY0 613000WD
611110WD
611100WD
613200WD.fluf
WDS100T1X0E-00AFY0 614600WD
614300WD
614900WD.fluf
WDS200T1X0E-00AFY0 613000WD
611110WD
611100WD
613200WD.fluf
WDS200T1X0E-00AFY0 614600WD
614300WD
614900WD.fluf
Unlisted Drive

Visit https://wddashboarddownloads.wdc.com/wdDashboard/config/devices/lista_devices.xml in a web browser.

On the page, search for the model number you obtained in step 1. Between the opening <lista_device> and closing </lista_device>, you should see one or more URLs. If there are multiple, use the one which starts the same way as the firmware version you obtained in step 2.

To get the device properties URL for your drive, put https://wddashboarddownloads.wdc.com/ before the URL from above. In a web browser, open this device properties URL.

You will probably see a page about an XML parsing error. This is expected. Right click on the page. For Chrome and Firefox, click “View Page Source”. For Safari, click “Show Page Source”. (You must enable the Develop menu under advanced preferences to see this option.)

Between the opening <fwfile> and closing </fwfile>, you will see the name of the firmware file to download. In the device properties URL, replace device_properties.xml with the name of the firmware file to download it. Also, make sure the firmware version you obtained in step 2 is listed on one of the <dependency> lines. If not, you will have to upgrade to one of those versions first.

Now that you have the appropriate firmware file, the fun can start. Take a flash drive, and format it as FAT32. Visit https://wddashboarddownloads.wdc.com/wdDashboard/application/EmbeddedLinux.zip to download the standalone updater. Extract the archive, and copy the contents of Img/to-esp (not the folder itself) to the root of the flash drive. Also, copy the firmware file to the root of the flash drive. Finally, create an empty file named embedded-toolkit.cfg at the root of the flash drive.

Shut down your Framework Laptop, plug in the flash drive, and then, turn the laptop on. When you see the Framework logo, hit F12, and select the flash drive as the boot device.

After it boots (about 15 seconds), you will have to select your drive from the list. The operation should default to firmware update. You will also have to type in the name of the firmware file you downloaded. After entering this information, start the update procedure.

Once the update completes, you can repeat step 2 from above to verify your firmware has been upgraded successfully.

Good luck and happy flashing.

17 Likes

Thank you for this guide. For me it worked except the flashing process itself.

[user@fedora ~]$ cat /sys/class/nvme/nvme0/model
WDS100T1X0E-00AFY0                      
[user@fedora ~]$ cat /sys/class/nvme/nvme0/firmware_rev
614600WD

I downloaded the flashing program and obtained the firmware file, copied the files to a freshly formatted usb drive …

… and followed your steps.

This is what i get:

Any ideas?

Thanks in advance!

I have to report the same Binary Could Not Be Opened error as @Sven_Hiller
The only difference is firmware_rev reported mine as being at version 613000WD so I chose the most similar firmware link from lista_devices.xml which was 613200WD.

Oh no! I’m glad you were able to follow my guide, but I’m sorry it didn’t work.

Please create an empty file named embedded-toolkit.cfg at the root of your flash drive (next to the firmware file). Then, try the update procedure again.

3 Likes

Thank you so much for your support, now the update process was successful!
The file embedded-toolkit.cfg in the root of the flash drive did the trick :slight_smile:

[user@fedora ~]$ cat /sys/class/nvme/nvme0/model
WDS100T1X0E-00AFY0                      
[user@fedora ~]$ cat /sys/class/nvme/nvme0/firmware_rev
614900WD

@Edward_Felder
Good work Edward, I suggest you add this solution to your guide in the opening post :+1:t2:

4 Likes

This is so useful I’m pinning it! Thanks!

3 Likes

That worked! Creating the empty embedded-toolkit.cfg was the trick. I moved to the installer directory and created it using

touch embedded-toolkit.cfg

I then repeated the upgrade process booting from the thumb drive and that upgraded my 1TB WD850 to firmware version 613200WD which was released a year ago (July 2021)

I am surprised there wasn’t a later firmware version, but the process worked!

3 Likes

I don’t have a WD NMVe SSD so I cannot test the following myself, but I don’t suppose it’s possible to simply boot Hiren’s BootCD PE via Ventoy or the like and then run the official for-Windows WD SSD firmware updater?

I recently had to do this to update the BIOS on a Thinkpad from a friend because the ISO image Lenovo provides was unable to be booted for some reason when using Rufus, Linux Mint’s “image writer”, etc (it’s possible that this was actually a BIOS bug because one of the newer BIOSes mentioned fixing being unable to boot from USB in some instances).

I want to add the SN750 to the table in the main post, but I’m not sure if I have the right model numbers. Can anyone who bought an SN750 from Framework confirm if the model number is one of the following:

  • 250GB: WDS250G3X0C
  • 500GB: WDS500G3X0C
  • 1TB: WDS100T3X0C
  • 2TB: WDS200T3X0C
  • 4TB: WDS400T3X0C

Thanks!

First of all, thank you for this guide!

Yes, I have a WD_BLACK SN750 with 1TB without heatsink and my model number is: WDS100T3X0C-00SJG0.

I don’t know if there is actually a firmware update for the SN750? My firmware version is: 111130WD.
I can’t find the model number on this site:

The only model i can find is the SN750 SE. If there is no update for the SN750, then I’m fine. But if there is one, it would be nice to know.

Thanks again!

So I’m wondering what you mean here. I have this model and it’s currently running 613200. It has been updated once. Does this mean it would have been shipped with 613000, 611110 or 611100 and can only be updated to 613200, or can it be updated to 614900?

Both 1TB models are identical, so is the only difference between them the initial firmware? Can I update from 613200 to 614900?

@cocher
Thanks for confirming. I didn’t see the SN750 listed, either, which is why I wanted to verify the model numbers. As far as I can tell, you are up to date. I’ve updated the guide to reflect this.


@Fraoch
Thanks for the feedback. I’ve updated the wording slightly. Let me know if things are clearer now.
To answer your question, you are correct. Your drive shipped with one of those versions and, after being updated, is currently on the latest version. Do not update to 614900. It is not compatible with your drive.
For some background, there are two versions of the SN850, and each runs a different firmware (613XXX/611XXX or 614XXX), which is why all of the models are duplicated in the table. I’m not sure exactly what flashing the other version’s firmware would do, but it would certainly be disastrous.

2 Likes

I see. Thanks!