Framework Website Stability and Loading Issues (UPDATE: RESOLVED)


Hi everyone,

We’re experiencing some loading and stability issues with our domain and this affects all services and pages hosted on the domain. We’re working with our engineers and hosting provider and resolving the issues and thank you for your patience.

Our apologies for the inconvenience.


Hope it’s not caused by malicious intents.

I’ve been having problems logging into the website via my mobile device (Android on Brave Browser). It works fine on the desktop via Chromium. I don’t get any errors, I just input user/pass, press log in, and then the log in page just re-appears with no effect to the session.

Brave is likely blocking something from allowing authentication from happening. I’ve seen similar reports as Brave can be a bit aggressive when allowing authentication or logins. Can you try another mobile browser just to verify that it is Brave causing the issue?

1 Like

Hey @TheTwistgibber,

Thanks for the reply. I got some results!

I tried Chrome on Android and used my Bitwarden auto-filler (as usual) to auto fill the user/pass information and attempt to log in. When doing this, I got an incorrect user/password message… which was odd because I know for sure the Bitwarden info is correct, and I use Bitwarden on my desktop as well with no issues. That incorrect password information wasn’t displayed when doing the same thing on Brave on Android.

This made me try a few things:

  1. Manually copy the password from Bitwarden and paste it into Chrome on Android and see if that works. That worked! So that means that there is some bug on Bitwarden when auto-filling into browsers.
  2. I retried logging into on Brave on Android, also manually copying the password from Bitwarden. This time, it worked.

So it seems we are ok :). I’ll file a bug report with upstream. Thank you!

There’s a slight wrench in the authentication flow…from a user experience perspective:
There seems to be some additional script components required by the login.
If you submit your username & password too quickly (before all the script components have been loaded…even when the username and password fields are graphically rendered by the browser), the login page will prompt you for recapture input.

I have noticed this with some frontend frameworks on mobile phones these days (maybe React?), auto fill doesn’t trigger a “change” notification, so even though your password manager has put the password in, the application is oblivious and will pass empty to the server (or if they have frontend validation, trigger incorrect password or password required errors). Easy way to test is, on an erring form, after password has been pasted, tap at the end, press spacebar and then backspace to delete it. This triggers a viewmodel refresh and the password is then passed in correctly.