Fresh install, all went well, but default boot device is still missing

Ordered a DIY edition last friday, recieved it this monday (Holy crap that was fast!). I turned off secureboot, and set off to install slackware 15.

First weird part was that when I tried to partition using CFDisk, CFdisk defaulted to the flash drive first rather than the WD HD unit. However, my laptop still saw the storage, so I used CFDisk, targeted the HD, did the usual formatting process with zero issues.

Then came the part to reboot into the OS itself, and I get that dreaded blue box that complains that it cannot find any devices to boot.

So I thought it was the OS. So I installed Void linux. Same result: everything goes well on the install side but when I reboot, blue whiny box of death.

Tried it with Debian. Same result. I even tried a BSD variant. Same result.

I don’t know where to go from here. I feel “well-versed-enough” with the software side of things, but when it comes to firmware or bios snarls and snafus, I don’t know what to do.

What am I missing? I just want to use my new laptop.

Which SSD do you have?

As Chiraag is asking, there is a known issue on a outdated version of the WD firmware:

If you are using a SN850 this is your most likely problem.


@2disbetter - My SSD is a 500GB WD Black SM750 NVMe. I don’t know the firmware. I tried to check my laptop’s bios to see if I could find what the firmware was there, but I don’t know where to look or if even that’s the right place to look.

@RandomUser - Slackware’s partitioning is manual-only. I created a 256MB EFI partition, an 80GB root, a 20GB swap, and the rest as home partition. I installed the packages and device settings, and at the end, chose ELiLo as the bootloader. ELiLo is the EFI version of LiLo, slackware’s bootloader, and that currently works fine with my current PC.

The partition was just three primary partitions and a swap partition. No Logical Partitions whatsoever.

When I tried the other distros, I just did the installation as automatically as possible since there was no data I needed to keep/salvage at all. I only made this post because Debian of all things had the same result as my usual obscure distro choices.

Not sure about how to do that on Linux. On Windows WD has a program called Dashboard which you can use to check the “health” of your drive. It will report the current firmware and tell you if an update is possible. If there is, it will download and install it.

All I know is that per WD’s own admission, older firmware version would not properly mount at boot, or something to that affect. Framework’s hardware is about as new as it gets.

lshw will get you the current firmware revision of your NVMe drives (as well as even stuff like the UEFI firmware revision).

Unfortunately the only way to update WD firmware is through WD Dashboard, Windows only.

One of the reasons I went with a Samsung 970 EVO Plus, since there is a way (albeit unsupported?) to update it from Linux or by booting from a flash drive.


Go here, download your firmware ISO, burn to a flash drive, and boot from it. I’m about to try it right now (found out they released a firmware update).


Unfortunately, the damn thing won’t boot…I tried using this method as well, but that one isn’t detecting the (only) SSD, presumably because it’s not unmounted…


I’m an idiot and figured I could just dd it onto the flash drive. I used Unetbootin but now it’s just failing to boot (at least it attempts to boot now, though).


After looking around a bit, I found this thread where it seems that “No supported SSD found” (which I saw using the link in [Edit1]) happens because my SSD doesn’t qualify for the upgrade (apparently it fixes issues that don’t apply to my serial number or something).

So yeah. Final verdict: Unsupported method in [Edit1] should work but didn’t in this case because my SSD doesn’t actually need that update.


is there a way to update the SN850 firmware with linux?
Or is the only possibility to install windows first, update the firmware and install linux after that?

No, there is no way to update the WD firmware without Windows.

There are various ways you can install Windows to a (large) USB stick or expansion card.

1 Like

@Fraoch It looks like that the Qemu-method is gonna be the best bet for me.

It makes me wonder, Is there a Windows PE .iso floating around for framework users that need WD firmware help? If not, why? According to Hiren’s Boot CD staff, distributing windows PE isn’t against Microsoft’s TOS.

Does Windows PE run a GUI? That’s what the WD Dashboard firmware updater requires.

The BIOS updater only needs a command line and this can be run from the Windows installer, but WD Dashboard can’t.

@Fraoch As far as I understand yes, Windows PE does run with a GUI. Hiren’s boot CD is a version of windows 10 PE with various diagnostic tools.

Well anyways, I got good news! My framework laptop is now working, just not in the way I initially wanted it, but it’s working and that’s good enough for me.

I went through the process of getting a windows 10 .vhd file working on a large microSD card, installed WD Dashboard on the windows machine, and it turns out. the firmware was up to date. this issue was not an issue with the WD disk.

Then I remembered something: I don’t think I managed to actually install void linux, and left it for others because I was frustrated and impatient with it. So I took my time, actually RTFM (or in this case RTFD), got void linux installed and holy crap it actually works!

So, well, turns out the issue I think is that something about the isos I got had versions of linux that were not compatible with my hardware. TL:DR Void linux works.

1 Like

could it be that with newer bacthes the WD 850 already has the firmware installed? does somebody with newer batches had this experience?

1 Like