Fresh Install of Fedora 36 and Ubuntu 22.04 persistant stuttering issues

(11th Gen Intel laptop)
The issue:

Persistant stuttering or frame drops/skips despite new installation of Fedora or Ubuntu. The strangest thing is that for the first few days the stutters aren’t there. It almost seems random. Of course after a few days/weeks the the stutters appear and don’t go away. The only solution I’ve found is to just do a re-install. A few days ago I moved from Ubuntu to Fedora after restarting everything seemed fine, animations were smooth and videos played correctly, no problems with input lag from keyboard either. However, shutting down for the day, the next day the problems reappear. One other solution is to install Windows, there is usually no stutters, but I prefer to use Linux (don’t like wsl2). Also to note, I installed Ubuntu about a month ago, and for ~3 weeks everything was smooth. I thought the problem had been fixed. Until just a few days ago. I am unsure how to diagnose this problem.

Visual problems:

  • Keyboard key presses delay, visual lag. (tried on bluetooth keyboard too)
  • Videos played in firefox or gnome-videos/mpv, Stutter
  • Non fluid animations moving between workspaces or generally manipulating windows

What I’ve tried:

  1. Installed Fedora & Ubuntu and only updated and installed basic additional packages (intel-media-driver for hw accel, emacs, vscode etc).
  2. Installed BIOS 3.10
  3. Before writing image to USB thumb drive, I checked for file integrity of fedora and ubuntu images. Both passed.
  4. Tried in Xorg and of course Wayland for the Gnome DE
  5. Currently on Kernel 5.18.16, tried to downgrade to other kernels but that didn’t solve it.
  6. Disabled PSR (stutters persist on laptop screen & monitor)
  7. Power settings set to performance

My Hardware:

4K monitor as main display through usb-c (I’ve disabled laptops built-in screen)
SK hynix Gold P31 SSD

Finally, thanks for creating and providing this excellent community. I’ve been able to solve some issues on the laptop previously, and thankfully the hard work from the developers at framework and contributions to the various distro’s continue to improve the user experience.

Hopefully I can find a solution to this (need to get back to work :slight_smile: ) Also if you are not having this issue and are on Linux what distribution are you using? Or perhaps DE/WM? Also I’m not sure if using an external monitor changes things. In any case the problem is still there whether I’m on laptop display or ext. mon.

Thanks any one for you kind help

1 Like

No issues here on Linux Mint 20.3 (based on Ubuntu 20.04) and Linux Mint 21 (based on Ubuntu 22.04). Linux Mint only uses

I have it after suspending the Framework laptop after PopOS 22.04 LTS, the keyboard froze but the touchpad worked. Shutting down and turning it on didn’t work.
Using the touchpad I restarted the Framework and got into the Gnome desktop after 2 attempts.

The stuttering keep returning especially when I was using the touchpad.

I went into the Gnome Control panel and changed the resolutions to another and back again and set back fractional scaling and now it works ok?

I have no idea what I did but it resolves the issue.

In dmesg, there is an error that keeps appearing: Can’t update stage views actor MetaWindowGroup is on because it needs an allocation.

Could be related to this and the resolution?

Not sure how helpful this is.