FW 13 amd 7040 first boot no display no leds

just got my new 13 got the amd 7040 ive installed my memory and nvme and ive put it all together and the splash screen wont come up the display just hasnt lit up
ram: cricial 2x8gb 5200 mhz CT2K8G52C42S5
ive reseated ram
ive unplugged and replugged the battery
ive tried outputting to an external display(didnt work obviously)
ive tried both ram stick separately to no evail

That RAM is incompatible, 5200 doesn’t seem to work, there are a lot of forum posts about it. Most people had luck with 5600, which is also the speed of the official RAM.

1 Like

thanks i figured that was the issue id seen mentions on that but didnt know how consistent the issue was but ive ordered a pair of 5600 versions and ill send the 5200’s to return thanks for the help much appreciated :slight_smile:

Also make sure your wifi chip is fully seated. I had an issue with it not booting and I noticed the wifi card looked just slightly unaligned, possibly from when I was tightening screw, so I reseated it and pressed the back of it to keep it firmly aligned in the slot while I tightened down the screw. Booted right up afterward. Before that it was the power button lit but no output.