FW13 AMD and Jabra Evolve Link USB headset

I have a strange issue with my new AMD Framework 13 and my old Jabra Link USB headset:

After some (random) time (sometimes minutes, sometimes hours), the headset stops working: either by (a) ceasing to provide audio or by (b) Windows 11 telling me that the USB device malfunctioned. It happens both when I attach the headset directly to the USB A port (symptom (a), and yes, I used one of the two front docks) and when I attach the headset to a USB-C hub (symptom (b)).

It worked fine on my old notebook. So, yes, my first thought was that the headset must be broken and the timing (new notebook) is just a strange coincidence. But then I tried it with a second headset (same model), and the same problem occurred.

So, apparently, there is some “incompatibility” between my notebook and that particular brand of headset.

Any ideas on what to try? The headset drivers (Jabra direct) are installed, and both the drivers and the headset firmware are up-to-date.