FW13 external display black screen issue

I just received my prebuilt FW13 with an AMD Ryzen 7840U and Windows 11 (23H2) but I noticed that it will not extend or duplicate my display to an external display through USB C.

- When connected to an external display using a USB C to HDMI cable or a USB C dongle with an HDMI cable, the external display will connect, but will only show a black screen with a soft glow (indicating that the display is connected).
- With the external display USB C cable plugged in, Windows Display Settings and the AMD software that came preinstalled both show that the monitor is connected (monitor positions, extended/duplicate, display resolution, etc.) but the external display still remains black with a soft glow even when you hit the Identify Screen button.
- In Windows Display Settings I can switch from Extend or Duplicate to Second Screen Only and that will cause the external display to work! But if I switch back to Extend or Duplicate the external display will go black again but remain connected. This makes it seem like the laptop can only display one screen at a time.

- I have tried 2 USB C cards in the rear and front right ports that should work with display output (I only have 2 USB C and 2 USB A ports).
- The USB C cable and dongle work with other USB C laptops for display output.
- Restarting with the display connected and disconnected had no effect.
- Updating the drivers and to BIOS 3.03 had no effect, and uninstalling drivers had no effect.

Any ideas on how to resolve this issue?

Update: I got the 1440p, 165 Hz external display to work with Extend! Though the process was a bit odd:

  • In Windows Display Settings I switched between the external displays only frame rate options of 29 Hz and 30 Hz at 1440p but neither worked.
  • I then switched to 1080p at 30 Hz but that also didn’t work.
  • I then switched to 1080p at 60 Hz and that worked!
  • I then switched back to 1440p but at 60 Hz and it still worked!
  • Now the only frame rate options for 1440p are different than before: 72 Hz, 60 Hz, and 50 Hz, but 72 Hz does not work.

Hope this helps anyone with a similar issue!