Gaming Throttling

I’ve tried some different combos over expansion cards, locations on the board, as well as bypassing the expansion card and plugging in directly (which didn’t seem to work for some odd reason).

I’ve also limited the frames for certain titles, but nothing has really made a dent so far.

Alright, the emotional rollercoaster continues.

With the help of support, I tried a new driver and also bypassed the expansion card to plug directly into the board for power. Currently, it’s not throttling in best performance mode! I played for an hour or so without issue. It did drain the battery by about 27% during that session, but one battle at a time.


What was this new driver? Something from AMD or somewhere else?

I tried a couple different options - this one was the driver that the auto-detect tool from AMD gave me. Ultimately, it still throttled hard before long.

I’ve been having issues with the 24.02.01 driver from AMD on my desktop…so I think its not specifically a FrameWork issue…

Hey, just wanted to throw my 2c into the pool:

I haven’t encountered any sort of battery switch/hard throttling behavior you’re describing here, but I have noticed that my battery drains by a fairly significant amount during what I would consider to be moderately heavy loads. Example: playing Subnautica for 20 minutes drains about 9% total capacity from the battery. On average, the CPU is drawing ~30w and the GPU ~90w, and the battery is discharging at around 15w. (I’m getting those numbers from “CPU Package Power”, “Total Graphics Power”, and “Battery Charge Rate” respectively on Hardware Info. If those are not the right entries for me to be looking at, feel free to correct me.)

To be honest, I’m a little sussed out by those numbers and wonder if maybe my laptop isn’t actually drawing a full 180w from the brick. The math doesn’t really math, ya know? 90 + 30 + maybe another 30 for the rest of the system should still put me well shy of the 180w power limit. On the other hand, if something wonky happened to the USB PD configuration and the laptop is only drawing 140w from the brick… suddenly that explains why the battery discharges like it does. I’ll be watching the first few BIOS and Driver updates closely to see if one of them addresses battery/power issues. Otherwise, I’ll definitely be grabbing a 240w brick the moment a company releases one to see if that addresses the power drain.


You should get a kill a watt to check.

Bear in mind, there will be losses at all stages. The 180 watt supply itself will have to convert from AC to regulated DC. My FW 60 watt power supply measures at 92-93% efficient, which is pretty darn good. If the 180 watt charger is similar, expect it to draw around 195 watts in order to supply 180. Then that 180 watts, delivered at 36V, will have to get converted in the laptop, resulting in some loss as well. That loss means that there won’t be the full 180 available for use by the computer. I don’t know how efficient that conversion process is.

Mostly, I just wanted to make sure people understand that a power supply rated to deliver 180 watts out, will draw a bit more than that. How much more will depend on its efficiency.

I was having this issue myself in starcraft 2. It may have been happening in other games too. However, it was the only game that I have played on it so far that was graphicly intensive. I noticed that the muk switch was not properly transferred from the Igpu to the DGPU. Starcraft ran off the IGPU, so I got 20-30 fps. Shockingly it was still rather smooth even though the game was set to high settings. I noticed this thanks to the program FPS monitor. I had to go into the AMD adrenalin software and change how the Muk switch functioned. I believe it has changed for every game now. but by default, it was not swapping to the DGPU for graphically intensive tasks. I don’t believe that this is a direct issue with Framework itself, as I have had the same issue with an MSI laptop running and Nvidia GPU as well. That is why I even thought to check what GPU was being used. I should also note that Starcraft was saying it was using the DGPU; however, an AMD setting was not letting it swap to that GPU. I feel like this issue could easily be resolved in a driver pack from Framework or AMD. So keep checking the driver pack page. I usually check it weekly.

Most I’ve seen mine pulling at the wall (240V) is 170W. That’s running a game and with the battery charging from 70%.

Just wanted to say I downloaded Ryzen master and Ryzen controller one of those fixed my throttling and made my cpu appear on adrenaline

1 Like

Did you ever figure this out? I started having a very similar problem recently. It happens on both windows and linux so I’m thinking it might actually be a hardware issue of some kind, though I’m not 100% sure it’s the exact same issue because it seems a little different. It only started happening like, this week though, and I can’t think of anything that would have damaged something. Might contact support soon if I can’t figure it out.

so yeah, after about half an hour or so (seems to be pretty random) fps will drop in half and checking nvtop tells me that the GPU is only receiving ~40W of power and the speed is only around 1300MHz, rather than the normal 2200MHz or so. A while ago there was a linux kernel issue causing a very similar issue, with the kernel not properly loading the amd-pmf driver, but that module is properly loaded so it’s not that. I’ll have to check power usage next time it happens in windows to see if it’s the same.

Also, GPU thermals are fine. CPU is running pretty hot but it doesn’t seem to be throttling. I don’t see how CPU temperature would make the GPU throttle, so it’s definitely not a thermal issue.

I didn’t end up keeping my batch 1 16, but I have recently purchased a used one and am ready to take another run at the platform. I’m hoping that between driver updates and the new bios there might be hope for stability, but it looks like some people may still be encountering similar issues.

The new–to me–machine will arrive sometime this week and I’ll be able to report back.

Well, After some more experimentation, I think it actually was a thermal issue. My room can get a bit warm at times and my laptop stand seems to block some of the intake (need to get a new one anyway). But yeah, GPU temps were fine but CPU temps were at like 98-100 when the issue hit. Set up a fan to blow air towards the laptop to help cooling and was able to play for ~75 minutes before I had any issues. Mind the time before this when I had the issue I only got 8 minutes in, and before that I got maybe 20 min.

Given the sudden drop in power usage, my current theory is that some kind of power management component is overheating and has to limit the amount of power it gives to the GPU. Probably close to the CPU given the very high CPU temp. I’ll keep experimenting if I have the issue again, but think this might’ve been it.

1 Like

Delighted to report that the second time’s been a charm for me. I’m assuming this used model that I purchased is also from an earlier batch, and the improvements are largely due to driver and BIOS updates, but basically none of the problems I had before are present now. It still borrows juice from the battery while gaming, but at a slower, more manageable rate than before.

I’m only a few days in, so I don’t want to jinx it, but I would also say that this machine has been supremely stable and more importantly, predictable for me, which is my favorite quality in a computer. I just want it to do what it’s supposed to do and not throw me inexplicable curve balls.

I’ve been playing Valheim, Helldivers 2, BF2042, and Overwatch 2, as well as using Premiere Pro (with 6k, open-gate files), Lightroom Classic, and Ableton Live 12. It’s getting along great with my TS4 dock and peripherals and been very well behaved away from the desk, on battery. So far, “it just works” and I couldn’t be happier.