Gaming Throttling

Hey friends,

I received my FW16 DIY (7940hs/7700s) yesterday and–overall–I’ve been impressed so far. I did have the initial issue of no video/display that I was able to resolve with some tinkering, and I’ve also experienced the disappearing secondary drive issue when coming out of sleep, but aside from that, I’ve enjoyed getting everything set up and dialed in.

Unfortunately, I’ve encountered a new issue when finally kicking the tires on some gaming with the machine. Once I dialed in my settings, the performance at 1440p/medium was pretty good at over 100fps in most games. However, after about 5-10 minutes of playing, my frames suddenly drop by 50%+ and things slow to a crawl. Eventually, the sound starts to distort as well.

According to hwmonitor, the GPU is pulling 85-100w and the CPU around 35w when I start playing. When the throttling happens, it drops the GPU wattage all the way down to 30w and the overall package wattage caps at 60w, around half of the the limit.

This throttling also seems to correlate with the battery percentage starting to drop. It seems like the load over saturates the 180w adapter, so the machine borrows a bit of juice from the battery to sustain (which I previously read Framework acknowledged as a possibility). Once that happens, it’s almost like the machine switches over to the power constraints of battery-only mode?

It happens faster with more demanding games like Battlefield 2042 and Hell Divers 2. I’m wondering if anyone else has done any semi-demanding gaming on their 7700s equipped FW16 and if they’ve encountered any similar issues.

I don’t want to ramble on too long, but it’s worth noting that I had a ThinkPad P16 that had a similar issue. The 230w power supply couldn’t keep up with the HX processor and RTX 5000 and would start to borrow from the battery under load. Once it did, it would throttle everything way down and the audio would start to distort, just like the FW.

Hoping I can get this sorted out. Thanks for the consideration!


Could be thermals. Have you checked temps before and after it slows down?

1 Like

They seemed within the normal range, GPU was around 70 C and the CPU, though initially spiking to 100 C, settled in around 90 C. These are the temps before everything gets significantly reduced a few moments later.

Hmm… spiking to 100c then settling back found to 90 sounds like it could be thermal throttling, but odd that the timing doesn’t match up…

Best way to say for sure is to plot CPU temperature and clock speed and compare them. Could do it for the GPU too, but it seems like that’s fine. Plenty of programs to do that with, I’d recommend open hardware monitor but up to you.

Is it possible to game without a battery? If the battery is drained during the process, this might contributes to the inefficiency of the power supply. If the computer takes the DC input directly to the power-hungry devices there are less dc-dc which means lower loss. If the battery is involved, two additional dc-dc circuits are involved, namely PD input to battery and battery to output, which means that the efficiency is lower.

This throttling also seems to correlate with the battery percentage starting to drop.

The heat power of the circuit is power*(1-efficiency), using battery like this might contribute to additional heating within the circuits that increase the temperature of the laptop, which makes the CPU and/or GPU easier to overheat.

ThinkPad P16 that had a similar issue. The 230w power supply couldn’t keep up with the HX processor and RTX 5000 and would start to borrow from the battery under load. Once it did, it would throttle everything way down and the audio would start to distort, just like the FW.

As I mentioned earlier in another thread

before non-removable(without opening the laptop and access its chassis) battery pack became mainstream, all laptops were capable of running full performance while charging the battery pack at full(at least half) speed on their factory-supplied power bricks, regardless of gaming laptop or not. When non-removable laptop battery becomes mainstream, laptop manufactures begin to cut cost on the power brick (and the internal PSU) because they assume the average users don’t run the laptop full performance without a battery.

Have you tried applying an FPS limit to your games?
If you normally see over 100, does the drop still happen if you limit to say 70 or 80 from the start? It might just push it off to a bit longer if anything at least.

I’ve been playing Darktide, though that game just stutters on everything and anything. It stutters on a 3080ti for me, so the 7700s drops to 30-40s all the time unsurprisingly. All the psykers doing their Palpatine chain lighting thing drags it down further if I’m in the middle of it… I’ve not had it fully throttle the GPU down however, with the in-game limiter set to 72 and the settings tweaked, I find my battery stays level or charged very slowly during gameplay sessions on average.
I use RTSS to set a global limit of 80, haven’t tried Helldivers yet, but I can see if I discharge while doing some drops later.

*Edit: I see you also have the 7940, I have the 7840. Not sure if that makes enough difference in power draw to cause the discharge issue, but it might.

1 Like

My gut says this is the laptop thinking it’s on battery power only, and thus kicks in the battery performance profiles, but I can’t know for sure. Mine just shipped yesterday.

1 Like

Some updated info, initially, I had my TS4 dock plugged into the back left port (one of the USB-4 compatible), and the power adapter plugged into the middle left port (one of the 240w power compatible). I thought maybe there was an issue with the port receiving the full power delivery, so I swapped to powering with the rear right.

It seemed to be working better, as I was able to play for 30ish minutes. The battery was dropping by 3-4% per round, but the wattage and frames were holding steady. Then, sadly, the mega throttle happened again and the system went down to a 30w cap.

Smol update: It seems that running things on balanced mode in windows takes enough of the edge off to maintain. I’ll be able to test it more later. Not the best long-term solution since you’re leaving about 25% of the performance on the table, but might be a decent option to limp by until 240w adapters hit the market.


What happens if you take off the TB4 dock entirely? Does the Dock do power delivery?

It does, up to 98w. As far as I know, it should take the highest power source available. Does anyone know if there’s a way to tell the details of the power source in Windows? I know it’s doable in first-party control software like Lenovo Vantage.

Not FW16, bug might related. I’m using an FW13 running Arch Linux. I set suspend on idle 10min on battery 1h on AC with battery charging limit set to 75%. When plugged in, the battery indicator often shows alternate between “75%, charging” and “75% discharging” when not in a gaming session. In addition to that, the laptop often suspends after 10min instead of 1h when running on AC.

My guess is there’s a miscommunication between the hardware and the OS, the OS believes that the computer is on battery when the battery is discharging.

I was able to force discharge during use last night, but I did not encounter a hard throttle. This was tested with the laptop both on max performance and balanced, with the stock 180W charger.
It could be the difference between the 7940 and the 7840 is just enough to cause this, or possibly other issues like increased thermal load leading to the throttle.

1 Like

I’m going to test Best Performance mode, bypassing the dock later. Maybe there’s something weird going on with the TS4.

What rate of battery usage were you seeing against those two settings? I thought I remembered hearing on an old Q&A something about throttling enough to not discharge the battery on the Balanced setting.

So far, it’s not doing the mega-throttle when I bypassed the dock. It IS draining the battery by about 30% per hour though. This is using best performance settings.


I didn’t measure the rate running full out. I have a general fps limit set via rtss at 80.
When at that and set for best performance, I dropped about 8-10% after a 30 minute run.

No drain when at balanced, it charged slowly actually.


Just wanted to update this a bit. I thought that I could duck the issue but just sacrificing some power and gaming in balanced mode, but unfortunately, it also depletes the battery (though at a lower rate) and still runs into the hard throttle after a few minutes.

It’s also doing it while not plugged into the dock, so that theory has also run dry.

1 Like

After a bit more testing, it doesn’t appear to triggering the hard throttle anymore (at least for now).

I have the laptop on a stand for better air flow and good lord, the bottom of the laptop on and around the USB C expansion card that the 180w charger is feeding is the hottest I’ve felt on a laptop. Like you can only leave your finger on it for a half a second hot. I can’t imagine what pushing 240w through it would do.

1 Like

Did you try to connect the charging cable directly without the expansion card? A hot expansion card could lead to more resistance in the circuitry, and a lower wattage delivered. Also try to swap the expansion card for another USB C expansion card/or USB C port. This should not get boiling hot (my opinion). This can be a faulty expansion card problem.

I take it you’re not trying an fps limit either, just running full tilt?

I do not have that hot expansion port issue. Could be a problem with that module like Marek said.