High Battery Drain During Suspend (Windows edition)

Yeah I am aware of that, I was commenting on it not taking long to resume because others had questioned or mentioned that S3 took a long time to resume from. I think they might have been thinking of a bug under Linux that caused S3 to take a long time to resume from when running Linux and a specific kernel. (Long time here being a few seconds instead of instant.)

1 Like

S3 is also relegated to “linux/legacy sleep state”, which I guess is what that is causing the issue.

I think it’s down the not-so-great support state for S3 sleep, as covered in one of Linus’ more recent videos.

How long is that?

I use hibernate which takes 7 seconds to save to ‘NVMe’
On my dual boot which brings up GRUB from hibernate I have the 7 seconds to load from NVMe ’ select ‘Windows’ another 2 seconds i.e. 9 seconds before password request.

S0 was a mess and took at least as long as hibernate

Windows Suspend (that’s sleep ~ right) a different matter with it’s ‘instant’ showing without having to log in. Is there not meant to be a login when waking from sleep?

So I haven’t had the issue in either of my laptops since I have stopped unplugging the laptop when it’s sleeping. It’s kind of annoying because I have to wake up the laptop before unplugging it and then put it back to sleep.

1 Like

I’d like to see where my Framework 12th-gen stands on this issue - I’ve experienced some of the same problems as many other users.

However this problem’s reporting methodology among users is all over the map, understandably. Perhaps it would be good to make a suite of specific scenarios and battery run-down tools we can all try so we can get consistent information?

I’d be happy to spend some time going through specific steps, even if it takes a long time, but only if there’s a way to aggregate such data into something useful for troubleshooting. Currently poring through the comments is a frustrating experience, it’s hard to know what is relevant, and hard to compare results to other users.

I’m happy to help with this but I’d be of limited use, it’s out of my area of expertise.

[I’m not very active here in the forums, apologies if this isn’t the right place to put this comment]

Cross-posting this solution here because it has completely stopped random fan ramp-ups when in sleep from turning the inside of my laptop bag into a furnace. Laptop Fan Ramping Up in Sleep - #15 by Mr_Darcy

@BJ_Kramer Would you be willing to test this on your 12th gen? I can confirm this fixes the issue on 11th gen i5, Windows 10 Pro.

1 Like

While it’s still not perfect, I recently discovered that Windows Phone Link is responsible for a lot of CPU usage in sleep. With Phone Link running and the laptop on a charger, as soon as it goes to sleep it starts overheating with the fans blaring. With Phone Link turned off, same setup, there is no fan noise at all.


@Be_Far that seems to have worked for me to prevent it from overheating and fans turning on.

I’m still not getting proper sleep though, and the culprit is the audio controller. Did anyone find a proper solution to this?

1 Like

Not sure if any of these issues are framework specific, but documenting anyway for anyone in the future.

  • Disabling Fx Sound removed the Intel SST problem (so far) and reduced power consumption to about a third
  • There was a weird temporary issue with find my device, only happened once
  • Quitting Phone link reduced power usage by ~20%, but it’s not something I’d want to do regularly.
  • Main culprit now is the C10.Unkown, which I believe some people mentioned earlier

I’ve managed to get it down to about 2%/hour, down from 12%/hour, which is acceptable. If anyone has any advice about C10 let me know.


Yup, both phone link and FxSound are horrible for battery…

1 Like

Ooh, thanks for this! I’ll test and report back.

Phone Link is notoriously power hungry, I use KDE Connect’s windows build to get around that. All of the clipboard-sharing and media functionality, significantly less battery usage.

1 Like

Out of curiosity, but how does one go about doing this? Is it a service, and if so what is the name, etc.

It’s a popular third party app some of us had, not a windows service. I just stopped using it.

Win 10
11th gen
USB-A, HDMI (modded & flashed w/ experimental FW), USB-C, SD Card Reader
Latest BIOS & Driver Package installed

With nothing plugged into the expansion cards, I will put my laptop to sleep before bed, and my laptop will subsequently drain down to nearly zero by the time I wake up.

Sleep study seems to suggest various USB things are the culprit:

This doesn’t make any sense, though. Nothing is plugged in except the expansion cards. The same problem occurs even with the HDMI expansion removed. Can someone help me understand what is going on here?

Thank you.

The laptop should go to hibernate after a drop of say 20 5%

Edited above text

If you use sleep you will run the battery down, see above

I’m not seeing such an option. Only S0 states are available.

I did skim this thread previously but was unable to identify an obvious or relevant solution, but there are also hundreds of posts/replies so it’s a little hard to parse useful or relevant details.

This is all especially strange considering that when I had a MBP for work, I could leave that thing asleep over 3 day weekends and it would still have juice when I’d go back to work. Unsure how Windows compares in that department though (I assume not particularly well).

Appreciate any help.

1 Like

[quote=“2disbetter, post:82, topic:4421, full:true”]
so the official answer there is No. S3 is not supported under Tiger Lake, and and S0 is what we have to work with.

Yes the default S0

Now search for hibernate in this topic


Why not just switch it off fully? With NVMe is only takes a few seconds to boot. Much quicker than having a flat battery in the morning.

BIOS battery permitting it will still boot up a week later. :smiley:

Yeah, I suppose I could just shut it off… but feels like I shouldn’t have to. :wink: It’s also a little annoying having to wait for everything to open back up from a cold reboot.

Enabling Hibernation made it “only” run down to 50% instead of 0, which is better, but still disappointing.

My hibernate doesn’t loose 1% over 24 hours so something in your set up is draining.

Windows 11 on Gen 11