How to Install EC Firmware on Model 13 with Intel 13th Gen (Solved)


I bought a model 13 laptop last year, and now that I’m somewhat settled into my apartment, I’ve started setting it up. Because the Intel Management Engine is now standard on every new CPU, I was looking into how to disable it before I use the laptop full-time. Although it can’t be done completely, the EC firmware helps remove some level of functionality to it. After I read this Reddit post:, I clicked on the link the first person provided: GitHub - FrameworkComputer/EmbeddedController: Embedded Controller firmware for the Framework Laptop. Unfortunately, it says the firmware is only available for the 11 and 12 gen models. What kind of workaround can I use then?

You already have the open-source embedded controller firmware installed on your machine. It runs on a separate processor that controls battery charging, power management, the keyboard, etc.

It does not do anything to disable or otherwise modify the Intel Management Engine.

The version on your computer is likely already identical to the version on GitHub, and compiling it from source and installing it yourself (or downloading a binary release) will not change that.


Despite the various unproven rumors and conspiracy theories claiming it’s spyware, I was hoping to have it removed to increase my security (as it’s been known for security vulnerabilities). Because this is a startup company that’s using relatively-new hardware, and I’ve learned to practice good op-sec over the years, hopefully having to live with it won’t affect me too much.

best defense is knowing your system, your network and the used OS.
There was a time where I literally felt at login if something was wrong.
But that only worked on systems/servers I had setup.
But I agree, the Intel ME engine causes me serious headache!