How-to reset keyboard keymap back to default?

I made some changes accidentally to my keyboard using Framework’s Via web interface ( But I have been unable to find a way to reset it back to default.

I started my search in Framework’s online guides, and they only have default keymaps for the numpad and macropad.

Does anyone know how to reset it back to default without reflashing the firmware? Or can someone screen capture their first/top layer that has the RGB English keyboard? I’m specifically unsure about the “Fn” key.
Currently I have set it to “Fn1(3)”, because I don’t see any other good options. Thanks!

Have you tried the Reset key? This is found under “Special”. I’m not certain what Via uses Reset for, annoying it doesn’t give the actual QMK keycode. It’s likely either EE_CLR, QK_BOOT, or QK_RBT. EE_CLR would reset the EEPROM / persistent memory.
~edit~ for anyone else who comes upon this, the Via “Reset” key is QK_BOOT, reset to bootloader.

I believe reflashing may not restore the original keymap. Via stores settings in persistent memory which may not be overwritten during a normal reflash.

If the Reset key in Via doesn’t work, then
you can use the qmk-hid tool to reset persistent memory with --eeprom-reset
GitHub - FrameworkComputer/qmk_hid: Commandline tool for interacting with QMK devices over HID

The Fn key would be the same for any keyboard variation or language. On layer 0 (zero) Fn would be MO(1).


Thanks for the help, i haven’t tried the reset key. That qmk-hid tool sounds promising. I’ll check it out.


Thank you so much, for all of your help. You are awesome!

1 Like

For future reference, you can set any key to reset the eeprom by selecting the desired key, selecting special, then using the Any keycode and type in QK_CLEAR_EEPROM then click confirm and press the key you just remapped.


Does this work for you in Via?
It certainly should, but for me, Via won’t recognize QK_CLEAR_EEPROM, nor the EE_CLR alias, as valid codes, and won’t let you assign them. There are a number of codes that Via just refuses to accept.

I never tried it, because setting one key back to MO(1) using the web app sounded a lot easier. Sorry I can’t help.

Oh I don’t need it myself, I was just looking for others to have an easy way,

It worked just fine for me via the interface.

1 Like

You’re right.
My other keyboard doesn’t allow it. Though it looks like only the full QK_CLEAR_EEPROM is allowed, the EE_CLR alias still isn’t accepted.

Great to know, Thanks!