[IN TICKET] Fingerprint device failure and really bad framework customer support


I am getting some kind of hardware error from the fingerprint device on my framework 12th gen laptop after updating to BIOS 3.06. Not exactly sure if they are connected, or just a coincidence.

Please see attached a photo from Manjaro, at the end. I have tried resetting the motherboard, checked all the connectors and the wire from the sensor to the trackpad and they all seem to be ok.

I have tried contacting framework support also but besides having one of the worst experiences ever, they were no help. They have asked me to re-do all the tests above while videotaping myself doing it. After dismantling my laptop several times and giving them all the photos and videos they asked for, over a period of about 1 week, at a rate of 1 email response per day, they are now insisting that it must be debree in the connectors (there isn’t). I was most bothered by their attitude where they do not actually look at the photos/videos they ask for, and act like it is not in my best interest to get this sorted.

Anyway, as I am not very familiar with linux driver errors, I am hoping someone might be able to explain the one I am getting. Also if anyone knows a procedure to reset the Goodix fingerprint sensor (besides the MB reset which I already tried several times) I would greatly appreciate it.

This is the only way I know of clearing the cache of the fingerprint reader. I’ve never used this script but it’s supposed to work. I don’t know about driver issues but you can check in BIOS if it is enabled there? It might have been reset after the BIOS update for some reason. Have you tried Fedora to see if it works there? It might just be a Manjaro thing.

1 Like

Thanks for the script. I’ll have a look. The fingerprint is enabled in the BIOS. Checked that several times, also toggled it a bunch of times with restarts in between.

The error is not just on Manjaro. I have only used that for customer support reasons. The issue is present in Windows 11 and on Archlinux. Plus the USB connection error really supports the point that its a hardware issue.

1 Like

If it really is a hardware fault and there is no connection, then there simply isn’t anything I or anyone else on the forum can help with. Especially since the terminal is spitting out Cannot enable. Maybe the USB cable is bad?. My suggestion is to politely ask to escalate the issue to a higher tier support person. @Twistgibber perhaps you can take a look at his ticket?

1 Like

Thanks for the help. Unfortunately the script you linked does not work in my case, which is to be expected given that the driver is not properly loaded.

My hope with this post is that someone might know about a reset option for the fingerprint, or some firmware flashing procedure. If not, seems like the hardware might need replacing.

1 Like

@meehien There really isn’t anything to reset except the storage/cache. Nor is there any way to get the firmware except by asking FW and I doubt they can legally give it to you.

This thread while not precisely the same, is close enough that I would consider it a hardware flaw. Escalate support.

1 Like

Thanks, the thread does look similar indeed. I’ll try the escalation route then. Hopefully I can reach somebody that is genuinely interested in fixing this. However, after a few days of running in circles with the customer support I am a bit disheartened.

I used to think that sending an engineer at home, something that big companies like Lenovo, HP, Dell, etc., do was wasteful. I see now that with them at least you get someone with proper knowhow to deal with problems. I would not be surprised if, in the long run, it ends up being more efficient.

1 Like

Hi @meehien

This is tier 3 Linux support. I located your ticket, I’ll reply there. Bear with me while I catch up on what has taken place thus far in the ticket. But I have the ticket now.

1 Like

@GhostLegion “Twistgibber” is not me, it’s simply a placeholder to avoid impersonation. @TheTwistgibber is the correct handle.

@meehien I’ve fully reviewed your inquiries into our Support team but it seems you continuously created new tickets which then had to be merged instead of just communicating on a singular thread, which complicated the troubleshooting flow. The agents were following our standard troubleshooting for your issue at which point you became argumentative. Our team has been nothing but professional and polite through the entire interaction via numerous ticket merges. I see nothing here that would constitute the terrible experience you are claiming.

@Matt_Hartley is our Linux Lead and will be taking this over to determine whether this is a Linux issue or a hardware fault, and will provide next steps. I kindly ask that you please treat him with a bit more respect than you have provided our other agents.


Thanks for picking this up. With regards to the ticket system. I simply replied to the emails I was sent, which I always thought is standard practice. I am not sure exactly why this triggered new tickets being generated.

With regards to the contents, I apologize if I came across as argumentative. However after being asked 4 times to open up my laptop to take the same pictures and videos you can perhaps realise why I was beginning to think I wasn’t taken seriously.

Might be that the whole situation was created because new tickets were generated every time. Would be happy to avoid this situation in the future if you explain the correct way to reply to a ticket.

Anyway, looking forward to a resolution to the actual problem related to the fingerprint sensor.