Issue with Cinnamon after screen lock?

I’ve been getting a strange display issue that I’m looking to narrow down and/or see if others have encountered it.

I’m running Linux Mint with Cinnamon on my FW16. Sometimes when my screen locks or my system goes to sleep, when I wake it up and sign back in, I get these extremely abstract designs that flicker heavily on my screen between the normal display:

If I restart Cinnamon (Alt+F2, r), the issue usually goes away. I’ve also restarted X11 (Ctrl+Alt+Backspace) as a solution and that has also worked, until my screen is locked again.

I have unplugged the connector to the LED display and reconnected/re-seated it, but still encounter this issue. Since a restart of the environment usually clears the issue, I don’t think it’s a display cable issue…

So my question here:
Is this an issue with Cinnamon, or perhaps Linux Mint, or is this some sort of deeper hardware issue?
I’m aware that there is no official support for Mint, but I wanted to see if anyone else has seen this issue. I may try live-booting into Fedora or something and seeing if this issue happens in there.

EDIT: I can provide some deeper info about what kernel I’m running, etc:
Kernel - 6.5.0-35-generic
Cinnamon version - 6.0.4
Mint version - 21.3

1 Like

Eventual (batch 16) FW16 mint user, watching.

There are several mint users on this forum. Much more experienced than I. Hopefully someone can help you.

I’ve been running the Edge version since I got mine without problems,
also I think there were some very similar looking problems with the AMD version of the FW13 on older 6.7 kernels.

Can you run a live system with Mint Edge or one of the official supported distros?

I ran a live system with Fedora with Xfce the other day and ran tests with screen lock and logging out and back in. I didn’t get any abstract designs during testing during then.
I may try spending more time in the live system and get more data.

Spent more time in a live boot with Fedora Xfce, having the screen lock from inactivity, manually locking, closing the lid, suspending and reawakening, and combinations of the previous.
Thus far I haven’t gotten any screen abstracting.

I also made a live boot of Mint Edge, got that running, and performed the same sort of testing and also did not get any abstracting.

I’ve decided to do a fresh Mint Edge install, and will see if I encounter the issue any further.

1 Like

It’s been a few weeks since my fresh Mint Edge install. I haven’t encountered the display issue since then. So if you intend on running Mint, be sure to install Mint Edge. Marking post as solved.