Laptop won't charge

i have an 11th gen framework (3rd batch i think). this week it stopped charging. Last week my laptop was fine, it charged when plugged in and was not acting strange. I always unplug the charger before closing it so my battery doesn’t drain while in my bag. When i pulled it out to use in class on tuesday it was dead. I thought maybe it went into that sleep state that linus talked about in his video. but when i plugged it in nothing. I have the Framework charger. I thought maybe the cable was bad so i got another type c cable and it didn’t charge. it wasn’t until today that i was able to get back to my laptop. I tried my roommate’s type c charger and nothing. its from lenovo so its not junk.

I tried opening up the laptop to see if there was something wrong and i couldn’t see anything wrong with it. i tried reinstalling the battery and it still doesn’t charge. idk how to go about diagnosing the issue. any ideas what could be wrong with it and how could i check?

Hi and welcome

Read up on a mainboard reset which is often a requirement of the RTC|CMOS battery, the rechargeable ML 1220, being depleted

Info on the ML 1220 to come

There’s a lot on this subject

1 Like

I’ll always say that you should contact support, as they will be a lot of help with diagnosis. If you want to do some extra testing while you wait for them to respond, make sure to test all four ports on the laptop, and try to plug a charger directly into the ports on the board as opposed to the type c expansion card. If that doesn’t work you can try resetting the mainboard, you can check the EMF shielding tape on the port, or you could try using a lower wattage chargers to see if those are able to be recognized by your system.

Ok i went through this and it now turns on and is charging. i’m 99% sure this was the issue but i won’t know for sure until i let the battery recharge fully. i’ll update tomorrow