Linux Mint 21.1 on the Framework Laptop

Honestly, and this is my approach to all distros - if it’s working and not going to be outdated/unsupported soon, I leave my working installs alone. I have a very happy install of Fedora 37 on a personal machine even though I work on Fedora 38 for example.

That said, we have not had time to properly vet 21.2 yet for community level compatibility. May be fine, outside of the known issues list here (some of which would give me pause).

But it “should” be fine. Just remember, backup first before trying anything and as always, clean installs always have a higher success rate than an upgrade path in my experience. Some will debate this, I’ve witnessed for over a decade as fact.

Tltr: If you feel strongly about upgrading and wish to do so, consider everything above and backup, backup and backup. :slight_smile:

1 Like

Golden rule of computing: one backup is no backups; two backups is one backup.

Also: test your backups before erasing anything.

1 Like

Bingo. Per a former TechTV personality I know.

“One copy and the orginal is a copy. Two copies in two locations and the original is a backup.”

This was pre-cloud, referring to a cloned drive and a tape backup (if memory serves me). :slight_smile:

1 Like

Thanks for all the advice. I did go ahead and install 21.1 in the hopes that it would allow me to apply the code as given here: https://github.com/FrameworkComputer/linux-docs/blob/main/LinuxMint21-1-Manual-Setup-12thGen.md

However, I encountered a similar issue as I did previously, getting this output (I assume an error someplace in there?). Screenshot attached:

In fact, I was never prompted for my password, which the install guide suggested I would be. What am I missing here?

Looks like one of Mint’s repositories is not cooperating. Try sudo apt update again to ping them and see if the error is persistant.

ok, problem solved. Just had to reboot first before attempting to apply updates. All good now, thanks for the help everyone.

2 Likes

Hey, need support help if anyone is able to assist.

My wife just got her Framework 13 factory second with the intel 11th gen, and every once and a while the desktop will crash on her. From what she’s showed me:

  • the screen goes black

  • all wireless devices from WiFi to Bluetooth disconnects

  • we think the OS sometimes suspends since on occasion the keyboard goes black, and power button blinks

If the computer doesn’t suspend itself, it takes 30 seconds or so for the desktop to return and for her to reconnect everything. If it does suspend, then she needs to press the power button to get back into it.

I’ve looked at error logs in the “Logs” app, and searched around with Google with nothing helping narrow this issues down. It’s intermittent and sometimes can happen multiple times per day, while other times it’s good for a week or so. Just need help trying to trouble shoot this, as I’ve gone though the Guide and did everything I could, but nothing helped remedy this problem.

Easy check: make sure there are no magnets near the left side of the keyboard. There’s a sensor here which detects a magnet in the lid. When the lid is closed, it goes to sleep. Magnets and other laptops can trigger this.

As for the OS, support would have you check against a live USB of Ubuntu or Fedora. If it occurs while running Ubuntu or Fedora you should request support. But Linux Mint should still work well, and for 11th gen, it may not even need an advanced kernel. An updated kernel may help, though, and on Linux Mint it’s very easy to install and run a 6.5.0 kernel.

No magnets near the Laptop when it happens. We just swapped out the RAM and SSD, as they are from her old laptop, and did a fresh install and walkthrough of the community guide and the issue still happened.

New bios just dropped for her framework so trying that to see if it fixes it, if not then installing Ubuntu, and if that still doesn’t fix it, contacting Framework Support.

Thanks for the advice, and I really hope this isn’t a hardware issue.

OK, was able to solve it. My wife likes to have her e-reader near her laptop when she’s working. And the weak magnet for the latch was enough to put it to sleep when she was moving it above her keyboard.

I am shocked with how sensitive the sleep sensor on the Framework 13 is, especially since her previous HP wasn’t having this issue. But I am happy to know that the laptop is fine.

2 Likes