Linux Mint on Framework

I haven’t seen anything specific to Linux Mint on Framework, so I thought I would post my first impressions and workarounds.

To get the AX210 working on install, install the “edge” ISO, which comes with kernel 5.11. It works out of the box.

On first update, the newer 5.11 kernel will break the AX210. To resolve this, find and install the 5.14 kernel using either apt-get or Synaptic. There’s an 5.14 OEM kernel. There are also several 5.13 OEM kernel versions, these might work - I have not tried them.

I haven’t tried the fingerprint reader yet, I’ll tackle that later.

In regards to display scaling, I don’t like the look of “Automatic (2x)” or “Double (Hi-DPI)” (which looks the same as “Automatic (2x)”). I tried fractional scaling and 150% or 125% had a good size but the text was fuzzy. What I find is a good compromise is to set it to “Normal” or 100% scaling and adjust the default font, icon and panel sizes accordingly. Text scaling factor also helps, I have to research the difference between keeping the font sizes small vs. setting text scaling to 1.2, 1.3, 1.4 etc.

I’m using QRedshift to control the screen brightness and colour temperature. 6500K/100% in the day, 4000K/70% at night. That takes care of the pinkish cast some say the panel has, although I did not notice it.

So, really, everything just works. I keep reading extensive workarounds to get the newer hardware working and I didn’t need this or never encountered it. Just use that 5.13 or 5.14 kernel and everything seems to work!

Finnicky items I’ve seen mentioned that I tested and work fine:

  • AX210 wireless
  • Bluetooth
  • second monitor over a dock, HDMI or VGA
  • wired networking over a dock, 2.5 GbE (through a USB 3.0 adapter) or Gigabit in the dock
  • suspend, on timeout or with the lid closing

The only thing I tried that does NOT work is a third monitor over a dock. I cannot get an HDMI and a VGA monitor over a dock working simultaneously. It just seems buggy but the situation may improve. It’s minor in the grand scheme of things.

7 Likes

Thank you for recommending the Edge installer. I initially used the regular 20.2 installer and had the same failure with no WiFi. Not sure if I want to mess with kernel versions since Linux Mint 20.3 is supposedly only a couple months away.

Given that Framework is a Mint sponsor, I hope the Linux Mint team will give some attention to making the next installer work automatically.

2 Likes

Great!

Watch that first update, it will update you to a 5.11 kernel which had buggy AX210 implementation and you’ll lose your WiFi again. But they’re updating 5.11 at least once every two weeks, including this morning, so maybe there will be a 5.11 kernel which works with the AX210 again.

And, of course, you can always select your kernel on the GRUB boot menu. Just press and hold SHIFT right after the Framework logo. Select “Advanced options for Linux Mint 20.2” and select your kernel.

There’s a trick you can do via the command line to alter GRUB so it comes up without you holding shift and either waits a predefined number of seconds or indefinitely. Let me know if you would like to see this, but given how some don’t like the command line, I didn’t want to say it was absolutely necessary. It is nice though.

I heard mention in another thread how people were hesitant over the 5.14 OEM kernel. This is a really cutting edge kernel, but I have absolutely no problems running it. Just find it and install it, reboot, hold SHIFT on boot and select it. You only have to do this once. If you don’t like it or it doesn’t work for you, reboot and select a different kernel.

1 Like