[SOLVED] Linux Mint on Framework

EDIT: We now have an official guide! https://guides.frame.work/Guide/Mint+20.3+Installation+on+the+Framework+Laptop/110?lang=en

I haven’t seen anything specific to Linux Mint on Framework, so I thought I would post my first impressions and workarounds.

To get the AX210 working on install, install the “edge” ISO, which comes with kernel 5.11. It works out of the box.

On first update, the newer 5.11 kernel will break the AX210. To resolve this, find and install the 5.14 kernel using either apt-get or Synaptic. There’s an 5.14 OEM kernel. There are also several 5.13 OEM kernel versions, these might work - I have not tried them.

I haven’t tried the fingerprint reader yet, I’ll tackle that later.

In regards to display scaling, I don’t like the look of “Automatic (2x)” or “Double (Hi-DPI)” (which looks the same as “Automatic (2x)”). I tried fractional scaling and 150% or 125% had a good size but the text was fuzzy. What I find is a good compromise is to set it to “Normal” or 100% scaling and adjust the default font, icon and panel sizes accordingly. Text scaling factor also helps, I have to research the difference between keeping the font sizes small vs. setting text scaling to 1.2, 1.3, 1.4 etc.

I’m using QRedshift to control the screen brightness and colour temperature. 6500K/100% in the day, 4000K/70% at night. That takes care of the pinkish cast some say the panel has, although I did not notice it.

So, really, everything just works. I keep reading extensive workarounds to get the newer hardware working and I didn’t need this or never encountered it. Just use that 5.13 or 5.14 kernel and everything seems to work!

Finnicky items I’ve seen mentioned that I tested and work fine:

  • AX210 wireless
  • Bluetooth
  • second monitor over a dock, HDMI or VGA
  • wired networking over a dock, 2.5 GbE (through a USB 3.0 adapter) or Gigabit in the dock
  • suspend, on timeout or with the lid closing

The only thing I tried that does NOT work is a third monitor over a dock. I cannot get an HDMI and a VGA monitor over a dock working simultaneously. It just seems buggy but the situation may improve. It’s minor in the grand scheme of things.

EDIT: The Linux Mint 20.3 edge ISO is out. Kernel is now 5.13, which may have a problem with the wireless card, hopefully someone can confirm or deny. Before confirmation, install 20.3 edge with an Ethernet adapter or older wireless adapter ready and update the kernel.


Thank you for recommending the Edge installer. I initially used the regular 20.2 installer and had the same failure with no WiFi. Not sure if I want to mess with kernel versions since Linux Mint 20.3 is supposedly only a couple months away.

Given that Framework is a Mint sponsor, I hope the Linux Mint team will give some attention to making the next installer work automatically.



Watch that first update, it will update you to a 5.11 kernel which had buggy AX210 implementation and you’ll lose your WiFi again. But they’re updating 5.11 at least once every two weeks, including this morning, so maybe there will be a 5.11 kernel which works with the AX210 again.

And, of course, you can always select your kernel on the GRUB boot menu. Just press and hold SHIFT right after the Framework logo. Select “Advanced options for Linux Mint 20.2” and select your kernel.

There’s a trick you can do via the command line to alter GRUB so it comes up without you holding shift and either waits a predefined number of seconds or indefinitely. Let me know if you would like to see this, but given how some don’t like the command line, I didn’t want to say it was absolutely necessary. It is nice though.

I heard mention in another thread how people were hesitant over the 5.14 OEM kernel. This is a really cutting edge kernel, but I have absolutely no problems running it. Just find it and install it, reboot, hold SHIFT on boot and select it. You only have to do this once. If you don’t like it or it doesn’t work for you, reboot and select a different kernel.

1 Like

Just an update - I noticed there was a newer kernel, 5.14.0-1005-oem so I installed it and everything I could find related to it.

It works fine too. No improvement that I could find, but no malfunctions either. :grin:

Fraoch keep the updates coming :slight_smile: I was going to hold off until summer for the next Mint release. I appreciate your scouting the path!

1 Like


Well 20.3 is coming by Christmas. I’m guessing the default kernel will be 5.11 by then, and bug-fixed versions should support Framework’s AX210 out of the box. Also by then there will be better-tested, better-supported, better-tweaked 5.14 kernels available.

I was a bit intimidated to use newer kernels, but I needed 5.11 in my desktop and it’s worked very well. Now I’m finding that an even more bleeding edge 5.14 works well in Framework. Perhaps it doesn’t have all the performance tweaks since people have pointed out my bechmark scores are low, but I wouldn’t have known that otherwise. And if you ever have an issue, reboot, hold Shift, select “advanced options” and pick a previous kernel.

Hi there! Writing this from my Framework with Linux Mint 20.2 and the 5.14.9-051409-generic Linux kernel installed for wi-fi/bluetooth compatibility. My laptop doesn’t wake from sleep properly both when it times out or after I open the lid - just a black screen, even after switching workspaces or using Ctrl + Alt + Backspace to refresh the desktop environment GUI. Would you happen to have any tips for me? Do I need to install a driver for the integrated GPU or something? Googling returned several threads of similar problems, but none of the solutions there helped. As far as I can tell, the swap partition is set up fine.

I’m a Linux newbie - enjoying the experience a lot so far, though this problem has been stumped me more than the rest.


Sorry to hear you’re having problems. I’m using a different kernel, 5.14.0-1005-oem although 5.14.0-1004-oem worked fine for me too.

I found this package in Synaptic looking for “image” and scrolling down through the “linux-image” listings, marking and installing all packages matching “5.14.0-1005-oem”.

After you install this, reboot and make sure to boot from the new kernel in GRUB by pressing and holding Shift then selecting “Advanced options for Linux Mint 20.2”. If you miss this screen, there’s a trick you can set in the GRUB configuration, let me know if you want to see this (you’re setting timeout to a longer time or -1 to wait forever).

I see you’ve looked for additional drivers. I looked there too (“Driver Manager”) but didn’t find anything. I believe they’re built in.

So try installing the 1004-oem or 1005-oem kernel and its associated packages. Hopefully that does it for you!

Second edit: their version number has been changed to “5.14.0-1004.4” and “5.14.0-1005.5” but the package name remains “linux-image-5.14.0-1004-oem”, etc.


Thanks for the post. It was so disheartening to have everything working on first boot and then break after updating! I even tried switching back to the 5.11.0-22 kernel and still the wireless would not initialize. I wonder what was upgraded that broke even when running -22.

At first blush I’m happy with the resolution set to 1600x1024, which I believe means the display is doing the scaling so it should be effortless for the OS. This seems pretty ideal, am I missing the downsides?


There was a regression in the kernel, early 5.11 kernels supported the AX210 well but there were errors in later kernels. Those errors were carried over to certain 5.12 and 5.13 kernels too. Some work, some don’t. The errors were mostly corrected in 5.14.

Regarding resolution, that should work? I’ve never tried it. I do notice when you enable “experimental” fractional scaling the main settings screen reports “effective resolution X x Y” so I suppose it’s equivalent.

It’s the linux-firmware package. When that updates, it breaks the wifi for kernel 5.11. You’ll have to move a file:

sudo mv /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm.orig

And after a reboot, it’ll be fixed. However - newer kernels require this file to be there, so you’ll have to move it back if you want it to work on anything higher than 5.11.


Since battery life with Suspend is not great (the one thing Apple really does right), I did some searching and found a thread on enabling Hibernation in Mint 20.2. Hibernation should preserve the state of your applications when the laptop is not being used without draining the battery.

Enabling Hibernation in Linux Mint 20.2

I followed Adam_Halverson’s directions in the linked thread. Now when I select Shutdown from the Mint menu, the Hibernate option is available (alongside Suspend, Restart, Cancel, and Shut Down)

Adam_Halverson’s directions tell you to start by resizing your /swap partition to be twice your RAM size. I used gparted to resize mine to 64 GiB.

Hopefully, my Framework will hold a charge for a week or two now without being shut down.


@Eph, I may try that, thanks!

Update: there’s now a 5.14.0-1007-oem kernel and it works just fine too.

1 Like

How to Hibernate-After-Suspend
Coming back from Hibernate takes several seconds longer than waking from Suspend. Mint has settings so that, if you don’t wake up from Suspend after a preset time interval, it will drop into Hibernate mode and save the battery.

I wanted Mint to Suspend when I shut the lid, but drop into Hibernate mode if I don’t wake the computer up for 5 minutes. This gives me time enough for my typical use case where I close up the laptop to move to another room.

The process isn’t super obvious, but I pieced it together and the steps aren’t too bad…

Step 1: In Preferences/Power Management set
When the lid is closed (On battery power) to Suspend
(You could also set it for the On A/C Power case)

Step 2: In Preferences/Power Management turn on
Enable Hibernate after suspend
(You can close Power Management preferences now)

Step 3: Next we need to edit the system file sleep.conf which requires us to work as the root user. Launch Terminal and type the following two commands:

sudo -i

(You’ll be prompted for your password)

xed /etc/systemd/sleep.conf

This will open sleep.conf in the xed text editor.

Step 4: In xed, add this line to the end of sleep.conf:


Step 5: Save sleep.conf and quit xed.

Step 6: In Terminal, drop out of superuser mode by typing:


Step 7: Restart the computer.

After you reboot, closing the laptop lid will put the computer into Suspend mode and, if not awoken for five minutes, it will drop into the power saving Hibernate mode.


Got my laptop :slight_smile:

Mint (Edge) install took less time than the wifi chip install. No issues at all. Wifi worked out of the box, and continues to work after updates.

I am not having luck with hibernate. From google, I’m seeing the swapfile can be set inside of Mint (using fallocate and mkswap) OR it can be done through a ton steps messing with hard disc partitions. Seems like the former works, but… still no hibernate. Do I actually need to go through gparted tweaks?

Fingerprint reader isn’t working. Not really stressed. Battery is reporting 8 hours. Set some tlp settings, but haven’t had time to confirm everything is working yet.

1 Like

My reading suggested that swap could be done as a file instead of a partition, but I did not pursue that. What I am sure worked was using a dedicated swap partition.

If you have a swap partition, it’s not hard to resize to the required size. Just boot from the USB stick you installed Mint from, and run gparted from the thumb drive. You probably have to shrink another partition to free space to enlarge the swap partition.


I get leery about unnecessary partition-shifting. It puts me in a place where I can pretty easily brick something (speaking from experience).

I did a little more googling and found these instructions:

which let me set up hibernation using a file with no issues. (It did require tweaking the UEFI secure boot settings, which I thought I had done, but apparently not.) There’s also a link for doing it via partition if the instructions provided earlier in this thread don’t work.

Now onto the fingerprint reader!

1 Like

New-to-Linux user, do I need to re-make my boot USB with the edge ISO, or has that issue with the AX210 been fixed? Didn’t think to look here before making the boot USB.

If you’re not using the edge ISO, the wireless won’t work. Support is built into the kernel. The “regular” LM 20.2 ISO has a kernel that won’t work. It was built into the ISO at the time of the 20.2 release, so this won’t change. The kernel in the edge ISO will work until you update it, then it won’t. So while you’re updating it, install the 5.14.0-1007-oem kernel and pick that on boot.

I don’t think that will change when 20.3 is released in a few weeks, I’m guessing it’s using a 5.11 kernel and the latest versions of those won’t work. But by then there will be more advanced 5.15 or maybe 5.16 kernels to try out.


As a note, I installed the Mint Edge ISO two days ago with no issues. I did do the automatic update, including the kernel to 5.13.0-21 and wireless continued to work with no issues. Fraoch’s previous posts on how to update the kernel to 5.14 are the best way to go. However, if you don’t mind the potential headaches of managing updates without the wifi card, you can try just updating and see if you’re as lucky.

*Assuming here you got with no vPro. If you have vPro you may have some additional complications to deal with.