Linux re-locate CPU

Hello, I having problem that if I re-located my Linux NVMe storage to new AMD CPU? I wonder if will work, just insert into CPU and can be boot up? Is it not same of case Windows 11?

Drivers are built into the kernel in Linux. You should be able to move the SSD over without any issues if the kernel is new enough.

Windows is very different and you have to load drivers specific to your hardware. If the SSD won’t boot in the new hardware then you will have to find some other way to load the drivers.


There should be zero problems with Linux, unless you’ve build a custom kernel to support specific hardware, or anything like that.

Windows doesn’t really like it if the hardware changes. Not only could you get problem with Windows activation, but most often it will simply refuse to boot because device drivers have changed drastically. A reinstall is often the better solution here. But it might work if switching between very similar laptops like from the Framework 12th gen Intel to Framework 13th gen Intel.

Did that with my daughters Slimbook AMD CPU, to Dell Intel i5 CPU.
It was, as if nothing had happened. Just worked out of the Box :wink:
Just make sure you install the latest HWE kernel or else the AMD cpu may not be supported correctly.

If you can install the drivers for the new system prior to switching the SSD over, then you may find that it will boot just fine. Beware of disk encryption though, if you have your disk encrypted, the keys are stored in the TPM chip of your old system. You should disable bitlocker before you switch over your SSD.

Windows has gotten quite good at this too these days. Unless you need some weird raid drivers or something it’ll basically just work and maybe gather up the drivers for the new hardware in the background.

For Linux, I would say just try it and see. It is very likely to just work. If it does not work, come back here and you will get help.
Whether it works or not is down to something called the “Linux Kernel”.
The more recent the kernel, the more likely that it will work.

Windows 11 is also pretty good at moving, if bitlocker is disabled.
I have a Windows-to-go USB stick, made with rufus, and it works in all PCs I have tried it in so far.

Depending on how your distro builds their initrd archive, you might still be missing the modules needed to mount your root fs in initrd, in which case you won’t be able to boot.
Usually you can easily fix this from a live system though, and once you can mount your root fs in initrd, everything else should work without issue, as mentioned above.