Linux users: Use kernel >=5.13.10 to avoid WFi/BT issues

The Intel AX210 WiFi+BT card doesn’t work with kernel >5.13 (ironically after they had just baked in support in 5.11). So downgrade/don’t upgrade to 5.13 if you want bluetooth support.


Have any specific info on what the issue is or where I could read more about it, or is this anecdotal from your own experience?

There are a couple of refs here and there. I don’t know if an official bug report has been filed with the kernel devs yet.

Manjaro forums: Bluetooth via AX210 fails with Linux 5.13.4-1, but works with 5.12.19-1 - Support - Manjaro Linux Forum

Here’s a thread in the Arch forums too: Intel AX210 Bluetooth - nothing in hcitool / Kernel & Hardware / Arch Linux Forums


Did anyone file the upstream kernel 5.13’s Bluetooth bug to or find it there?

I am running 5.13.6-200.fc34.x86_64 on Fedora 34 and have not had any bluetooth issues with Bluetooth or Wifi. Just wanted to throw that out as a data point.


Working bluetooth on 5.13.7 kernel in arch linux

1 Like

Awesome! I’m trying now.

Hmm, @Anthony_Powell no dice for me. I had devices paired just fine under 5.12.15, but on 5.13.7 I’m still getting nothing from bluetoothctl, blueman, or the GNOME bluetooth interface. Did you muck with your kernel params or any other drivers?

@mbernhard hmm that is super weird… I did not do anything other than disable PSR. neofetch confirms that I am on latest kernel and bluetooth continues to work just fine.

1 Like



I assume a cold boot is also performed directly after a linux kernel upgrade? Might be why its working for me

Just tried a cold boot after upgrade, still no luck.

The only other thing I did pertaining to bluetooth was install bluez and bluez-utils , enable the bluetooth service, and try toggling bluetooth off and on, on the newest kernel. The only bios option I changed was legacy ps2 emulation to disabled but I doubt that has any effect.

1 Like

@Anthony_Powell did you install bluez-utils or bluez-utils-compat? I have the latter installed, I wonder if that’s my problem? I installed it as the regular utils didn’t seem to work, but now I might switch and see what happens.

Non compat afaik. I just did what the arch wiki suggested

Hey! I finally got it working this morning. I installed 5.13.8-arch1-1, replaced bluez-utils-compat with bluez-utils, and also removed setting the autosuspend kernel parameter to 0 and now it works!


@mbernhard what is this kernel parameter / what does it do?

I had set btusb.enable_autosuspend=0 as a kernel param following some advice here: 1589548 – Disable auto suspend for bluetooth USB dongle

1 Like

Welp, nope. I’m still periodically having this problem. After wake up I have no bluetooth. Weird.

Reverting back to 5.12.15 fixes it reliably.