Linux users: Use kernel >=5.13.10 to avoid WFi/BT issues

Strange, I’ve been running this for a while without issues. I do have to manually reconnect to my mouse or make it enter pairing mode briefly for it to connect again but I assumed that was an issue with my mouse

Yeah, after wake from sleep, bluetoothctl shows no device and GNOME offers me the option “Bluetooth Off: Turn off”. I’m too tired today to dig more, but I’ll try to tomorrow.

This is possibly fixed.

I’m running kernel version 5.13.7-200 and I have full WiFi and Bluetooth support. Tested using a Bluetooth headset. No latency or quality issues noted.

As a note, I did manually install the driver for this card as noted in [Guide] Install Intel Wireless Drivers on Linux.

Would someone be willing to try updating to help confirm this?

It seems finally fixed. 5.13.10 seemed to do the trick.

Edit: nope. After several reboot, somehow, I’m back to where I was.

Ah, I can finally confirm it’s the cold boot/warm boot problem noted here:


Besides being up to date, I’ve made no changes to my system, running 5.13.12-200.fc34.x86_64 (Fedora 34 Workstation) and haven’t noticed a single bluetooth issue.

Anyone running 5.14 yet? I’m tempted to build out a kernel just for kicks to see how it’s doing, but if there’s known breakage I might not bother just yet… :slight_smile:

I tried 5.14 on ElementaryOS 6, and WiFi/Bluetooth seemed to work fine but for me Sleep was broken. For the time being I went back to 5.13.13

@mbernhard if the issue is resolved, consider appending to the title of this thread to note the version # in which it was resolved, to save others’ time.

1 Like

Running 5.14.7 on Solus 4.3 here and everything’s working well. I had disappearing bluetooth issues with 5.13 but it’s been solid since updating.

@bmcdonnell I don’t seem to have edit permissions any more for the post. Currently running 5.13.19 and things seem stable (though now my mouse no longer works on wake from suspend, but that’s another story).

@mbernhard reading through this thread, it looks like 5.13.10 fixed this issue for you. I have updated the post’s title.

I’m running 5.14.7 on Arch, and I’m still having issues with my bluetooth disappearing after a warm reboot.

1 Like

That’s better than I did. I never managed to get it to work at all on anything but the 5.12 kernel series, which is a problem because 5.12 doesn’t contain the PSR fixes.

As I’ve mentioned elsewhere, my “solution” was to upgraded to 5.14 and use the wifi card from my old laptop. Once AX210 support matures I might switch back but until then I’ve got a fully working laptop, now.

Could someone explain how I can manually update the kernel on Ubuntu? I’m on 5.11-36 and things work, but I would prefer being on 5.13.10.

Thanks a bunch for anyone willing to take the time to explain.

@2disbetter I followed the command line method explained here: How to Upgrade to the Latest Mainline Kernel In Ubuntu Linux

1 Like

Hmm why is it that Ubuntu specifically doesn’t have 5.13.10 available?

@2disbetter that’s strange! My guess — Upstream Linux kernels 5.13.8 through 5.13.12 were released in quick succession, with only 3-4 days between them. Maybe the Ubuntu kernel maintainers didn’t have enough time/didn’t think it was worth the effort to patch and release all of them as separate Ubuntu kernels.

Is there any problems using the program Mainline (I’m not a programmer or anything, but I’m learning a great deal from all of these conversations.). I’ve tried it on a “play” computer but haven’t tested anything yet.

@P_bark Mainline is a good tool, but depending on your setup might not work. I don’t use it because I use full disk encryption with secure boot for my Windows install, and the kernels Mainline installs aren’t signed so they can’t boot.